Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1026349 - eclipse-swt: Crash in gtk_print_backend_destroy (libgtk-x11)
Summary: eclipse-swt: Crash in gtk_print_backend_destroy (libgtk-x11)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-04 13:39 UTC by Mikolaj Izdebski
Modified: 2015-12-07 21:21 UTC (History)
8 users (show)

Fixed In Version: eclipse-4.5.1-5.fc23 eclipse-4.5.1-5.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-07 20:29:03 UTC
Type: Bug


Attachments (Terms of Use)
JVM crash log (112.12 KB, text/x-log)
2013-11-04 13:40 UTC, Mikolaj Izdebski
no flags Details
crash log (120.76 KB, text/plain)
2014-11-13 10:38 UTC, Mikolaj Izdebski
no flags Details

Description Mikolaj Izdebski 2013-11-04 13:39:44 UTC
Description of problem:
Azureus segfaults in function gtk_print_backend_destroy() from libgtk-x11, called by SWT.

Version-Release number of selected component (if applicable):
4.3.1-10

Steps to Reproduce:
1. mock -r fedora-rawhide-x86_64 init
2. mock -r fedora-rawhide-x86_64 install azureus xauth
3. mock -r fedora-rawhide-x86_64 shell "adduser me && su me - sh -c 'export DISPLAY=$DISPLAY && azureus'"
4. when azureus window appears close it with File -> Exit

Actual results:
Segmentation fault when Azureus terminates.
# Problematic frame:
# C  [libgtk-x11-2.0.so.0+0x2fa747]  gtk_print_backend_destroy+0x3807

Additional info:
See attachement.

Comment 1 Mikolaj Izdebski 2013-11-04 13:40:28 UTC
Created attachment 819149 [details]
JVM crash log

Comment 2 Alexander Kurtakov 2014-11-13 10:25:57 UTC
Mikolaj, do you still experience this ?

Comment 3 Mikolaj Izdebski 2014-11-13 10:27:17 UTC
(In reply to Alexander Kurtakov from comment #2)
> Mikolaj, do you still experience this ?

I'll try to reproduce it now.

Comment 4 Mikolaj Izdebski 2014-11-13 10:37:10 UTC
(In reply to Alexander Kurtakov from comment #2)
> Mikolaj, do you still experience this ?

Yes, it is still reproducible.

eclipse-swt-4.4.1-7.fc22.x86_64
gtk3-3.15.1-1.fc22.x86_64

Comment 5 Mikolaj Izdebski 2014-11-13 10:38:02 UTC
Created attachment 957112 [details]
crash log

A fresh JVM crash log

Comment 6 Jaroslav Reznik 2015-03-03 15:11:08 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 7 Mat Booth 2015-11-28 11:16:52 UTC
I am not able to reproduce this since Eclipse was updated to Mars.1 on F22 or F23:

$ rpm -q eclipse-swt gtk3 azureus
eclipse-swt-4.5.1-5.fc22.x86_64
gtk3-3.16.7-1.fc22.x86_64
azureus-5.6.1.2-1.fc22.noarch

$ rpm -q eclipse-swt gtk3 azureus
eclipse-swt-4.5.1-5.fc23.x86_64
gtk3-3.18.2-1.fc23.x86_64
gtk3-3.18.2-1.fc23.i686
azureus-5.6.2.0-1.fc23.noarch

Azureus appears to shutdown normally.

Comment 8 Fedora Update System 2015-11-28 11:35:19 UTC
eclipse-4.5.1-5.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-216e0b2968

Comment 9 Fedora Update System 2015-11-29 00:53:58 UTC
eclipse-4.5.1-5.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update eclipse'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-216e0b2968

Comment 10 Fedora Update System 2015-11-29 10:46:28 UTC
eclipse-4.5.1-5.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-3984ff045b

Comment 11 Fedora Update System 2015-11-29 23:52:49 UTC
eclipse-4.5.1-5.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update eclipse'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-3984ff045b

Comment 12 Fedora Update System 2015-12-07 20:28:52 UTC
eclipse-4.5.1-5.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2015-12-07 21:21:14 UTC
eclipse-4.5.1-5.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.