Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1049528 - needs 'BuildRequires: python-cups, cups' to pick up postscriptdriver() tags
Summary: needs 'BuildRequires: python-cups, cups' to pick up postscriptdriver() tags
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: epson-inkjet-printer-escpr
Version: 20
Hardware: All
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Susi Lehtola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-07 17:07 UTC by Jiri Popelka
Modified: 2014-01-22 09:39 UTC (History)
3 users (show)

Fixed In Version: epson-inkjet-printer-escpr-1.3.1-1.1lsb3.2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-16 07:15:37 UTC
Type: Bug


Attachments (Terms of Use)

Description Jiri Popelka 2014-01-07 17:07:17 UTC
PPD files in latest version include IEEE 1284 DeviceIDs, which are necessary for automatic printer driver installation [1] to work. The last missing piece is 
'BuildRequires: python-cups, cups'

Also since Fedora-19, we've had a cups-filesystem subpackage which owns all the necessary directories, so you could also change
'Requires: cups' to 'Requires: cups-filesystem'

Version-Release number of selected component (if applicable):
epson-inkjet-printer-escpr-1.3.0-1.1lsb3.2.fc20.x86_64

Steps to Reproduce:
# rpm -q --provides epson-inkjet-printer-escpr

Actual results:
no postscriptdriver() tags

Expected results:
lots of postscriptdriver() tags

[1] http://fedoraproject.org/wiki/Features/AutomaticPrintDriverInstallation

Comment 1 Susi Lehtola 2014-01-07 17:20:40 UTC
Thanks for the report, fixed.

Comment 2 Fedora Update System 2014-01-07 18:00:33 UTC
epson-inkjet-printer-escpr-1.3.1-1.1lsb3.2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/epson-inkjet-printer-escpr-1.3.1-1.1lsb3.2.fc19

Comment 3 Fedora Update System 2014-01-07 18:00:46 UTC
epson-inkjet-printer-escpr-1.3.1-1.1lsb3.2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/epson-inkjet-printer-escpr-1.3.1-1.1lsb3.2.el6

Comment 4 Fedora Update System 2014-01-07 18:01:00 UTC
epson-inkjet-printer-escpr-1.3.1-1.1lsb3.2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/epson-inkjet-printer-escpr-1.3.1-1.1lsb3.2.fc20

Comment 5 Fedora Update System 2014-01-08 00:30:10 UTC
Package epson-inkjet-printer-escpr-1.3.1-1.1lsb3.2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing epson-inkjet-printer-escpr-1.3.1-1.1lsb3.2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-0083/epson-inkjet-printer-escpr-1.3.1-1.1lsb3.2.el6
then log in and leave karma (feedback).

Comment 6 lnie 2014-01-08 03:15:12 UTC
epson-inkjet-printer-escpr-1.3.1-1.1lsb3.2.fc20 works

Comment 7 Fedora Update System 2014-01-16 07:15:37 UTC
epson-inkjet-printer-escpr-1.3.1-1.1lsb3.2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2014-01-16 07:18:32 UTC
epson-inkjet-printer-escpr-1.3.1-1.1lsb3.2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2014-01-22 09:39:11 UTC
epson-inkjet-printer-escpr-1.3.1-1.1lsb3.2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.