Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1083853 - [abrt] WARNING: CPU: 0 PID: 1 at arch/x86/mm/ioremap.c:171 __ioremap_caller+0x2f3/0x3b0()
Summary: [abrt] WARNING: CPU: 0 PID: 1 at arch/x86/mm/ioremap.c:171 __ioremap_caller+0...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:3767652603c1158ea4a0336bae7...
: 1117392 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-03 05:55 UTC by Ilya Gradina
Modified: 2016-02-01 06:27 UTC (History)
26 users (show)

Fixed In Version: kernel-4.3.3-301.fc23 kernel-4.3.3-303.fc23 kernel-4.3.4-200.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-26 18:25:05 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: dmesg (106.92 KB, text/plain)
2014-04-03 05:55 UTC, Ilya Gradina
no flags Details

Description Ilya Gradina 2014-04-03 05:55:37 UTC
Additional info:
reporter:       libreport-2.2.0
WARNING: CPU: 0 PID: 1 at arch/x86/mm/ioremap.c:171 __ioremap_caller+0x2f3/0x3b0()
Info: mapping multiple BARs. Your kernel is fine.
Modules linked in:
CPU: 0 PID: 1 Comm: swapper/0 Not tainted 3.15.0-0.rc0.git2.1.fc21.x86_64 #1
Hardware name: LENOVO 23205NG/23205NG, BIOS G2ETA0WW (2.60 ) 03/05/2013
0000000000000000 00000000b651038b ffff880211b81ab8 ffffffff817d3c00
ffff880211b81b00 ffff880211b81af0 ffffffff81096aad ffffc90000cb0000
00000000fed16000 ffffc90000cb0000 ffffc90000cb0000 0000000000006000
Call Trace:
[<ffffffff817d3c00>] dump_stack+0x4d/0x66
[<ffffffff81096aad>] warn_slowpath_common+0x7d/0xa0
[<ffffffff81096b2c>] warn_slowpath_fmt+0x5c/0x80
[<ffffffff8109f8fc>] ? iomem_map_sanity_check+0xac/0xe0
[<ffffffff81060fe3>] __ioremap_caller+0x2f3/0x3b0
[<ffffffff810610b7>] ioremap_nocache+0x17/0x20
[<ffffffff8103cb24>] snb_uncore_imc_init_box+0x74/0xb0
[<ffffffff8103fb48>] uncore_pci_probe+0xd8/0x1b0
[<ffffffff81411065>] local_pci_probe+0x45/0xa0
[<ffffffff81412315>] ? pci_match_device+0xc5/0xd0
[<ffffffff81412459>] pci_device_probe+0xf9/0x150
[<ffffffff814fd875>] driver_probe_device+0x125/0x3a0
[<ffffffff814fdbc3>] __driver_attach+0x93/0xa0
[<ffffffff814fdb30>] ? __device_attach+0x40/0x40
[<ffffffff814fb5b3>] bus_for_each_dev+0x73/0xc0
[<ffffffff814fd1fe>] driver_attach+0x1e/0x20
[<ffffffff814fcda8>] bus_add_driver+0x188/0x260
[<ffffffff81f79cb5>] ? uncore_types_init+0x1a7/0x1a7
[<ffffffff814fe264>] driver_register+0x64/0xf0
[<ffffffff81f79cb5>] ? uncore_types_init+0x1a7/0x1a7
[<ffffffff81410a00>] __pci_register_driver+0x60/0x70
[<ffffffff81f79e2a>] intel_uncore_init+0x175/0x430
[<ffffffff81f79cb5>] ? uncore_types_init+0x1a7/0x1a7
[<ffffffff8100216a>] do_one_initcall+0xfa/0x1b0
[<ffffffff810c20c5>] ? parse_args+0x225/0x3f0
[<ffffffff81f6d232>] kernel_init_freeable+0x20b/0x2aa
[<ffffffff81f6c926>] ? do_early_param+0x88/0x88
[<ffffffff817c2c60>] ? rest_init+0x140/0x140
[<ffffffff817c2c6e>] kernel_init+0xe/0xf0
[<ffffffff817e78fc>] ret_from_fork+0x7c/0xb0
[<ffffffff817c2c60>] ? rest_init+0x140/0x140

Comment 1 Ilya Gradina 2014-04-03 05:55:42 UTC
Created attachment 882089 [details]
File: dmesg

Comment 2 Josh Boyer 2014-07-08 15:03:34 UTC
*** Bug 1117392 has been marked as a duplicate of this bug. ***

Comment 3 Tom Watson 2014-07-09 21:32:48 UTC
Description of problem:
At reboot.  I have NVIDIA drivers.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.2.2
cmdline:        BOOT_IMAGE=/vmlinuz-3.15.3-200.fc20.x86_64 root=UUID=71f5fa9c-a8f2-4cff-a12e-f53cd1729a04 ro rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8 rhgb quiet
kernel:         3.15.3-200.fc20.x86_64
runlevel:       unknown
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 0 PID: 1 at arch/x86/mm/ioremap.c:171 __ioremap_caller+0x2d9/0x3a0()
Info: mapping multiple BARs. Your kernel is fine.
Modules linked in:
CPU: 0 PID: 1 Comm: swapper/0 Not tainted 3.15.3-200.fc20.x86_64 #1
Hardware name: Hewlett-Packard HP EliteBook 8570w/176B, BIOS 68IAV Ver. F.06 08/15/2012
 0000000000000000 0000000076a88072 ffff8802320fbaf8 ffffffff816ef1f2
 ffff8802320fbb40 ffff8802320fbb30 ffffffff8108931d ffffc90000ca0000
 00000000fed16000 ffffc90000ca0000 ffffc90000ca0000 0000000000006000
Call Trace:
 [<ffffffff816ef1f2>] dump_stack+0x45/0x56
 [<ffffffff8108931d>] warn_slowpath_common+0x7d/0xa0
 [<ffffffff8108939c>] warn_slowpath_fmt+0x5c/0x80
 [<ffffffff81090348>] ? iomem_map_sanity_check+0xc8/0xd0
 [<ffffffff810569c9>] __ioremap_caller+0x2d9/0x3a0
 [<ffffffff81056aa7>] ioremap_nocache+0x17/0x20
 [<ffffffff81033564>] snb_uncore_imc_init_box+0x74/0xb0
 [<ffffffff81036508>] uncore_pci_probe+0xd8/0x1b0
 [<ffffffff8138e695>] local_pci_probe+0x45/0xa0
 [<ffffffff8138fa89>] pci_device_probe+0xf9/0x150
 [<ffffffff8145e3fd>] driver_probe_device+0x12d/0x3d0
 [<ffffffff8145e773>] __driver_attach+0x93/0xa0
 [<ffffffff8145e6e0>] ? __device_attach+0x40/0x40
 [<ffffffff8145c223>] bus_for_each_dev+0x73/0xc0
 [<ffffffff8145ddae>] driver_attach+0x1e/0x20
 [<ffffffff8145d960>] bus_add_driver+0x180/0x250
 [<ffffffff81d3ab0c>] ? uncore_types_init+0x1a7/0x1a7
 [<ffffffff8145edf4>] driver_register+0x64/0xf0
 [<ffffffff81d3ab0c>] ? uncore_types_init+0x1a7/0x1a7
 [<ffffffff8138e02c>] __pci_register_driver+0x4c/0x50
 [<ffffffff81d3ac81>] intel_uncore_init+0x175/0x430
 [<ffffffff81d3ab0c>] ? uncore_types_init+0x1a7/0x1a7
 [<ffffffff8100216a>] do_one_initcall+0xfa/0x1b0
 [<ffffffff810aa455>] ? parse_args+0x225/0x3f0
 [<ffffffff81d2e182>] kernel_init_freeable+0x190/0x22c
 [<ffffffff81d2d926>] ? do_early_param+0x88/0x88
 [<ffffffff816dfff0>] ? rest_init+0x80/0x80
 [<ffffffff816dfffe>] kernel_init+0xe/0xf0
 [<ffffffff816ff17c>] ret_from_fork+0x7c/0xb0
 [<ffffffff816dfff0>] ? rest_init+0x80/0x80

Comment 4 Jaroslav Reznik 2015-03-03 15:39:44 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 5 David Juran 2015-07-29 10:15:15 UTC
I'm running an un-tainted kernel 4.1.2-200.fc22.x86_64 and encountered this issue while booting machine.

Comment 6 Tobias Schönberg 2015-08-14 15:14:36 UTC
Encountered this bug when trying to search "base_site.html" on the whole system. After typing the first few letters the computer freezes.

Comment 7 Bojan Smojver 2015-10-09 23:49:55 UTC
Description of problem:
Boot on ThinkPad T450s.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.6.2
cmdline:        BOOT_IMAGE=/vmlinuz-4.2.3-200.fc22.x86_64 root=/dev/mapper/vg0-root ro rd.lvm.lv=vg0/root rd.lvm.lv=vg0/swap LANG=en_AU.UTF-8
kernel:         4.2.3-200.fc22.x86_64
runlevel:       unknown
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 1 PID: 1 at arch/x86/mm/ioremap.c:198 __ioremap_caller+0x2c5/0x380()
Info: mapping multiple BARs. Your kernel is fine.
Modules linked in:
CPU: 1 PID: 1 Comm: swapper/0 Not tainted 4.2.3-200.fc22.x86_64 #1
Hardware name: LENOVO 20BXCTO1WW/20BXCTO1WW, BIOS JBET53WW (1.18 ) 09/14/2015
 0000000000000000 00000000777b6cec ffff88023429ba78 ffffffff8177220a
 0000000000000000 ffff88023429bad0 ffff88023429bab8 ffffffff8109e4a6
 ffff88023429bae8 00000000fed10000 ffffc90000cc0000 0000000000006000
Call Trace:
 [<ffffffff8177220a>] dump_stack+0x45/0x57
 [<ffffffff8109e4a6>] warn_slowpath_common+0x86/0xc0
 [<ffffffff8109e535>] warn_slowpath_fmt+0x55/0x70
 [<ffffffff81065ba5>] __ioremap_caller+0x2c5/0x380
 [<ffffffff81065c77>] ioremap_nocache+0x17/0x20
 [<ffffffff81039bf9>] snb_uncore_imc_init_box+0x79/0xb0
 [<ffffffff810383a4>] uncore_pci_probe+0xd4/0x1a0
 [<ffffffff813e6055>] local_pci_probe+0x45/0xa0
 [<ffffffff8129a57d>] ? sysfs_do_create_link_sd.isra.2+0x6d/0xb0
 [<ffffffff813e724d>] pci_device_probe+0xed/0x140
 [<ffffffff814d0664>] driver_probe_device+0x1f4/0x450
 [<ffffffff814d0950>] __driver_attach+0x90/0xa0
 [<ffffffff814d08c0>] ? driver_probe_device+0x450/0x450
 [<ffffffff814ce12c>] bus_for_each_dev+0x6c/0xc0
 [<ffffffff814cfe6e>] driver_attach+0x1e/0x20
 [<ffffffff814cf9bb>] bus_add_driver+0x1eb/0x280
 [<ffffffff81d65149>] ? uncore_cpu_setup+0x12/0x12
 [<ffffffff814d11c0>] driver_register+0x60/0xe0
 [<ffffffff813e593c>] __pci_register_driver+0x4c/0x50
 [<ffffffff81d6521b>] intel_uncore_init+0xd2/0x2be
 [<ffffffff81d65149>] ? uncore_cpu_setup+0x12/0x12
 [<ffffffff81002123>] do_one_initcall+0xb3/0x200
 [<ffffffff810bbed1>] ? parse_args+0x271/0x4a0
 [<ffffffff81778600>] ? ldsem_down_write+0x170/0x199
 [<ffffffff81d571dc>] kernel_init_freeable+0x18e/0x228
 [<ffffffff81768950>] ? rest_init+0x80/0x80
 [<ffffffff8176895e>] kernel_init+0xe/0xe0
 [<ffffffff81778fdf>] ret_from_fork+0x3f/0x70
 [<ffffffff81768950>] ? rest_init+0x80/0x80

Comment 8 Justin M. Forbes 2015-10-20 19:30:54 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 22 kernel bugs.

Fedora 22 has now been rebased to 4.2.3-200.fc22.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 23, and are still experiencing this issue, please change the version to Fedora 23.

If you experience different issues, please open a new bug report for those.

Comment 9 Bojan Smojver 2015-10-20 20:26:51 UTC
(In reply to Justin M. Forbes from comment #8)
 
> Fedora 22 has now been rebased to 4.2.3-200.fc22.  Please test this kernel
> update (or newer) and let us know if you issue has been resolved or if it is
> still present with the newer kernel.

As you can see from the trace in comment #7, this kernel still has the issue.

Comment 10 scd 2015-10-24 13:30:42 UTC
Lenovo T440s with NVidia GK208M and Intel Haswell-ULT and GPUs.

The bug is present since upgrading to Fedora 22 -- with kernel version 4.1.10, I was able to boot w/o the panic occuring sometimes.
Since upgrading to 4.2.3, it occurs at almost every boot.

But, besides kernel being tainted, no ill effects up to now.

Comment 11 Bojan Smojver 2015-11-02 04:03:19 UTC
Still the case with 4.2.5-201.

Comment 12 acebond 2015-12-18 13:17:07 UTC
I've had the same issue on my ThinkPad E450
This patch here looks like it might fix it
https://lkml.org/lkml/2015/12/11/165

Comment 13 Yaniv Kaul 2016-01-04 09:59:45 UTC
Lenovo Carbon X1, with Intel Broadwell-U Integrated Graphics, running on 4.2.8-300.fc23.x86_64

Comment 14 Josh Boyer 2016-01-12 17:02:52 UTC
(In reply to acebond from comment #12)
> I've had the same issue on my ThinkPad E450
> This patch here looks like it might fix it
> https://lkml.org/lkml/2015/12/11/165

Thank you for the pointer to the patch.  It is now queued upstream as well and I've included it in Fedora git.

Comment 15 Fedora Update System 2016-01-15 19:25:09 UTC
kernel-4.3.3-301.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-26e19f042a

Comment 16 Fedora Update System 2016-01-17 14:23:05 UTC
kernel-4.3.3-301.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-26e19f042a

Comment 17 Fedora Update System 2016-01-19 12:54:41 UTC
kernel-4.3.3-302.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-db9fedd7c4

Comment 18 Fedora Update System 2016-01-20 12:15:01 UTC
kernel-4.3.3-200.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f71868ce66

Comment 19 Fedora Update System 2016-01-20 21:52:10 UTC
kernel-4.3.3-301.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2016-01-21 06:23:50 UTC
kernel-4.3.3-200.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f71868ce66

Comment 21 masterdead 2016-01-21 20:41:12 UTC
I have same problem on f23 with latest kernel 4.3.3-303.fc23.x86_64 which should contains patch. (Lenovo t440s with intel cpu/gpu)

WARNING: CPU: 2 PID: 1 at arch/x86/mm/ioremap.c:198 __ioremap_caller+0x2c5/0x380()
Info: mapping multiple BARs. Your kernel is fine.
Modules linked in:

CPU: 2 PID: 1 Comm: swapper/0 Not tainted 4.3.3-303.fc23.x86_64 #1
Hardware name: LENOVO 20AR001GXS/20AR001GXS, BIOS GJET86WW (2.36 ) 12/04/2015
 0000000000000000 000000006283e84d ffff880214a1baf8 ffffffff813a625f
 ffff880214a1bb40 ffff880214a1bb30 ffffffff810a07c2 00000000fed10000
 ffffc90000cb8000 0000000000006000 0000000000000000 ffff88021477c1c0
Call Trace:
 [<ffffffff813a625f>] dump_stack+0x44/0x55
 [<ffffffff810a07c2>] warn_slowpath_common+0x82/0xc0
 [<ffffffff810a085c>] warn_slowpath_fmt+0x5c/0x80
 [<ffffffff810a6fba>] ? iomem_map_sanity_check+0xba/0xd0
 [<ffffffff81065835>] __ioremap_caller+0x2c5/0x380
 [<ffffffff81065907>] ioremap_nocache+0x17/0x20
 [<ffffffff8103a119>] snb_uncore_imc_init_box+0x79/0xb0
 [<ffffffff81038900>] uncore_pci_probe+0xd0/0x1b0
 [<ffffffff813efda5>] local_pci_probe+0x45/0xa0
 [<ffffffff813f118d>] pci_device_probe+0xfd/0x140
 [<ffffffff814d9b52>] driver_probe_device+0x222/0x480
 [<ffffffff814d9e34>] __driver_attach+0x84/0x90
 [<ffffffff814d9db0>] ? driver_probe_device+0x480/0x480
 [<ffffffff814d762c>] bus_for_each_dev+0x6c/0xc0
 [<ffffffff814d930e>] driver_attach+0x1e/0x20
 [<ffffffff814d8e4b>] bus_add_driver+0x1eb/0x280
 [<ffffffff81d6af1a>] ? uncore_cpu_setup+0x12/0x12
 [<ffffffff814da680>] driver_register+0x60/0xe0
 [<ffffffff813ef78c>] __pci_register_driver+0x4c/0x50
 [<ffffffff81d6affc>] intel_uncore_init+0xe2/0x2e6
 [<ffffffff81d6af1a>] ? uncore_cpu_setup+0x12/0x12
 [<ffffffff81002123>] do_one_initcall+0xb3/0x200
 [<ffffffff810be500>] ? parse_args+0x1a0/0x4a0
 [<ffffffff81d5c1c8>] kernel_init_freeable+0x189/0x223
 [<ffffffff81775c40>] ? rest_init+0x80/0x80
 [<ffffffff81775c4e>] kernel_init+0xe/0xe0
 [<ffffffff81781adf>] ret_from_fork+0x3f/0x70
 [<ffffffff81775c40>] ? rest_init+0x80/0x80
---[ end trace 1e73e1a37dd5f055 ]---

Comment 22 Josh Boyer 2016-01-21 20:49:17 UTC
(In reply to masterdead from comment #21)
> I have same problem on f23 with latest kernel 4.3.3-303.fc23.x86_64 which
> should contains patch. (Lenovo t440s with intel cpu/gpu)

Please open a new bug.  The patch likely does not contain a match for your system.  In the new bug, please provide the full output of dmesg and the output of lspci -nnvv.
>

Comment 23 Fedora Update System 2016-01-22 04:58:30 UTC
kernel-4.3.3-303.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b59fd603be

Comment 24 Fedora Update System 2016-01-25 18:26:57 UTC
kernel-4.3.4-200.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5d43766e33

Comment 25 Fedora Update System 2016-01-26 04:22:32 UTC
kernel-4.3.4-200.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5d43766e33

Comment 26 Fedora Update System 2016-01-26 18:23:06 UTC
kernel-4.3.3-303.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2016-02-01 06:24:17 UTC
kernel-4.3.4-200.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.