Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1087047 - ImportError: No module named '' when starting
Summary: ImportError: No module named '' when starting
Alias: None
Product: Fedora
Classification: Fedora
Component: flumotion
Version: 20
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Sergio Basto
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2014-04-13 12:43 UTC by Zamir SUN
Modified: 2015-06-30 01:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2015-06-30 01:35:24 UTC
Type: Bug

Attachments (Terms of Use)

Description Zamir SUN 2014-04-13 12:43:40 UTC
Description of problem:
when I open flumotion, it cannot start with the error ImportError: No module named ''

Version-Release number of selected component (if applicable):
 flumotion                 x86_64      0.10.0-7.fc20

$ uname -r
$ cat /etc/redhat-release 
Fedora release 20 (Heisenbug)

How reproducible:

Steps to Reproduce:
1.Install Fedora 20 with XFCE, x86_64
2.sudo yum install flumotion -y
3.start flumotion-admin from the Application Menu or via the terminal

Actual results:
ImportError: No module named ''

Expected results:
it starts without error

Additional info:
I tried as the following
$sudo yum install pygtk2-libglade -y
and then 
the import error will not occur. So I think it is dependence issue.

FYI, However, even after these, I still get errors

  File /usr/lib64/flumotion/python/flumotion/ui/, line 54, in _flumotion_glade_custom_handler
    widget = widget_class()
  File /usr/lib64/flumotion/python/flumotion/admin/gtk/, line 64, in __init__
    self.connections.set_policy(gtk.POLICY_AUTOMATIC, gtk.POLICY_AUTOMATIC)
AttributeError: 'ObjectList' object has no attribute 'set_policy'

But I did not find any workaround to fix this issue. I just found a ticket on flumotion trac here and this may have not fixed in my opinion

Comment 1 Fedora Update System 2015-05-10 17:45:46 UTC
flumotion- has been submitted as an update for Fedora 22.

Comment 2 Fedora Update System 2015-05-10 17:46:35 UTC
flumotion- has been submitted as an update for Fedora 21.

Comment 3 Fedora Update System 2015-05-10 17:47:27 UTC
flumotion- has been submitted as an update for Fedora 20.

Comment 4 Fedora Update System 2015-05-12 20:37:50 UTC
Package flumotion-
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing flumotion-'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).

Comment 5 Fedora End Of Life 2015-05-29 11:33:28 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 6 Fedora End Of Life 2015-06-30 01:35:24 UTC
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.