Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1116162 - no sys/io.h included in glibc-headers on aarch64
Summary: no sys/io.h included in glibc-headers on aarch64
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: rawhide
Hardware: aarch64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Carlos O'Donell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARM64, F-ExcludeArch-aarch64
TreeView+ depends on / blocked
 
Reported: 2014-07-03 23:10 UTC by Peter Robinson
Modified: 2016-11-24 12:35 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1124952 1124955 (view as bug list)
Environment:
Last Closed: 2014-07-30 17:42:06 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Peter Robinson 2014-07-03 23:10:25 UTC
The aarch64 build of glibc-headers doesn't include sys/io.h 

I'm not sure if it's a bug in glibc or the packages but we've got a small selection of packages that fail to build as a result.

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=2466015

Comment 1 Carlos O'Donell 2014-07-14 16:55:08 UTC
The sys/ headers are architecture and OS dependent. They do not exist across all targets and io.h in particular is intended for very lowl-level non-portable uses often in coordination with the kernel. The only targets that provide sys/io.h are x86*, Alpha, IA64, and 32-bit ARM. No other systems provide it.

We have two options:

* Port the AArch64 kernel version of arch/arm64/include/asm/io.h to glibc to provide sys/io.h for use in userspace. I don't know if this is even possible given the AArch64 instructions and architecture.

or

* Fixup the broken package to build without the header. If it's not feasible to build without those definitions in the header the package should at least build and say it doesn't work at runtime.

Does it even make sense for these packages to build for AArch64? Should they be on the blacklist?

Comment 2 Carlos O'Donell 2014-07-14 16:56:06 UTC
I have brought up the issue upstream to see if we could provide a stub sys/io.h that does nothing to allow these source packages to build but fail at runtime.

Comment 3 Peter Robinson 2014-07-14 17:00:54 UTC
Third option might be to review what functionality the srcpd package uses from the include and see if the package should in fact be using something entirely different such as a standardised platform independent call and is badly written.

Comment 4 Peter Robinson 2014-07-30 12:52:56 UTC
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=2527728

rxtx is another one that makes use of it.

Comment 5 Carlos O'Donell 2014-07-30 16:53:06 UTC
(In reply to Carlos O'Donell from comment #2)
> I have brought up the issue upstream to see if we could provide a stub
> sys/io.h that does nothing to allow these source packages to build but fail
> at runtime.

Upstream consensus is that the package should fail to build to indicate that it has not been ported to the target architecture.

There this is not a bug in glibc but a package relying on architecture-specific headers that don't exist on AArch64.

The mention of rxtx brings back vivid memories of when I used to work with cellular telephony and we used rxtx to talk to cellular modems. While rxtx is not badly written, it is certainly doing very very non-portable things.

Peter, Shall we close this issue as CLOSED/NOTABUG and reopen an issue for srcpd and rxtx to have them blacklisted or fixed?

Comment 6 Peter Robinson 2014-07-30 16:58:43 UTC
> Peter, Shall we close this issue as CLOSED/NOTABUG and reopen an issue for
> srcpd and rxtx to have them blacklisted or fixed?

That works for me but if you could possibly do it as you actually can document the details of what/why as you actually have a clue about this I would be very appreciative ;-)

Comment 7 Carlos O'Donell 2014-07-30 17:42:06 UTC
Bug 1124952 - srcpd must be ported or blacklisted for AArch64.
https://bugzilla.redhat.com/show_bug.cgi?id=1124952

Bug 1124955 - rxtx must be ported or blacklisted for AArch64.
https://bugzilla.redhat.com/show_bug.cgi?id=1124955


Note You need to log in before you can comment on or make changes to this bug.