Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1116552 - Review Request: ustl - A size-optimized STL implementation
Summary: Review Request: ustl - A size-optimized STL implementation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Denis Fateyev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-06 07:10 UTC by Christopher Meng
Modified: 2014-08-19 07:06 UTC (History)
2 users (show)

Fixed In Version: ustl-2.1-3.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-19 07:06:18 UTC
Type: ---
denis: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Christopher Meng 2014-07-06 07:10:02 UTC
Spec URL: http://us-la.cicku.me/ustl.spec
SRPM URL: http://us-la.cicku.me/ustl-2.1-1.fc21.src.rpm
Description: The C++ standard template library (STL) is a collection of common containers 
and algorithms in template form. Unfortunately its standard incarnation 
shipped with gcc is implemented without much concern for code size. Not only 
is the library itself large, the current version being over a megabyte in 
size, but with all the code you instantiate by using a vector for each of 
your containers, it is easy to become fearful and opt for using static 
arrays instead or, worse yet, abandon C++ altogether for C. This is 
especially painful to former DOS assembly programmers like myself, who fret 
endlessly when the size of the executable crosses the magic 64k boundary, 
forgetting that nobody cares about memory anymore.

Of course, these days everyone has gigabytes of RAM and has no compunction 
about loading up OpenOffice, whose source tree is over a gigabyte in size. 
Why then bother with saving a kilobyte of code here and there? I can't really 
say. Maybe it's that warm fuzzy knowledge that you are making maximum possible
use of your computer's resources. Maybe it's that thrill you get after 
expressing your program's functionality in the fewest possible instructions 
and the minimum imaginable overhead. Or maybe it really is of no importance 
and any code bloat will be easily overcome by faster processors in some near 
future. I just know what I like, and it's the sight of clean, concise, and 
fast code. Therefore this library.
Fedora Account System Username: cicku

Comment 1 Michael Schwendt 2014-07-06 07:32:14 UTC
As much as you may like "sed -i …" based substitutions in files, be aware that this road is not a safe one. If the match fails, nothing gets substituted. Using patches is to be preferred, unless you add guards more often than not to verify that the sed command has worked.

Comment 2 Christopher Meng 2014-07-06 08:14:00 UTC
(In reply to Michael Schwendt from comment #1)
> As much as you may like "sed -i …" based substitutions in files, be aware
> that this road is not a safe one. If the match fails, nothing gets
> substituted. Using patches is to be preferred, unless you add guards more
> often than not to verify that the sed command has worked.

If you prefer, I could change to awk.

I do check my script everytime, from the spec, and also from the koji build.log. The reason of not using patch is that, I only write patch for the code, such build script could be easily fixed.

Thanks.

Comment 3 Michael Schwendt 2014-07-06 09:13:47 UTC
> I do check my script everytime,

A guard in the spec file (such as a well-crafted grep match) would automate that task during version upgrades.

You'll burn your hands sooner or later, if you miss a single failing sed that doesn't cause the build to fail.

Comment 4 Denis Fateyev 2014-07-28 22:33:37 UTC
Preliminary notes:
----------------

1) ustl-2.1-1.fc21.src.rpm build fails on rawhide x86_64, please see: https://koji.fedoraproject.org/koji/taskinfo?taskID=7205264

RPM build errors:
    File not found by glob: /builddir/build/BUILDROOT/ustl-2.1-1.fc22.x86_64/usr/lib64/libustl.so*

It's caused by this part in spec:

%files
...
%{_libdir}/libustl.so*

%files devel
...
%{_libdir}/libustl.so

Probably, you meant `libustl.so.1*` in the first case;

2) Since SourceURL points to a Github resource, you need to follow its specific packaging rules: https://fedoraproject.org/wiki/Packaging:SourceURL#Github

Also some details here in a recent package review: https://bugzilla.redhat.com/show_bug.cgi?id=1112434#c6 (see my comment and below).

Comment 5 Denis Fateyev 2014-07-29 01:01:35 UTC
> Probably, you meant `libustl.so.1*` in the first case;
Fix: it's caused by wrong libdir used during install.

Comment 6 Christopher Meng 2014-07-29 01:02:15 UTC
Hi,

Thanks for your comment. I checked the spec and found that issue 1 is already fixed in my local repo days ago as the previous packaging was broken.

The root cause is that I forgot to set the libdir for /lib64 systems so the install will put libraries to /lib still on 64 bits systems.

Regarding issue 2, the current way of handling such URL is acceptable, you can read paragraphs after the URL you pointed to me ;)

https://fedoraproject.org/wiki/Packaging:SourceURL#Troublesome_URLs

NEW SPEC URL: http://us-la.cicku.me/ustl.spec
NEW SRPM URL: http://us-la.cicku.me/ustl-2.1-1.fc21.src.rpm

Comment 7 Christopher Meng 2014-08-01 09:16:22 UTC
NEW SPEC URL: http://us-la.cicku.me/ustl.spec
NEW SRPM URL: http://us-la.cicku.me/ustl-2.1-2.fc22.src.rpm

Comment 8 Denis Fateyev 2014-08-02 21:47:41 UTC
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

C/C++:
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Header files in -devel subpackage, if present.
[x]: ldconfig called in %post and %postun if required.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.
[x]: Development (unversioned) .so files in -devel subpackage, if present.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "Unknown or generated". 100 files have unknown license. Detailed output
     of licensecheck in /home/mock/sandbox/test/ustl/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 92160 bytes in 13 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install' ' DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package do not use a name that already exist
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Scriptlets must be sane, if used.
[x]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: Dist tag is present (not strictly required in GL).
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Fully versioned dependency in subpackages if applicable.
[x]: Uses parallel make %{?_smp_mflags} macro.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.


Rpmlint
-------
Checking: ustl-2.1-2.fc20.x86_64.rpm
          ustl-devel-2.1-2.fc20.x86_64.rpm
          ustl-2.1-2.fc20.src.rpm
ustl.x86_64: W: spelling-error %description -l en_US gcc -> cc, g cc
ustl.src: W: spelling-error %description -l en_US gcc -> cc, g cc
ustl.src:11: W: macro-in-comment %{version}
ustl.src:11: W: macro-in-comment %{name}
ustl.src:11: W: macro-in-comment %{version}
ustl.src:46: W: macro-in-comment %setup
ustl.src:60: W: rpm-buildroot-usage %build ./configure --with-libstdc++ --force-inline --prefix=%{buildroot}%{_prefix}
ustl.src:60: W: configure-without-libdir-spec
ustl.src:56: W: mixed-use-of-spaces-and-tabs (spaces: line 5, tab: line 56)
3 packages and 0 specfiles checked; 0 errors, 9 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint ustl ustl-devel
ustl.x86_64: W: spelling-error %description -l en_US gcc -> cc, g cc
ustl.x86_64: W: unused-direct-shlib-dependency /usr/lib64/libustl.so.1.6 /lib64/libm.so.6
ustl-devel.x86_64: W: only-non-binary-in-usr-lib
2 packages and 0 specfiles checked; 0 errors, 3 warnings.
# echo 'rpmlint-done:'



Requires
--------
ustl (rpmlib, GLIBC filtered):
    /sbin/ldconfig
    libc.so.6()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    libm.so.6()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    rtld(GNU_HASH)

ustl-devel (rpmlib, GLIBC filtered):
    libustl.so.1()(64bit)
    ustl(x86-64)



Provides
--------
ustl:
    libustl.so.1()(64bit)
    ustl
    ustl(x86-64)

ustl-devel:
    ustl-devel
    ustl-devel(x86-64)



Source checksums
----------------
https://github.com/msharov/ustl/archive/5d6de720cb16e18a4b63a2c889d4e089b32d773f/ustl-5d6de720cb16e18a4b63a2c889d4e089b32d773f.tar.gz :
  CHECKSUM(SHA256) this package     : a35042b2ec1b2128dd526614d92a40bf86ff2f2b5adc10d655536cafe91c1efe
  CHECKSUM(SHA256) upstream package : a35042b2ec1b2128dd526614d92a40bf86ff2f2b5adc10d655536cafe91c1efe


Generated by fedora-review 0.5.1 (bb9bf27) last change: 2013-12-13
Command line :/usr/bin/fedora-review --rpm-spec -n ustl-2.1-2.fc22.src.rpm
Buildroot used: fedora-20-x86_64
Active plugins: Generic, Shell-api, C/C++
Disabled plugins: Java, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP, Ruby
Disabled flags: EXARCH, EPEL5, BATCH, DISTTAG


Result:
-------
You can add README file to docs and eliminate some rpmlint warning above. Otherwise, this package is APPROVED.

Comment 9 Christopher Meng 2014-08-03 02:26:59 UTC
New Package SCM Request
=======================
Package Name: ustl
Short Description: A size-optimized STL implementation
Upstream URL: http://msharov.github.io/ustl/
Owners: cicku
Branches: f19 f20 f21 el6 epel7

Comment 10 Gwyn Ciesla 2014-08-04 12:22:47 UTC
Git done (by process-git-requests).

Comment 11 Fedora Update System 2014-08-08 09:14:39 UTC
ustl-2.1-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ustl-2.1-3.fc20

Comment 12 Fedora Update System 2014-08-09 07:35:07 UTC
ustl-2.1-3.fc20 has been pushed to the Fedora 20 testing repository.

Comment 13 Fedora Update System 2014-08-19 07:06:18 UTC
ustl-2.1-3.fc20 has been pushed to the Fedora 20 stable repository.


Note You need to log in before you can comment on or make changes to this bug.