Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1146642 - [abrt] xfce4-power-manager: _cairo_scaled_glyph_page_destroy.lto_priv.542(): xfce4-power-manager killed by SIGABRT
Summary: [abrt] xfce4-power-manager: _cairo_scaled_glyph_page_destroy.lto_priv.542(): ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-power-manager
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:60963a2d733c374326b40f86aad...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-25 16:33 UTC by Robbie Harwood
Modified: 2015-02-12 02:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-12 02:36:11 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (40.45 KB, text/plain)
2014-09-25 16:33 UTC, Robbie Harwood
no flags Details
File: cgroup (191 bytes, text/plain)
2014-09-25 16:33 UTC, Robbie Harwood
no flags Details
File: core_backtrace (20.13 KB, text/plain)
2014-09-25 16:33 UTC, Robbie Harwood
no flags Details
File: dso_list (8.52 KB, text/plain)
2014-09-25 16:33 UTC, Robbie Harwood
no flags Details
File: environ (1.31 KB, text/plain)
2014-09-25 16:33 UTC, Robbie Harwood
no flags Details
File: limits (1.29 KB, text/plain)
2014-09-25 16:33 UTC, Robbie Harwood
no flags Details
File: maps (45.89 KB, text/plain)
2014-09-25 16:33 UTC, Robbie Harwood
no flags Details
File: open_fds (771 bytes, text/plain)
2014-09-25 16:33 UTC, Robbie Harwood
no flags Details
File: proc_pid_status (991 bytes, text/plain)
2014-09-25 16:33 UTC, Robbie Harwood
no flags Details
File: var_log_messages (200 bytes, text/plain)
2014-09-25 16:33 UTC, Robbie Harwood
no flags Details

Description Robbie Harwood 2014-09-25 16:33:40 UTC
Description of problem:
I right-clicked on the icon in the notification tray for the power manager.  I am unable to reproduce this crash.

Version-Release number of selected component:
xfce4-power-manager-1.2.0-11.fc22

Additional info:
reporter:       libreport-2.2.3
backtrace_rating: 4
cmdline:        xfce4-power-manager --restart --sm-client-id 2341583eb-9230-44e1-9f3c-16d9d6d34f51
crash_function: _cairo_scaled_glyph_page_destroy.lto_priv.542
executable:     /usr/bin/xfce4-power-manager
kernel:         3.17.0-0.rc6.git1.1.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            21259

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 _cairo_scaled_glyph_page_destroy.lto_priv.542 at /lib64/libcairo.so.2
 #5 _cairo_scaled_font_free_last_glyph at /lib64/libcairo.so.2
 #6 _cairo_scaled_glyph_lookup at /lib64/libcairo.so.2
 #7 _cairo_scaled_font_glyph_path at /lib64/libcairo.so.2
 #8 _cairo_gstate_glyph_path at /lib64/libcairo.so.2
 #9 cairo_glyph_path at /lib64/libcairo.so.2
 #10 pango_cairo_renderer_show_text_glyphs at pangocairo-render.c:491
 #11 pango_cairo_renderer_draw_glyphs at pangocairo-render.c:516
 #12 pango_renderer_draw_glyphs at pango-renderer.c:641
 #13 pango_renderer_draw_layout_line at pango-renderer.c:570

Comment 1 Robbie Harwood 2014-09-25 16:33:43 UTC
Created attachment 941182 [details]
File: backtrace

Comment 2 Robbie Harwood 2014-09-25 16:33:45 UTC
Created attachment 941183 [details]
File: cgroup

Comment 3 Robbie Harwood 2014-09-25 16:33:46 UTC
Created attachment 941184 [details]
File: core_backtrace

Comment 4 Robbie Harwood 2014-09-25 16:33:47 UTC
Created attachment 941185 [details]
File: dso_list

Comment 5 Robbie Harwood 2014-09-25 16:33:49 UTC
Created attachment 941186 [details]
File: environ

Comment 6 Robbie Harwood 2014-09-25 16:33:50 UTC
Created attachment 941187 [details]
File: limits

Comment 7 Robbie Harwood 2014-09-25 16:33:52 UTC
Created attachment 941188 [details]
File: maps

Comment 8 Robbie Harwood 2014-09-25 16:33:53 UTC
Created attachment 941189 [details]
File: open_fds

Comment 9 Robbie Harwood 2014-09-25 16:33:54 UTC
Created attachment 941190 [details]
File: proc_pid_status

Comment 10 Robbie Harwood 2014-09-25 16:33:56 UTC
Created attachment 941191 [details]
File: var_log_messages

Comment 11 Mukundan Ragavan 2014-09-26 03:24:28 UTC
Thanks for the report.

One time crash.... I am hoping to update xfpm to version 1.4 (over the next few days). Perhaps, that will be more stable ....

Comment 12 Fedora Update System 2014-10-02 03:13:56 UTC
xfce4-power-manager-1.4.1-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/xfce4-power-manager-1.4.1-3.fc21

Comment 13 Fedora Update System 2014-10-10 16:09:33 UTC
xfce4-power-manager-1.4.1-3.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Mukundan Ragavan 2015-02-12 02:36:11 UTC
I am closing this bug since an updated version is available. Feel free to reopen if this bug persists.


Note You need to log in before you can comment on or make changes to this bug.