Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1150179 - Upgrade to lightdm-1.10.2-1.fc21 doesn't allow login
Summary: Upgrade to lightdm-1.10.2-1.fc21 doesn't allow login
Alias: None
Product: Fedora
Classification: Fedora
Component: lightdm
Version: rawhide
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
: 1150321 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2014-10-07 15:13 UTC by John Barbieri
Modified: 2014-10-10 15:57 UTC (History)
5 users (show)

Fixed In Version: lightdm-1.10.2-2.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2014-10-10 15:57:48 UTC
Type: Bug

Attachments (Terms of Use)
lightdm.log.old (14.38 KB, text/plain)
2014-10-07 15:13 UTC, John Barbieri
no flags Details

Description John Barbieri 2014-10-07 15:13:07 UTC
Created attachment 944642 [details]

Description of problem:
After doing a yum upgrade on my rawhide system yesterday, and rebooting, I could no longer log into a desktop. The login screen comes up, I enter correct password, and it acts like it is handing off to a desktop environment, but then comes back to login screen. Tried multiple desktops (xfce, mate, lxde), and none of them allowed logins. With lxde, a startx worked. With the other desktops (removed lxde), would get the same results, would start to load, then go back to command prompt.

A yum downgrade on lightdm and lightdm-gobject (to 1.10.1-5.fc21) restored access.

Version-Release number of selected component (if applicable):

How reproducible:
I did a yum upgrade again this morning, and got same results. I could not find any errors in Xorg.log or in /var/log/messages. Nothing in ~/.xsession-errors (0 length file).

Attached /var/log/lightdm/lightdm.log.old (failed attempt)

Steps to Reproduce:
1. Upgrade lightdm and lightdm-gobject to 1.10.2-1.fc21
2. Reboot system
3. Attempt to log into desktop environmnet

Actual results:
Login screen disappears, can briefly see CLI, then login screen re-appears. Never ending cycle.

Expected results:
Expected to go into desktop environment.

Additional info:

Comment 1 Fedora Update System 2014-10-07 18:02:41 UTC
lightdm-1.10.2-2.fc21 has been submitted as an update for Fedora 21.

Comment 2 Rex Dieter 2014-10-07 18:04:57 UTC
Sorry about that, I'd botched lightdm.conf, see

for the fix.

In particular, you want 

Comment 3 Spenk 2014-10-08 09:47:38 UTC
*** Bug 1150321 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2014-10-08 19:14:35 UTC
Package lightdm-1.10.2-2.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lightdm-1.10.2-2.fc21'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).

Comment 5 John Barbieri 2014-10-09 20:39:48 UTC
1.10.2-2.fc21 fixed it


Comment 6 Fedora Update System 2014-10-10 15:57:48 UTC
lightdm-1.10.2-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.