Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1159060 - Zabbix22 for EL6 not updated since 2.2.1
Summary: Zabbix22 for EL6 not updated since 2.2.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: zabbix22
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Volker Fröhlich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1136479 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-30 19:33 UTC by Trey Dockendorf
Modified: 2015-10-02 23:23 UTC (History)
6 users (show)

Fixed In Version: zabbix22-2.2.10-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-02 23:23:09 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
zabbix22 spec for EL6 and EL7 (38.46 KB, text/plain)
2014-10-30 19:33 UTC, Trey Dockendorf
no flags Details
SRPM updated to 2.2.7 version (14.33 MB, application/x-rpm)
2015-02-06 12:36 UTC, Fabiano Martins
no flags Details

Description Trey Dockendorf 2014-10-30 19:33:12 UTC
Created attachment 952320 [details]
zabbix22 spec for EL6 and EL7

Description of problem:

Zabbix22 for EPEL6 has not been updated to the same versions available for EPEL5 and EPEL7.  Currently 2.2.1 is the latest available version while EPEL7 is now at 2.2.7.

Version-Release number of selected component (if applicable):

2.2.1

Additional info:

Attached is a spec file I've used to build EL6 and EL7 RPMs from the same spec file based on the EL version being built.

Comment 1 Greg Swift 2014-11-11 22:43:33 UTC
*** Bug 1136479 has been marked as a duplicate of this bug. ***

Comment 2 Denis S Mikhlevich 2015-01-08 17:30:59 UTC
Yes, I'm confirming still no update of version Zabbix 2.2.1 in EL6. The date of version 2.2.1 in EL6 is 2014-01-19 is nearly 1 year.

Comment 3 Fabiano Martins 2015-02-06 12:36:56 UTC
Created attachment 988851 [details]
SRPM updated to 2.2.7 version

I attached a SRPM containing:
- specfile updated to 2.2.7-1 (latest from EL7 at this moment)
- zabbix-server.init, zabbix-agentd.init and zabbbix-proxy.init, from zabbix22-2.2.1-5.el6.src.rpm
- other files from zabbix22-2.2.7-1.el7.src.rpm

I've tested this specfile and it works fine in EPEL 6 and 7: please use it to build a EPEL 6 package now. And when you have time to work on 2.2.8 version, you could start from this generic specfile instead of EPEL 7 specific specfile.

For now, please update the zabbix22 package, at least to 2.2.7 version: many bugfixes depends from it!

Comment 4 Denis S Mikhlevich 2015-02-06 20:19:44 UTC
 Dear Fabiano, 

I built packages on my CentOS 6.5 from your zabbix22-2.2.7-1.el7.src.rpm.
In my folder ~/RPM/RPMS/noarch creates this files:
zabbix22-dbfiles-mysql-2.2.7-1.el6.noarch.rpm
zabbix22-dbfiles-pgsql-2.2.7-1.el6.noarch.rpm
zabbix22-dbfiles-sqlite3-2.2.7-1.el6.noarch.rpm
zabbix22-proxy-2.2.7-1.el6.noarch.rpm
zabbix22-server-2.2.7-1.el6.noarch.rpm
zabbix22-web-2.2.7-1.el6.noarch.rpm
zabbix22-web-mysql-2.2.7-1.el6.noarch.rpm
zabbix22-web-pgsql-2.2.7-1.el6.noarch.rpm

and in ~/RPM/RPMS/x64_86 this:
zabbix22-2.2.7-1.el6.x86_64.rpm
zabbix22-agent-2.2.7-1.el6.x86_64.rpm
zabbix22-proxy-mysql-2.2.7-1.el6.x86_64.rpm
zabbix22-proxy-pgsql-2.2.7-1.el6.x86_64.rpm
zabbix22-proxy-sqlite3-2.2.7-1.el6.x86_64.rpm
zabbix22-server-mysql-2.2.7-1.el6.x86_64.rpm
zabbix22-server-pgsql-2.2.7-1.el6.x86_64.rpm

Now I try to install zabbix22-server-2.2.7-1.el6.noarch.rpm by this command from ~/RPM/RPMS/noarch
and I got the follow error:
# rpm -Uvh ./zabbix22-server-2.2.7-1.el6.noarch.rpm
ошибка: Неудовлетворенные зависимости:
        zabbix22 = 2.2.7-1.el6 нужен для zabbix22-server-2.2.7-1.el6.noarch
        zabbix22-server-implementation = 2.2.7-1.el6 нужен для zabbix22-server-2.2.7-1.el6.noarch
        zabbix22-server = 2.2.1-5.el6 нужен для (установлен)zabbix22-server-mysql-2.2.1-5.el6.x86_64

What the package zabbix22-server-implementation? I have not it in my system:
# yum list installed | grep zabbix22
zabbix22.x86_64                      2.2.1-5.el6                       @epel
zabbix22-agent.x86_64                2.2.1-5.el6                       @epel
zabbix22-dbfiles-mysql.noarch        2.2.1-5.el6                       @epel
zabbix22-server.noarch               2.2.1-5.el6                       @epel
zabbix22-server-mysql.x86_64         2.2.1-5.el6                       @epel
zabbix22-web.noarch                  2.2.1-5.el6                       @epel
zabbix22-web-mysql.noarch            2.2.1-5.el6                       @epel

# yum search zabbix22-server-implementation
Загружены модули: fastestmirror, security
Loading mirror speeds from cached hostfile
 * base: mirror.atlanticmetro.net
 * epel: fedora-mirror01.rbc.ru
 * extras: mirror.atlanticmetro.net
 * updates: mirror.atlanticmetro.net
Внимание: совпадений для zabbix22-server-implementation не найдено
Совпадений не найдено

Comment 5 Fabiano Martins 2015-02-09 15:20:06 UTC
Hi,

In order to install zabbix-server, you need also support to a database. These support is represented by the dependence of "pseudo-package" zabbix-server-implementation.

zabbix-server-implementation is provided by zabbix-server-mysql and zabbix-server-pgsql: you need install one of these (and respective "dbfiles" RPM).

Re-running your installation steps...

[root@fabiano-centos6-zabbix22 RPMS]# rpm -Uvh noarch/zabbix22-server-2.2.7-1.el6.noarch.rpm x86_64/zabbix22-2.2.7-1.el6.x86_64.rpm 
error: Failed dependencies:
	zabbix22-server-implementation = 2.2.7-1.el6 is needed by zabbix22-server-2.2.7-1.el6.noarch
[root@fabiano-centos6-zabbix22 RPMS]# rpm -Uvh noarch/zabbix22-server-2.2.7-1.el6.noarch.rpm x86_64/zabbix22-2.2.7-1.el6.x86_64.rpm x86_64/zabbix22-server-mysql-2.2.7-1.el6.x86_64.rpm 
error: Failed dependencies:
	zabbix22-dbfiles-mysql is needed by zabbix22-server-mysql-2.2.7-1.el6.x86_64
[root@fabiano-centos6-zabbix22 RPMS]# rpm -Uvh noarch/zabbix22-server-2.2.7-1.el6.noarch.rpm x86_64/zabbix22-2.2.7-1.el6.x86_64.rpm x86_64/zabbix22-server-mysql-2.2.7-1.el6.x86_64.rpm noarch/zabbix22-dbfiles-mysql-2.2.7-1.el6.noarch.rpm
Preparing...                ########################################### [100%]
   1:zabbix22               ########################################### [ 25%]
   2:zabbix22-dbfiles-mysql ########################################### [ 50%]
   3:zabbix22-server-mysql  ########################################### [ 75%]
   4:zabbix22-server        ########################################### [100%]

Comment 6 Denis S Mikhlevich 2015-02-09 15:44:57 UTC
 Dear Fabiano,
Thank you for reply.
Installation was success by this command
# rpm -Uvh \
>noarch/zabbix22-server-2.2.7-1.el6.noarch.rpm \
>x86_64/zabbix22-2.2.7-1.el6.x86_64.rpm \
>x86_64/zabbix22-server-mysql-2.2.7-1.el6.x86_64.rpm \
>noarch/zabbix22-dbfiles-mysql-2.2.7-1.el6.noarch.rpm \
>noarch/zabbix22-web-2.2.7-1.el6.noarch.rpm \
>noarch/zabbix22-web-mysql-2.2.7-1.el6.noarch.rpm \
>x86_64/zabbix22-agent-2.2.7-1.el6.x86_64.rpm

But after this, zabbix-server would not started.
I looked in log file zabbix_server.log
and saw in it:
 27385:20150209:182914.510 Starting Zabbix Server. Zabbix 2.2.7 (revision 50148).
 27385:20150209:182914.510 ****** Enabled features ******
 27385:20150209:182914.510 SNMP monitoring:           YES
 27385:20150209:182914.511 IPMI monitoring:           YES
 27385:20150209:182914.511 WEB monitoring:            YES
 27385:20150209:182914.511 VMware monitoring:         YES
 27385:20150209:182914.511 Jabber notifications:      YES
 27385:20150209:182914.511 Ez Texting notifications:  YES
 27385:20150209:182914.511 ODBC:                      YES
 27385:20150209:182914.511 SSH2 support:              YES
 27385:20150209:182914.511 IPv6 support:              YES
 27385:20150209:182914.511 ******************************
 27385:20150209:182914.511 using configuration file: /etc/zabbix_server.conf
 27385:20150209:182914.521 current database version (mandatory/optional): 02020000/02020001
 27385:20150209:182914.521 required mandatory version: 02020000
 27385:20150209:182915.980 __mem_malloc: skipped 0 asked 136 skip_min 4294967295 skip_max 0
 27385:20150209:182915.980 [file:dbconfig.c,line:445] zbx_mem_malloc(): out of memory (requested 136 bytes)
 27385:20150209:182915.980 [file:dbconfig.c,line:445] zbx_mem_malloc(): please increase CacheSize configuration parameter

Then, I increased CacheSize from 35M to 64M, and Zabbix started successfully.

Comment 7 Fabiano Martins 2015-02-09 16:26:37 UTC
I'm actually not using this RPM for the server installation, but only to client. In fact I only tested it on the client side...

The CacheSize and other parameters of the Zabbix server are the same of the original EPEL 7 packaging: probably you have the same problem if you install zabbix-server package of EPEL 7 on CentOS 7.

I'm happy it worked for you, and I'll be even happier if this update is incorporated into the EPEL mainstream.

Please update here the results of your tests with my package on Zabbix server.

Comment 8 Denis S Mikhlevich 2015-02-11 06:33:29 UTC
Fabiano, you rpms work good. But I would need to increase CacheSize to 512M in zabbix_server.conf, because the web worked very slowly with 64M.

Comment 9 Fedora Update System 2015-09-15 15:06:21 UTC
zabbix22-2.2.10-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8091

Comment 10 Fedora Update System 2015-09-16 00:20:12 UTC
zabbix22-2.2.10-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update zabbix22'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8091

Comment 11 Fedora Update System 2015-10-02 23:22:51 UTC
zabbix22-2.2.10-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.