Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1159643 - Download progress prints new line
Summary: Download progress prints new line
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wget
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomáš Hozza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-02 14:27 UTC by nucleo
Modified: 2014-12-06 10:47 UTC (History)
2 users (show)

Fixed In Version: wget-1.16-3.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-22 12:34:23 UTC
Type: Bug


Attachments (Terms of Use)

Description nucleo 2014-11-02 14:27:31 UTC
Description of problem:


Version-Release number of selected component (if applicable):
wget-1.16-1.fc21

How reproducible:
Download progress prints new line when percent updates with LANG=ru_RU.UTF8, but
no problem with LANG=C.

Steps to Reproduce:
1. run 'LANG=ru_RU.UTF8 wget http://dl.fedoraproject.org/pub/fedora/linux/releases/test/21-Alpha/Live/i386/Fedora-Live-KDE-i686-21_Alpha-1.iso'

Actual results:
download progress displayed on many lines

--2014-11-02 16:25:05--  http://dl.fedoraproject.org/pub/fedora/linux/releases/test/21-Alpha/Live/i386/Fedora-Live-KDE-i686-21_Alpha-1.iso
Распознаётся dl.fedoraproject.org (dl.fedoraproject.org)… 209.132.181.23, 209.132.181.24, 209.132.181.25, ...
Подключение к dl.fedoraproject.org (dl.fedoraproject.org)|209.132.181.23|:80... соединение установлено.
HTTP-запрос отправлен. Ожидание ответа... 200 OK
Длина: 1027604480 (980M) [application/octet-stream]
Сохранение в: «Fedora-Live-KDE-i686-21_Alpha-1.iso»

ve-KDE-i686-21_Alpha-1.is   0%[                                       ]   1,18M   456KB/s              Fedora-Live-KDE-i686-21_A   0%[                                       ]   1,30M   464KB/s              edora-Live-KDE-i686-21_Al   0%[                                       ]   1,44M   467KB/s   eta 35m 44sdora-Live-KDE-i686-21_Alp   0%[                                       ]   1,71M   516KB/s   eta 35m 44sora-Live-KDE-i686-21_Alph   0%[                                       ]   1,86M   526KB/s   eta 35m 44sra-Live-KDE-i686-21_Alpha   0%[                                       ]   2,03M   555KB/s   eta 35m 44sa-Live-KDE-i686-21_Alpha-   0%[                                       ]   2,35M   629KB/s   eta 35m 44s-Live-KDE-i686-21_Alpha-1   0%[                                       ]   2,54M   660KB/s   eta 28m 4s Live-KDE-i686-21_Alpha-1.   0%[                                       ]   2,74M   698KB/s   eta 28m 4s ive-KDE-i686-21_Alpha-1.i   0%[                                       ]   3,08M   766KB/s   eta 28m 4s ve-KDE-i686-21_Alpha-1.is   0%[                                       ]   3,34M   810KB/s   eta 28m 4s Fedora-Live-KDE-i686-21_A   0%[                                       ]   3,57M   839KB/s   eta 28m 4s edora-Live-KDE-i686-21_Al   0%[                                       ]   3,83M   874KB/s   eta 23m 28sdora-Live-KDE-i686-21_Alp   0%[                                       ]   4,09M   921KB/s   eta 23m 28sora-Live-KDE-i686-21_Alph   0%[                                       ]   4,49M   999KB/s   eta 23m 28sra-Live-KDE-i686-21_Alpha   0%[                                       ]   4,88M  1,04MB/s   eta 23m 28sa-Live-KDE-i686-21_Alpha-   0%[                                       ]   5,18M  1,08MB/s   eta 23m 28s-Live-KDE-i686-21_Alpha-1   0%[                                       ]   5,52M  1,12MB/s   eta 19m 34sLive-KDE-i686-21_Alpha-1.   0%[                                       ]   5,85M  1,19MB/s   eta 19m 34sive-KDE-i686-21_Alpha-1.i   0%[                                       ]   6,21M  1,25MB/s   eta 19m 34sve-KDE-i686-21_Alpha-1.is   0%[                                       ]   6,69M  1,33MB/s   eta 19m 34sFedora-Live-KDE-i686-21_A   0%[                                       ]   7,18M  1,42MB/s   eta 19m 34sedora-Live-KDE-i686-21_Al   0%[                                       ]   7,71M  1,51MB/s   eta 16m 7s dora-Live-KDE-i686-21_Alp   0%[                                       ]   8,15M  1,56MB/s   eta 16m 7s ora-Live-KDE-i686-21_Alph   0%[                                       ]   8,64M  1,66MB/s   eta 16m 7s ra-Live-KDE-i686-21_Alpha   0%[                                       ]   9,13M  1,72MB/s   eta 16m 7s a-Live-KDE-i686-21_Alpha-   0%[                                       ]   9,65M  1,80MB/s   eta 16m 7s 

Expected results:
it should be in one line

Comment 1 nucleo 2014-11-02 14:28:44 UTC
Looks like progress bar fixed in this commit
http://git.savannah.gnu.org/cgit/wget.git/commit/?id=35bfcb34b0eb5ccc28c1e9f308678fd476f6fe22

Comment 2 Tomáš Hozza 2014-11-03 08:52:32 UTC
Thank you for the report.

The fix is not complete yet, based on the comments on wget mailing list:
http://lists.gnu.org/archive/html/bug-wget/2014-11/msg00032.html

Comment 3 Tomáš Hozza 2014-11-18 15:05:41 UTC
Fix committed into the dist-git. I'll push an update shortly...

Comment 4 Fedora Update System 2014-11-18 15:16:21 UTC
wget-1.16-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wget-1.16-3.fc19

Comment 5 Fedora Update System 2014-11-18 15:16:39 UTC
wget-1.16-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/wget-1.16-3.fc21

Comment 6 Fedora Update System 2014-11-18 15:17:22 UTC
wget-1.16-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/wget-1.16-3.fc20

Comment 7 Fedora Update System 2014-11-19 03:08:57 UTC
Package wget-1.16-3.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wget-1.16-3.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15347/wget-1.16-3.fc21
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2014-11-22 12:34:23 UTC
wget-1.16-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2014-12-01 19:07:26 UTC
wget-1.16-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2014-12-06 10:47:30 UTC
wget-1.16-3.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.