Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1161913 - Yumex does not save 'clean unused requirements is active by default' in preferences [NEEDINFO]
Summary: Yumex does not save 'clean unused requirements is active by default' in prefe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-09 09:55 UTC by Minus Zero
Modified: 2015-05-08 16:42 UTC (History)
6 users (show)

Fixed In Version: yumex-3.0.17-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-26 12:44:44 UTC
Type: Bug
projects.rg: needinfo? (tla)


Attachments (Terms of Use)

Description Minus Zero 2014-11-09 09:55:44 UTC
If I go to yumex's preferences and check 'clean unused requirements is active by default' and then OK the config is not saved, if I just open the preferences again it is unchecked. It seems to be the only option affected.

Comment 1 Tim Lauridsen 2014-11-11 16:01:52 UTC
I can reproduce this issue, I will look into it

Comment 2 Mike Simms 2014-12-10 10:04:05 UTC
I can reproduce too. build 3.0.16-1.fc21 i686 on MATE-Compiz spin.

Comment 3 Raphael Groner 2014-12-19 14:09:49 UTC
Reproducible for Fedora 21.

yumex-3.0.16-1.fc21.noarch

Comment 4 Mike Simms 2014-12-26 20:40:05 UTC
What is the yumex.conf entry for 'cleanup unused requirements is active by default'? Is it remove_requirements? If so it is being ignored. I was just wondering if there was another entry missing.

My yumex.conf currently shows the following.

[yumex]
autorefresh = 1
recentdays = 14
proxy =
exclude =
debug = 0
color_install = darkgreen
color_update = red
color_normal = black
color_obsolete = blue
plugins = 1
yumdebuglevel = 2
win_height = 753
win_width = 1126
remove_requirements = 1

Comment 5 Raphael Groner 2015-01-30 20:53:53 UTC
This is a broken feature. Setting Severity to high.

Comment 6 william.chan4 2015-02-16 16:22:59 UTC
I can reproduce this too. Until this is fixed, users will simply have to click options>"clean unused requirements" when uninstalling packages.

Comment 7 Alex. H. F. 2015-02-21 19:24:30 UTC
I have same problem.
Here is my yumex.conf:
[yumex]
autorefresh = 1
recentdays = 14
proxy =
exclude =
debug = 0
color_install = darkgreen
color_update = red
color_normal = black
color_obsolete = blue
plugins = 1
yumdebuglevel = 2
win_height = 740
win_width = 1210
win_sep = 379
typeahead_search = 0
use_sortable_view = 1
use_sudo = 1
check_for_updates = 1
remove_requirements = 1
remove_requirements = 1
remove_requirements = 1
remove_requirements = 1



Interesting that, even if you have already 1 entry set to 1, each time you set it to true again, a new entry will be created at the end of the file.
But, it does not get "sticky" under settings (in the same session)...


Seems as this item does not get parsed/recognized at startup.
Output log (German):
<...>
19:49:29 : INFO - Using config file : /home/XYZ/.config/yumex/yumex.conf
20:01:09 : DEBUG - Netzwerkschnittstelle wlp4s0b1 (brcmsmac) ist verbunden
20:01:09 : INFO - Yum-Option skip_broken wird auf False gesetzt
20:01:10 : INFO - Yum-Option clean_requirements_on_remove wird auf False gesetzt
20:01:10 : INFO - 13 Pakete zurückgegeben
20:01:10 : INFO - 0 Pakete zurückgegeben
20:01:12 : INFO - YUM: --> Transaktionsprüfung wird ausgeführt
<...>

Comment 8 william.chan4 2015-02-21 22:40:10 UTC
The latest (testing) version of Yum Extender from the yumex-dnf COPR repository does not have this issue. However, this is not a solution to this problem since several features are still yet to be implemented. 

More information is available at yumex.dk

Comment 9 Tim Lauridsen 2015-04-20 18:10:58 UTC
fixed upstream

https://github.com/timlau/yumex/commit/48027f5ffb4ef66a4d483eac25811b164aec9f24

Very weird case, look like iniparse don't like option there starts with remove
so i renamed the option to clean_requirments in yumex.conf and it work like a charm.

Comment 10 Mike Simms 2015-04-20 22:22:20 UTC
Thanks Tim! I'll try and hopefully leave some positive karma it as soon as it hits the updates-testing for F21 and F22.

Glad you managed to find the cause anyhow.

Comment 11 Fedora Update System 2015-04-21 05:27:56 UTC
yumex-3.0.17-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/yumex-3.0.17-1.fc22

Comment 12 Fedora Update System 2015-04-21 05:28:05 UTC
yumex-3.0.17-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/yumex-3.0.17-1.fc21

Comment 13 Fedora Update System 2015-04-21 05:28:17 UTC
yumex-3.0.17-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/yumex-3.0.17-1.el7

Comment 14 Fedora Update System 2015-04-22 05:08:43 UTC
Package yumex-3.0.17-1.el7:
* should fix your issue,
* was pushed to the Fedora EPEL 7 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing yumex-3.0.17-1.el7'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-5908/yumex-3.0.17-1.el7
then log in and leave karma (feedback).

Comment 15 lnie 2015-04-22 07:12:17 UTC
yumex-3.0.17-1.fc22 works

Comment 16 Fedora Update System 2015-04-26 12:44:44 UTC
yumex-3.0.17-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2015-05-01 16:53:06 UTC
yumex-3.0.17-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2015-05-08 16:42:15 UTC
yumex-3.0.17-1.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.