Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1163410 - shrinking partition to an absolutely minimum size results in an error
Summary: shrinking partition to an absolutely minimum size results in an error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1163887
TreeView+ depends on / blocked
 
Reported: 2014-11-12 16:27 UTC by Kamil Páral
Modified: 2014-11-25 03:06 UTC (History)
9 users (show)

Fixed In Version: python-blivet-0.61.10-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1163887 (view as bug list)
Environment:
Last Closed: 2014-11-25 03:06:15 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1162215 0 unspecified CLOSED partition resize does not check filesystem minimum size 2022-05-16 11:32:56 UTC
Red Hat Bugzilla 1163694 0 unspecified CLOSED ValueError: new size will not yield an aligned partition 2022-05-16 11:32:56 UTC
Red Hat Bugzilla 1164192 0 unspecified CLOSED AttributeError: 'CustomPartitioningSpoke' object has no attribute 'alignTargetSize' 2022-05-16 11:32:56 UTC

Internal Links: 1162215 1163694 1164192

Description Kamil Páral 2014-11-12 16:27:11 UTC
Description of problem:
This is split from bug 1162215 comment 13. The errors are here:
http://paste.fedoraproject.org/149421/64036014/
http://paste.fedoraproject.org/149440/44178141/

This updates.img was used:
https://dlehman.fedorapeople.org/updates/updates-1162215.1.img

Version-Release number of selected component (if applicable):
anaconda 21.48.13-1

How reproducible:
tried once

Steps to Reproduce:
1. apply updates.img
2. try to resize partition to a minimum size
3. error during beginning of the installation

Comment 1 David Lehman 2014-11-12 21:52:42 UTC
Here's an updates image with a proposed fix. It includes the content from 1162215 also.

  https://dlehman.fedorapeople.org/updates/updates-1163410.0.img

Let me know how it goes.

Comment 2 Kamil Páral 2014-11-13 10:10:21 UTC
Almost. I tried a standard ext4 partition, and LV, both guided and custom part, and everything worked. But I hit bug 1163694 while playing with guided part shrinking. I don't know whether it was caused by this updates.img or it is present in anaconda in general.

Comment 3 David Lehman 2014-11-13 17:06:47 UTC
Rebased updates:

  https://dlehman.fedorapeople.org/updates/updates-1163410.1.img

Comment 4 Kamil Páral 2014-11-14 10:06:56 UTC
(In reply to David Lehman from comment #3)
> Rebased updates:
> 
>   https://dlehman.fedorapeople.org/updates/updates-1163410.1.img

Works in guided part, crashes in custom part - bug 1164192. I used TC2 instead of TC1.

Comment 5 Fedora Update System 2014-11-19 01:56:47 UTC
anaconda-21.48.15-1.fc21, python-blivet-0.61.10-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-blivet-0.61.10-1.fc21,anaconda-21.48.15-1.fc21

Comment 6 Kamil Páral 2014-11-19 12:54:59 UTC
This seems to be fixed with the update above.

Comment 7 Fedora Update System 2014-11-25 03:06:15 UTC
python-blivet-0.61.10-1.fc21, anaconda-21.48.16-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.