Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1163574 - Backlight control needs kernel param: video.use_native_backlight=0
Summary: Backlight control needs kernel param: video.use_native_backlight=0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-13 03:31 UTC by Karthik Ganesan
Modified: 2015-02-04 13:20 UTC (History)
9 users (show)

Fixed In Version: kernel-3.18.3-201.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-26 02:31:06 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Output of dmidecode (deleted)
2014-11-14 02:01 UTC, Karthik Ganesan
no flags Details
dmi.log of leove notebook with the same problem on kernel 3.17.8-200.fc20.x86_64 (deleted)
2015-02-03 19:30 UTC, Joao S. O. Bueno
no flags Details

Description Karthik Ganesan 2014-11-13 03:31:47 UTC
Description of problem:

Since updating to kernel version 3.16+, the backlight keys/applet do not control the backlight on my Dell XPS15 (L521X, NVIDIA GeForce GT 630M and integrated Intel(R) HD Graphics 4000 ). 

The backlight keys invoke the OSD display - but, don't actually control the backlight. Manually writing to the /sys/class/backlight/intel_baclight/brightness does not work either.

Adding kernel parameter video.use_native_backlight=0 results in working backlight (via keys and applet). There are two more backlight interfaces in /sys/class/backlight - acpi_video0 and acpi_video1.

Version-Release number of selected component (if applicable):
Current kernel version: 3.17.2

How reproducible:
Always reproducible. 

Steps to Reproduce:
1.Use Fn+F4/Fn+F5 to reduce/increase brightness. 
2.Alternatively, use gnome interface in top bar.
3.Or manually write to /sys/class/backlight/intel_backlight/brightness

Actual results:
Backlight level does not change

Expected results:
Backlight level should change

Additional info:

Comment 1 Hans de Goede 2014-11-13 13:43:42 UTC
Hi,

So it looks like we need to add a quirk for your model for this, can you please do:

sudo dmidecode > dmi.log

And attach the generated dmi.log file here ?

Thanks,

Hans

Comment 2 Karthik Ganesan 2014-11-14 02:01:32 UTC
Created attachment 957386 [details]
Output of dmidecode

Hi Hans,
Here is the file.
Thank you,
-Karthik

Comment 3 Hans de Goede 2014-11-21 12:51:19 UTC
Hi,

Thanks for the dmidecode, I've prepared a patch to send upstream to fix your laptop without needing to specify anything on the kernel commandline.

I've started a scratch kernel build with this patch, please give it a try, and let me know if it fixes things, once I've confirmation this fixes things I'll send it upstream.

Please download kernel-3.17.3-...rpm for your arch from here:
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=8201334
(note this is still building atm)

And install it with:

rpm -ivh kernel-3.17.3-...rpm

Then boot into the new kernel without specifying any special kernel commandline options, and check if the backlight works as expected.

Regards,

Hans

Comment 4 Hans de Goede 2015-01-09 15:52:15 UTC
Hi,

I've done another scratch-build, with the fix for this, please give it a try.

Please download the following rpms:
kernel-3.17.8-...rpm
kernel-core-3.17.8-...rpm
kernel-modules-3.17.8-...rpm

For your arch from here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=8571559
(note this is still building atm)

Save them all to the same directory (which should not contain other rpms) and do:

sudo rpm -ivh kernel-*.rpm

From within that directory.

Then boot into the new kernel without specifying any special kernel commandline options, and check if the backlight works as expected.

Regards,

Hans

Comment 5 Josh Boyer 2015-01-12 14:15:30 UTC
Patch added to Fedora git.  Thanks Hans!

Comment 6 Karthik Ganesan 2015-01-14 04:19:46 UTC
Hello Hans,
Sorry for the tardy reply. Flu season :(. 
I am still running FC20 and did not download the kernels that you had created in time... Should/Can I try to install the FC21 kernel in FC20?
Thanks,
-Karthik

Comment 7 Hans de Goede 2015-01-14 08:00:12 UTC
(In reply to Karthik  Ganesan from comment #6)
> Hello Hans,
> Sorry for the tardy reply. Flu season :(. 
> I am still running FC20 and did not download the kernels that you had
> created in time... Should/Can I try to install the FC21 kernel in FC20?
> Thanks,
> -Karthik

Hi Karthik,

Since you did confirm that adding video.use_native_backlight=0 on the commandline helps I've just gone ahead with the quirk patch for doing that automatically on your model. An official Fedora kernel update with the patch included should show up soonish.

Installing F-21 kernels on F-20 works fine, so if you want you can still give the scratch build a try.

Regards,

Hans

Comment 8 Fedora Update System 2015-01-14 13:14:38 UTC
kernel-3.18.2-200.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kernel-3.18.2-200.fc21

Comment 9 Fedora Update System 2015-01-14 23:59:57 UTC
Package kernel-3.18.2-200.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.18.2-200.fc21'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-0724/kernel-3.18.2-200.fc21
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2015-01-19 20:49:19 UTC
kernel-3.18.3-201.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kernel-3.18.3-201.fc21

Comment 11 Fedora Update System 2015-01-26 02:31:06 UTC
kernel-3.18.3-201.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Joao S. O. Bueno 2015-02-03 19:29:24 UTC
Hi - I've been hit by this on an Lenovo Ideapad - 
still on fedora 20, though, so I will just get the new kernel when I upgrade.

I am adding the data on my hardware as more people might benefit:
Output of grep '.*' /sys/class/dmi/id/*_* 2> /dev/null:

/sys/class/dmi/id/bios_date:07/12/2013
/sys/class/dmi/id/bios_vendor:LENOVO
/sys/class/dmi/id/bios_version:71CN51WW(V1.21)
/sys/class/dmi/id/board_asset_tag:No Asset Tag
/sys/class/dmi/id/board_name:INVALID
/sys/class/dmi/id/board_serial:PE006G0E
/sys/class/dmi/id/board_vendor:LENOVO
/sys/class/dmi/id/board_version:00B98409WIN8 STD SGL
/sys/class/dmi/id/chassis_asset_tag:No Asset Tag
/sys/class/dmi/id/chassis_serial:PE006G0E
/sys/class/dmi/id/chassis_type:10
/sys/class/dmi/id/chassis_vendor:LENOVO
/sys/class/dmi/id/chassis_version:Lenovo IdeaPad Z400 Touch       
/sys/class/dmi/id/product_name:VIWZ1
/sys/class/dmi/id/product_serial:8SSB20E53404K1BR39LN2RE
/sys/class/dmi/id/product_uuid:011C8A01-21C9-11E3-8F81-641C676104A5
/sys/class/dmi/id/product_version:Lenovo IdeaPad Z400 Touch       
/sys/class/dmi/id/sys_vendor:LENOVO

Comment 13 Joao S. O. Bueno 2015-02-03 19:30:50 UTC
Created attachment 987784 [details]
dmi.log of leove notebook with the same problem on kernel  3.17.8-200.fc20.x86_64

Comment 14 Hans de Goede 2015-02-04 13:20:26 UTC
Hi,

(In reply to Joao S. O. Bueno from comment #12)
> Hi - I've been hit by this on an Lenovo Ideapad - 
> still on fedora 20, though, so I will just get the new kernel when I upgrade.
> 
> I am adding the data on my hardware as more people might benefit:
> Output of grep '.*' /sys/class/dmi/id/*_* 2> /dev/null:
> 
> /sys/class/dmi/id/bios_date:07/12/2013
> /sys/class/dmi/id/bios_vendor:LENOVO
> /sys/class/dmi/id/bios_version:71CN51WW(V1.21)
> /sys/class/dmi/id/board_asset_tag:No Asset Tag
> /sys/class/dmi/id/board_name:INVALID
> /sys/class/dmi/id/board_serial:PE006G0E
> /sys/class/dmi/id/board_vendor:LENOVO
> /sys/class/dmi/id/board_version:00B98409WIN8 STD SGL
> /sys/class/dmi/id/chassis_asset_tag:No Asset Tag
> /sys/class/dmi/id/chassis_serial:PE006G0E
> /sys/class/dmi/id/chassis_type:10
> /sys/class/dmi/id/chassis_vendor:LENOVO
> /sys/class/dmi/id/chassis_version:Lenovo IdeaPad Z400 Touch       
> /sys/class/dmi/id/product_name:VIWZ1
> /sys/class/dmi/id/product_serial:8SSB20E53404K1BR39LN2RE
> /sys/class/dmi/id/product_uuid:011C8A01-21C9-11E3-8F81-641C676104A5
> /sys/class/dmi/id/product_version:Lenovo IdeaPad Z400 Touch       
> /sys/class/dmi/id/sys_vendor:LENOVO

Can you please file a new bug for this, component kernel, and put me in the Cc ?

Please also provide the following information in the new bug report:

1) What desktop environment you are using
1.1) If the desktop environment shows an on screen display showing the brightness value when you press the brightness up / down buttons
2) Output of "ls /sys/class/backlight" both with and without "video.use_native_backlight=0"
3) For each directory under /sys/class/backlight cd into that directory and:
3.1) cat max_brightness
3.2) echo $val > brightness, where $val is max_brightness on the first try, and half of  max_brightness on the second try
3.3) check if the echo-ing changes the actual display brightness
3.4) Add a list to the bug with for which directories backlight control works and for which it does not


Note You need to log in before you can comment on or make changes to this bug.