Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1163694 - ValueError: new size will not yield an aligned partition
Summary: ValueError: new size will not yield an aligned partition
Keywords:
Status: CLOSED DUPLICATE of bug 1165714
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1c35f1bcb9d9c99cb9efcd3420a...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-13 10:07 UTC by Kamil Páral
Modified: 2014-11-19 17:15 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-19 17:15:17 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: anaconda-tb (393.05 KB, text/plain)
2014-11-13 10:07 UTC, Kamil Páral
no flags Details
File: anaconda.log (17.17 KB, text/plain)
2014-11-13 10:07 UTC, Kamil Páral
no flags Details
File: environ (2.19 KB, text/plain)
2014-11-13 10:07 UTC, Kamil Páral
no flags Details
File: journalctl (165.50 KB, text/plain)
2014-11-13 10:07 UTC, Kamil Páral
no flags Details
File: lsblk_output (2.18 KB, text/plain)
2014-11-13 10:07 UTC, Kamil Páral
no flags Details
File: nmcli_dev_list (1.55 KB, text/plain)
2014-11-13 10:07 UTC, Kamil Páral
no flags Details
File: os_info (377 bytes, text/plain)
2014-11-13 10:07 UTC, Kamil Páral
no flags Details
File: program.log (26.73 KB, text/plain)
2014-11-13 10:07 UTC, Kamil Páral
no flags Details
File: storage.log (129.91 KB, text/plain)
2014-11-13 10:07 UTC, Kamil Páral
no flags Details
File: ifcfg.log (2.74 KB, text/plain)
2014-11-13 10:07 UTC, Kamil Páral
no flags Details
File: packaging.log (371 bytes, text/plain)
2014-11-13 10:07 UTC, Kamil Páral
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1162215 0 unspecified CLOSED partition resize does not check filesystem minimum size 2022-05-16 11:32:56 UTC
Red Hat Bugzilla 1163410 0 unspecified CLOSED shrinking partition to an absolutely minimum size results in an error 2022-05-16 11:32:56 UTC
Red Hat Bugzilla 1165714 0 unspecified CLOSED ValueError: new size will not yield an aligned partition 2022-05-16 11:32:56 UTC

Internal Links: 1162215 1163410 1165714

Description Kamil Páral 2014-11-13 10:07:05 UTC
Description of problem:
This happened while testing bug 1163410 comment 1. I used a standard ext4 partition, that I tried to shrink in a guided dialog. I selected a value somewhere in the middle of the shrinking slider and confirmed.

Version-Release number of selected component:
anaconda-core-21.48.13-1.fc21.x86_64

The following was filed automatically by anaconda:
anaconda 21.48.13-1 exception report
Traceback (most recent call first):
  File "/tmp/updates/blivet/devices.py", line 1550, in _setTargetSize
    raise ValueError("new size will not yield an aligned partition")
  File "/tmp/updates/blivet/devices.py", line 752, in <lambda>
    lambda s, v: s._setTargetSize(v),
  File "/tmp/updates/blivet/deviceaction.py", line 443, in apply
    self.device.targetSize = self._targetSize
  File "/tmp/updates/blivet/devicetree.py", line 492, in registerAction
    action.apply()
  File "/tmp/updates/blivet/__init__.py", line 1381, in resizeDevice
    self.devicetree.registerAction(action_class(device, new_size))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 439, in _scheduleActions
    self.storage.resizeDevice(device, Size(obj.target))
ValueError: new size will not yield an aligned partition

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base --updates=https://dlehman.fedorapeople.org/updates/updates-1163410.0.img
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Workstation-x86_64-2 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.17.2-300.fc21.x86_64
other involved packages: anaconda-gui-21.48.13-1.fc21.x86_64
product:        Fedora"
release:        Fedora release 21 (Twenty One)
type:           anaconda
version:        Fedora

Comment 1 Kamil Páral 2014-11-13 10:07:08 UTC
Created attachment 957074 [details]
File: anaconda-tb

Comment 2 Kamil Páral 2014-11-13 10:07:10 UTC
Created attachment 957075 [details]
File: anaconda.log

Comment 3 Kamil Páral 2014-11-13 10:07:11 UTC
Created attachment 957076 [details]
File: environ

Comment 4 Kamil Páral 2014-11-13 10:07:13 UTC
Created attachment 957077 [details]
File: journalctl

Comment 5 Kamil Páral 2014-11-13 10:07:15 UTC
Created attachment 957078 [details]
File: lsblk_output

Comment 6 Kamil Páral 2014-11-13 10:07:16 UTC
Created attachment 957079 [details]
File: nmcli_dev_list

Comment 7 Kamil Páral 2014-11-13 10:07:17 UTC
Created attachment 957080 [details]
File: os_info

Comment 8 Kamil Páral 2014-11-13 10:07:19 UTC
Created attachment 957081 [details]
File: program.log

Comment 9 Kamil Páral 2014-11-13 10:07:21 UTC
Created attachment 957082 [details]
File: storage.log

Comment 10 Kamil Páral 2014-11-13 10:07:22 UTC
Created attachment 957083 [details]
File: ifcfg.log

Comment 11 Kamil Páral 2014-11-13 10:07:23 UTC
Created attachment 957084 [details]
File: packaging.log

Comment 12 Kamil Páral 2014-11-13 10:15:01 UTC
David, is this caused by your updates.img, or a generic bug in anaconda/blivet? In that latter case I think I should propose it as a blocker.

Comment 13 David Lehman 2014-11-13 14:34:44 UTC
This is caused by the updates image from 1163410. It needs a newer anaconda, which I didn't include in the image.

Comment 14 Kamil Páral 2014-11-13 14:40:39 UTC
I can retest with F21 TC2, if you rebase the updates.img.

Comment 15 Kamil Páral 2014-11-19 13:18:34 UTC
I wasn't able to hit this with https://admin.fedoraproject.org/updates/python-blivet-0.61.10-1.fc21,anaconda-21.48.15-1.fc21 . But, for the record, it was very hard to hit even with the original version.

Comment 16 Kamil Páral 2014-11-19 14:27:35 UTC
By accident I reproduced this again, reported as bug 1165714. I guess it can be marked as a duplicate of this one?

Comment 17 Kamil Páral 2014-11-19 14:32:13 UTC
I'm proposing this as a Final blocker. It's not easy to reproduce and I don't know about any reliable reproducer. But it seems to be happening quite often (twice in a few days for me), and the only thing needed is using the guided partitioning. That is likely to break some of the guided part criteria:
https://fedoraproject.org/wiki/Fedora_21_Beta_Release_Criteria#Guided_partitioning

David, your input for blocker bug meeting purposes would be very welcome, either here or by attending in person. Thanks.

Comment 18 David Lehman 2014-11-19 15:37:38 UTC
Let's keep 1165714 open since it does not depend on the updates image.

Comment 19 Kamil Páral 2014-11-19 17:15:17 UTC
Closing this bug in favor of bug 1165714, transferring blocker nomination.

*** This bug has been marked as a duplicate of bug 1165714 ***


Note You need to log in before you can comment on or make changes to this bug.