Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1170289 - shim spec file hardcodes DEFAULT_LOADER=grubx64.efi even for aarch64
Summary: shim spec file hardcodes DEFAULT_LOADER=grubx64.efi even for aarch64
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: shim
Version: 21
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARM64, F-ExcludeArch-aarch64
TreeView+ depends on / blocked
 
Reported: 2014-12-03 17:09 UTC by Laszlo Ersek
Modified: 2015-01-14 03:23 UTC (History)
5 users (show)

Fixed In Version: shim-0.8-2.fc21,shim-signed-0.8-5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-14 03:23:06 UTC
Type: Bug


Attachments (Terms of Use)

Description Laszlo Ersek 2014-12-03 17:09:09 UTC
*** Description of problem:
The spec file says

make 'DEFAULT_LOADER=\\\\grubx64.efi' ${MAKEFLAGS} shim.efi MokManager.efi fallback.efi

for which reason shim tries to load "grubx64.efi", which is not correct
on aarch64. Found while testing PXE booting.

*** Version-Release number of selected component (if applicable):
since shim-0.5-1

*** How reproducible:
100%

*** Steps to Reproduce:
1. Configure PXE boot on an aarch64 client system (can be a physical host, a
   virtualized KVM guest, or an emulated QEMU guest too). The boot file name
   returned by dhcpd or dnsmasq should be "shim.efi", as the various
   installation guides explain.
2. put grubaa64.efi beside shim.efi in the TFTP directory
3. initiate PXE boot

*** Actual results:
The shim.efi binary is loaded and executed. Then shim.efi tries to load grubx64.efi instead of grubaa64.efi, and fails.

*** Expected results:
shim should search for the grub binary under the architecture-matching name (grubaa64.efi)

Comment 2 Marcin Juszkiewicz 2014-12-04 10:49:41 UTC
Other way to reproduce: boot RC5 installer:

Shell> fs0:\EFI\BOOT\BOOTAA64.EFI
Failed to open \EFI\BOOT\grubx64.efi - Not Found
Failed to load image \EFI\BOOT\grubx64.efi: Not Found


Note You need to log in before you can comment on or make changes to this bug.