Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1177383 - [abrt] flumotion: common.py:393:assertSSLAvailable:AttributeError: 'module' object has no attribute 'sslEnabled'
Summary: [abrt] flumotion: common.py:393:assertSSLAvailable:AttributeError: 'module' o...
Keywords:
Status: CLOSED DUPLICATE of bug 833548
Alias: None
Product: Fedora
Classification: Fedora
Component: flumotion
Version: 21
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Vander Stichele
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:df3bf7cfb1c90783fb7cefd8655...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-26 20:09 UTC by Sylvain Arth
Modified: 2015-05-08 13:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-08 13:00:11 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.02 KB, text/plain)
2014-12-26 20:09 UTC, Sylvain Arth
no flags Details
File: environ (194 bytes, text/plain)
2014-12-26 20:09 UTC, Sylvain Arth
no flags Details

Description Sylvain Arth 2014-12-26 20:09:44 UTC
Description of problem:
I probably did a "systemctl start fluemotion.service" with an uncustomized configuration

Version-Release number of selected component:
flumotion-0.10.0-9.fc21

Additional info:
reporter:       libreport-2.3.0
cmdline:        /usr/bin/python /usr/bin/flumotion-manager -D --daemonize-to /var/cache/flumotion --service-name default /etc/flumotion/managers/default/planet.xml
executable:     /usr/bin/flumotion-manager
kernel:         3.17.6-300.fc21.i686
runlevel:       N 5
type:           Python
uid:            444

Truncated backtrace:
common.py:393:assertSSLAvailable:AttributeError: 'module' object has no attribute 'sslEnabled'

Traceback (most recent call last):
  File "/usr/bin/flumotion-manager", line 42, in <module>
    boot.boot(PROGRAM_PATH, gst=False, gtk=False, installReactor=False)
  File "/usr/lib/flumotion/python/flumotion/common/boot.py", line 305, in boot
    sys.exit(wrapped(sys.argv))
  File "/usr/lib/flumotion/python/flumotion/manager/main.py", line 231, in main
    configure.configdir)
  File "/usr/lib/flumotion/python/flumotion/common/server.py", line 99, in startSSL
    common.assertSSLAvailable()
  File "/usr/lib/flumotion/python/flumotion/common/common.py", line 393, in assertSSLAvailable
    if not posixbase.sslEnabled:
AttributeError: 'module' object has no attribute 'sslEnabled'

Local variables in innermost frame:
posixbase: <module 'twisted.internet.posixbase' from '/usr/lib/python2.7/site-packages/twisted/internet/posixbase.pyc'>
errors: <module 'flumotion.common.errors' from '/usr/lib/flumotion/python/flumotion/common/errors.py'>

Potential duplicate: bug 833548

Comment 1 Sylvain Arth 2014-12-26 20:09:47 UTC
Created attachment 973300 [details]
File: backtrace

Comment 2 Sylvain Arth 2014-12-26 20:09:49 UTC
Created attachment 973301 [details]
File: environ

Comment 3 Sergio Basto 2015-05-08 13:00:11 UTC

*** This bug has been marked as a duplicate of bug 833548 ***


Note You need to log in before you can comment on or make changes to this bug.