Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1189272 - ipa-client-install fails with No module named dbus on Fedora-Cloud-Base-20141203-21.x86_64.raw.xz
Summary: ipa-client-install fails with No module named dbus on Fedora-Cloud-Base-20141...
Keywords:
Status: CLOSED DUPLICATE of bug 1185132
Alias: None
Product: Fedora
Classification: Fedora
Component: freeipa
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: IPA Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-04 20:42 UTC by Jan Pazdziora
Modified: 2015-02-04 20:54 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-04 20:54:09 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Jan Pazdziora 2015-02-04 20:42:17 UTC
Description of problem:

When running Fedora 21 from Fedora-Cloud-Base-20141203-21.x86_64.raw.xz, I install the freeipa-client package (and let yum get all the dependencies). I then run ipa-client-install and it fails.

Version-Release number of selected component (if applicable):

freeipa-client-4.1.2-1.fc21.x86_64

How reproducible:

Deterministic.

Steps to Reproduce:
1. Start Fedora from the cloud base image.
2. Install freeipa-client.
3. Run ipa-client-install to IPA-enroll your machine.

Actual results:

There was a problem importing one of the required Python modules. The
error was:

    No module named dbus

Expected results:

Discovery was successful!
Hostname: server.example.test
Realm: EXAMPLE.TEST
[...]

Additional info:

Manually installing dbus-python-1.2.0-7.fc21.x86_64 helps but it should be pulled in via dependencies.

Comment 1 Rob Crittenden 2015-02-04 20:54:09 UTC

*** This bug has been marked as a duplicate of bug 1185132 ***


Note You need to log in before you can comment on or make changes to this bug.