Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1190004 - SELinux denials cause anaconda to fail to start on x86_64 20140204 Workstation Live
Summary: SELinux denials cause anaconda to fail to start on x86_64 20140204 Workstatio...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F22FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2015-02-06 04:08 UTC by Mike Ruckman
Modified: 2015-02-07 07:08 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-07 07:08:08 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
ABRT information. (2.26 KB, application/x-gzip)
2015-02-06 04:08 UTC, Mike Ruckman
no flags Details

Description Mike Ruckman 2015-02-06 04:08:16 UTC
Created attachment 988667 [details]
ABRT information.

Description of problem:
Attempted to launch anaconda from the 20140204 Workstation Live image and Ananconda crashed.

Version-Release number of selected component (if applicable):
anaconda-core-22.17-1.fc22

How reproducible:
Always

Steps to Reproduce:
1. Boot 20140204 Workstation live image
2. Attempt to start installation (from initial screen or from shell)
3. Anaconda fails to start.

Actual results:
Anaconda crashes.

Expected results:
Anaconda launches and completes installation.

Additional info:
This seems to be related to the selinux issues in the following bugs:
 - 1182640
 - 1185455
 - 1188888
 - 1188889

Disabling selinux allows the network to connect and anaconda to finish the install.

Comment 1 Mike Ruckman 2015-02-06 04:09:27 UTC
Proposing as a Final blocker: "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop." - https://fedoraproject.org/wiki/Fedora_22_Final_Release_Criteria#SELinux_and_crash_notifications

Comment 2 David Shea 2015-02-06 07:54:24 UTC
if [ -x /usr/sbin/getenforce ]; then
    current=$(/usr/sbin/getenforce)
    /usr/sbin/setenforce 0
fi

is one of the first things that the liveinst script does. Is getenforce missing? Did you turn enforcing back on?

Comment 3 Mike Ruckman 2015-02-06 16:10:03 UTC
getenforce isn't missing from the image and I didn't alter anything to get this crash. Just click the install button (tried it from the DE launch popup as well as from the shortcut bar in gnome-shell).

Comment 4 Mike Ruckman 2015-02-07 05:30:10 UTC
After building an image with selinux-policy-3.13.1-110.fc22.noarch, the problem seems to be resolved. Anaconda allows a clean install with no errors.

Comment 5 David Shea 2015-02-07 07:08:08 UTC
Ok. Closing per comment 4.


Note You need to log in before you can comment on or make changes to this bug.