Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1192555 - [abrt] flumotion: service.py:88:_parseManagersWorkers:FatalError: No worker with name admin
Summary: [abrt] flumotion: service.py:88:_parseManagersWorkers:FatalError: No worker w...
Keywords:
Status: CLOSED DUPLICATE of bug 880366
Alias: None
Product: Fedora
Classification: Fedora
Component: flumotion
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Vander Stichele
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:67c8bb7550ccafec2db3f43feeb...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-13 16:56 UTC by Allan Lewis
Modified: 2015-05-08 13:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-08 13:20:20 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (937 bytes, text/plain)
2015-02-13 16:56 UTC, Allan Lewis
no flags Details
File: environ (2.38 KB, text/plain)
2015-02-13 16:56 UTC, Allan Lewis
no flags Details

Description Allan Lewis 2015-02-13 16:56:48 UTC
Version-Release number of selected component:
flumotion-0.10.0-7.fc20

Additional info:
reporter:       libreport-2.2.3
cmdline:        /usr/bin/python /usr/sbin/flumotion -C /tmp/tmpOs9a0d.flumotion/etc -L /tmp/tmpOs9a0d.flumotion/var/log -R /tmp/tmpOs9a0d.flumotion/var/run stop worker admin
executable:     /usr/sbin/flumotion
kernel:         3.17.7-200.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
service.py:88:_parseManagersWorkers:FatalError: No worker with name admin

Traceback (most recent call last):
  File "/usr/sbin/flumotion", line 58, in <module>
    _run_main(PROGRAM_PATH)
  File "/usr/sbin/flumotion", line 51, in _run_main
    sys.exit(main(sys.argv))
  File "/usr/lib64/flumotion/python/flumotion/service/main.py", line 83, in main
    return servicer.stop(args[2:])
  File "/usr/lib64/flumotion/python/flumotion/service/service.py", line 183, in stop
    (managers, workers) = self._parseManagersWorkers('stop', args)
  File "/usr/lib64/flumotion/python/flumotion/service/service.py", line 88, in _parseManagersWorkers
    raise errors.FatalError, 'No worker with name %s' % name
FatalError: No worker with name admin

Local variables in innermost frame:
managers: []
name: 'admin'
workers: []
args: ['worker', 'admin']
command: 'stop'
which: 'worker'
self: <flumotion.service.service.Servicer instance at 0x1529320>

Potential duplicate: bug 904680

Comment 1 Allan Lewis 2015-02-13 16:56:50 UTC
Created attachment 991442 [details]
File: backtrace

Comment 2 Allan Lewis 2015-02-13 16:56:51 UTC
Created attachment 991443 [details]
File: environ

Comment 3 Sergio Basto 2015-05-08 13:20:20 UTC

*** This bug has been marked as a duplicate of bug 880366 ***


Note You need to log in before you can comment on or make changes to this bug.