Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1194612 - Please move mptspi.ko.xz (and related modules) to kernel-core
Summary: Please move mptspi.ko.xz (and related modules) to kernel-core
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-20 11:23 UTC by Sitsofe Wheeler
Modified: 2015-03-09 08:16 UTC (History)
6 users (show)

Fixed In Version: kernel-3.18.8-201.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-09 08:16:58 UTC
Type: Bug


Attachments (Terms of Use)

Description Sitsofe Wheeler 2015-02-20 11:23:06 UTC
Description of problem:
It is not possible to boot the cloud image when using VMware Fusion 7 as a host.

Version-Release number of selected component (if applicable):
kernel-core-3.18.7-200.fc21.x86_64
kernel-modules-3.18.7-200.fc21.x86_64

How reproducible:
Reproducible every time.

Steps to Reproduce:
1. Download the Fedora cloud image (https://getfedora.org/en_GB/cloud/download/ ).
2. Convert the raw disk to a VMDK (e.g.
qemu-img convert -O vmdk -o adapter_type=lsilogic Fedora-Cloud-Base-20141203-21.x86_64.raw Fedora-Cloud-Base-20141203-21.x86_64.vmdk
). 
3. Create a new VM and ensure the disk type is set to SCSI (VMware Fusion 7.1.1).
4. Boot the VM. 

Actual results:
Hang.

Expected results:
VM to finish booting.

Additional info:
Closer inspection shows the issue is because the "disk" requires the "Fusion MPT SPI Host" driver which isn't present in the base cloud image but is part of the kernel-modules package. If you can somehow get the kernel-modules RPM into the image and then rerun dracut this problem goes away.

Comment 1 Josh Boyer 2015-02-20 16:46:27 UTC
OK.  I've moved the modules into kernel-core on f21-rawhide.  Should be in the next build of each.

Comment 2 Fedora Update System 2015-03-02 12:34:32 UTC
kernel-3.18.8-201.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kernel-3.18.8-201.fc21

Comment 3 Fedora Update System 2015-03-04 10:27:27 UTC
Package kernel-3.18.8-201.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.18.8-201.fc21'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-3011/kernel-3.18.8-201.fc21
then log in and leave karma (feedback).

Comment 4 Sitsofe Wheeler 2015-03-04 16:34:30 UTC
This seems to be fixed:
# cat /sys/block/sda/device/subsystem/devices/host0/scsi_host/host0/subsystem/host32/proc_name
mptspi
# lsmod | grep mptspi
mptspi                 22552  0 
mptscsih               38664  1 mptspi
mptbase               103883  2 mptspi,mptscsih
scsi_transport_spi     30176  1 mptspi
# rpm -ql kernel-core | grep mpt
/lib/modules/3.18.8-201.fc21.x86_64/kernel/drivers/message/fusion/mptbase.ko.xz
/lib/modules/3.18.8-201.fc21.x86_64/kernel/drivers/message/fusion/mptlan.ko.xz
/lib/modules/3.18.8-201.fc21.x86_64/kernel/drivers/message/fusion/mptsas.ko.xz
/lib/modules/3.18.8-201.fc21.x86_64/kernel/drivers/message/fusion/mptscsih.ko.xz
/lib/modules/3.18.8-201.fc21.x86_64/kernel/drivers/message/fusion/mptspi.ko.xz
/lib/modules/3.18.8-201.fc21.x86_64/kernel/drivers/scsi/mpt2sas
/lib/modules/3.18.8-201.fc21.x86_64/kernel/drivers/scsi/mpt3sas

This looks fixed to me!

Comment 5 Fedora Update System 2015-03-09 08:16:58 UTC
kernel-3.18.8-201.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.