Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1197313 - firefox 36.0-1.fc21 removed -remote option, breaking exo-open
Summary: firefox 36.0-1.fc21 removed -remote option, breaking exo-open
Alias: None
Product: Fedora
Classification: Fedora
Component: exo
Version: 21
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
: 1197472 1197611 1199586 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2015-02-28 09:44 UTC by Panu Matilainen
Modified: 2015-03-16 07:50 UTC (History)
11 users (show)

Fixed In Version: exo-0.10.2-9.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2015-03-14 09:18:36 UTC
Type: Bug

Attachments (Terms of Use)
Remove use of -remote in firefox helper (672 bytes, patch)
2015-02-28 14:31 UTC, Panu Matilainen
no flags Details | Diff

Description Panu Matilainen 2015-02-28 09:44:14 UTC
Description of problem:

URL passed via -remote "openURL(<url>)" is not honored, instead a new window on home page is opened.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:

1. Start Firefox
2. From a terminal, run:
   firefox -remote "openURL("

Actual results:
A new window with home page is opened.

Expected results:
A new window on the specified URL, in the example but not specific to it, is opened.

Additional info:
This breaks opening links from other applications via xdg-open. The bug appeared on update to firefox-36.0-1.fc21.

Comment 1 Christian Klomp 2015-02-28 13:28:30 UTC
This option has been removed in Firefox 36 (see
In comment #5 an alternative is given for opening a URL in a new tab (-remote openurl(url,new-tab) -> -new-tab <url>).

Some other applications indeed seem to have difficulties with this change (like the browse-url library from Emacs as stated in that bz item) but I've tried xdg-open and it opened the URL fine.

Comment 2 Panu Matilainen 2015-02-28 13:36:02 UTC
Yeah, just noticed that as well.

It seems many/most of the helpers invoked by xdg-open are not affected by this, eg at least gvfs-open, gnome-open, kde-open still function. I'm seeing this on XFCE where exo-open is used, and its well reproducable with 'exo-open <url>'. Perhaps that's the last dinosaur using -remote and we just need to deal with it, no matter annoying this kind of breakage in stable release updates is.

Switching component to exo.

Comment 3 Panu Matilainen 2015-02-28 14:31:21 UTC
Created attachment 996458 [details]
Remove use of -remote in firefox helper

AFAICS it doesn't need anything fancier than this - firefox does the right thing when an URL is passed on the command line. I seem to recall a time when it (or maybe it was mozilla prior to that) didn't, but that'd be some 10+ years ago.

Comment 4 Kevin Fenzi 2015-02-28 18:29:19 UTC
So, We had about thunderbird and this issue, but no one there could reply that this change fixed it for them. sad. 

This was changed in xfce bug and will be in the new exo just released today. So, that takes care of rawhide. 

We need to figure if we are pushing to f22, or older with the new version and backport if not.

Comment 5 Cristian Ciupitu 2015-02-28 21:50:44 UTC
This problem exists on Fedora 20 too.

Comment 6 Kevin Fenzi 2015-03-01 16:22:01 UTC
*** Bug 1197472 has been marked as a duplicate of this bug. ***

Comment 7 Jason Montleon 2015-03-03 17:24:36 UTC
Fedora 21 scratch build; seems to fix it for me.

Comment 8 Fedora Update System 2015-03-03 18:38:59 UTC
exo-0.10.2-9.fc21 has been submitted as an update for Fedora 21.

Comment 9 Fedora Update System 2015-03-03 18:40:23 UTC
exo-0.10.2-9.fc20 has been submitted as an update for Fedora 20.

Comment 10 Tomas Hoger 2015-03-03 20:15:13 UTC
In the meantime, changing the last two lines in the /usr/share/xfce4/helpers/firefox.desktop file to the following fixes this issue:

X-XFCE-CommandsWithParameter=%B %s;

That's equivalent to upstream fix:

Comment 11 Tomas Hoger 2015-03-03 20:16:29 UTC
Oops, unintended state change because of mid-air collision.

Comment 12 Thomas Moschny 2015-03-04 08:51:08 UTC
*** Bug 1197611 has been marked as a duplicate of this bug. ***

Comment 13 Rex Dieter 2015-03-04 12:36:49 UTC
*** Bug 1197611 has been marked as a duplicate of this bug. ***

Comment 14 Fedora Update System 2015-03-05 12:35:15 UTC
Package exo-0.10.2-9.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing exo-0.10.2-9.fc21'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).

Comment 15 Martin Stransky 2015-03-05 13:14:07 UTC
Upstream decided to revert te change so the -remote options has been added back in firefox-36.0-3.fc23 (see

Comment 16 Kevin Fenzi 2015-03-05 13:36:25 UTC
Lovely. This change should still be ok however right? -remote is not required, just allowed...

Comment 17 Martin Stransky 2015-03-05 13:47:56 UTC
Sure, it's okay.

Comment 18 Kevin Fenzi 2015-03-06 18:50:14 UTC
*** Bug 1199586 has been marked as a duplicate of this bug. ***

Comment 19 Fedora Update System 2015-03-14 09:18:36 UTC
exo-0.10.2-9.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2015-03-14 09:20:46 UTC
exo-0.10.2-9.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Samo Dadela 2015-03-16 07:50:42 UTC
FC21 stable works. Thanks.

Note You need to log in before you can comment on or make changes to this bug.