Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1204408 - local variable 'app' referenced before assignment
Summary: local variable 'app' referenced before assignment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-abrt
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Filak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 1205930 1206136 1206290 (view as bug list)
Depends On: 1204524
Blocks: F22FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2015-03-21 18:33 UTC by Tim Waugh
Modified: 2016-12-01 00:48 UTC (History)
9 users (show)

Fixed In Version: gnome-abrt-1.1.0-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-29 04:49:24 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Tim Waugh 2015-03-21 18:33:40 UTC
Description of problem:
$ gnome-abrt 
Namespace(expert=False, problem=None, verbose=None)
/usr/lib64/python3.4/site-packages/gi/overrides/__init__.py:306: Warning: The property GSettings:schema is deprecated and shouldn't be used anymore. It will be removed in a future version.
  return super_init_func(self, **new_kwargs)

(gnome-abrt:8836): Gtk-CRITICAL **: gtk_header_bar_pack: assertion 'gtk_widget_get_parent (widget) == NULL' failed
ERROR:root:local variable 'app' referenced before assignment
Traceback (most recent call last):
  File "/usr/bin/gnome-abrt", line 275, in do_activate
    main_window = OopsWindow(self, self.all_sources, controller)
  File "/usr/lib64/python3.4/site-packages/gnome_abrt/views.py", line 469, in __init__
    self._reload_problems(self._source)
  File "/usr/lib64/python3.4/site-packages/gnome_abrt/views.py", line 700, in _reload_problems
    storage_problems.append(problem_to_storage_values(p))
  File "/usr/lib64/python3.4/site-packages/gnome_abrt/views.py", line 127, in problem_to_storage_values
    app = problem.get_application()
  File "/usr/lib64/python3.4/site-packages/gnome_abrt/problems.py", line 275, in get_application
    self['pid'])
  File "/usr/lib64/python3.4/site-packages/gnome_abrt/application.py", line 39, in find_application
    if not app:
UnboundLocalError: local variable 'app' referenced before assignment

Version-Release number of selected component (if applicable):
gnome-abrt-1.1.0-1.fc22.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Start gnome-abrt

Comment 1 Chris Murphy 2015-03-23 14:45:03 UTC
This is happening on launch in Fedora 22 Workstation Beta TC4.

Comment 2 Fedora Blocker Bugs Application 2015-03-23 14:51:07 UTC
Proposed as a Blocker for 22-final by Fedora user chrismurphy using the blocker tracking app because:

 "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test. "

Comment 3 Adam Williamson 2015-03-23 17:18:53 UTC
Discussed at 2015-03-23 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2015-03-23/f22-blocker-review.2015-03-23-16.02.log.txt . Accepted as a Final blocker per criterion cited in #c2.

Comment 4 Jakub Filak 2015-03-23 17:24:34 UTC
Upstream commit https://github.com/abrt/gnome-abrt/commit/6b2ca4019c0c43e4e9ea6a5f59871b8286dc9818 fixes this bug.

Comment 5 Fedora Update System 2015-03-24 01:54:52 UTC
gnome-abrt-1.1.0-2.fc22, abrt-2.5.0-2.fc22, libreport-2.5.0-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-4290/gnome-abrt-1.1.0-2.fc22,abrt-2.5.0-2.fc22,libreport-2.5.0-2.fc22

Comment 6 Jakub Filak 2015-03-26 05:38:51 UTC
*** Bug 1205930 has been marked as a duplicate of this bug. ***

Comment 7 Jakub Filak 2015-03-26 12:36:40 UTC
*** Bug 1206136 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2015-03-26 22:08:15 UTC
Package gnome-abrt-1.1.0-2.fc22, abrt-2.5.0-2.fc22, libreport-2.5.0-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-abrt-1.1.0-2.fc22 abrt-2.5.0-2.fc22 libreport-2.5.0-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-4290/gnome-abrt-1.1.0-2.fc22,abrt-2.5.0-2.fc22,libreport-2.5.0-2.fc22
then log in and leave karma (feedback).

Comment 9 Jakub Filak 2015-03-27 05:25:32 UTC
*** Bug 1206290 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2015-03-29 04:49:24 UTC
gnome-abrt-1.1.0-2.fc22, abrt-2.5.0-2.fc22, libreport-2.5.0-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.