Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1206764 - PulseAudio 6 update breaks autostart
Summary: PulseAudio 6 update breaks autostart
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1209200 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-28 10:50 UTC by Markus S.
Modified: 2015-12-12 14:48 UTC (History)
9 users (show)

Fixed In Version: pulseaudio-6.0-2.fc21.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-08 06:56:53 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
contents of /etc/pulse/daemon.conf (2.21 KB, text/plain)
2015-04-04 21:17 UTC, paul59584
no flags Details
contents of /etc/pulse/client.conf (1.17 KB, text/plain)
2015-04-04 21:18 UTC, paul59584
no flags Details

Description Markus S. 2015-03-28 10:50:00 UTC
Description of problem:
Nothing plays sound. alsamixer says "connection refused".

Version-Release number of selected component (if applicable):
6.0

How reproducible:
Always

Steps to Reproduce:
1. Try to play something

Actual results:
No sound.

Expected results:
Sound.

Additional info:
Downgrade to PA 5.0 works.
Maybe related to Bug 1206731 (which is about F22, not F21)

Comment 1 Rex Dieter 2015-03-28 13:55:59 UTC
Try restarting your session after installing the update?

Can you attach the output from:
pulseaudio -vvv

Can you attach the output from:
alsa-info.sh
(it may download a newer version of itself, for you to run)

Comment 2 Markus S. 2015-03-28 15:15:01 UTC
Of course I rebooted after the update.

Turns out PulseAudio 6.0 no longer starts by itself. When I run it manually, it runs just fine. *downgrades to 5.0 again*

Comment 3 Rex Dieter 2015-03-28 17:52:58 UTC
1. What happens if you run by hand:

$ start-pulseaudio-x11 

(that's essentially what is supposed to autostart with your session)

2.  What kind of DE/session are you using?  gnome, kde, other?

Comment 4 Markus S. 2015-03-28 21:08:36 UTC
I use Plasma 4.
As for the first question: Is that all you need or will you need additional output? I don't want to upgrade and downgrade all the time.

Comment 5 paul59584 2015-04-02 21:21:15 UTC
I see this too, pulseaudio is not starting

$ journalctl -b | grep -i pulse
Mar 29 18:00:22 localhost gnome-session[1155]: WARNING: App 'pulseaudio.desktop' exited with code 1
Mar 29 18:00:23 localhost gnome-session[1155]: gnome-session[1155]: WARNING: App 'pulseaudio.desktop' exited with code 1

$ pulseaudio -D

starts it and restores sound until next boot

Comment 6 Rex Dieter 2015-04-03 12:17:33 UTC
instead of 'pulseaudio -D', what happens when you try:
start-pulseaudio-x11
?
(that's what runs via /etc/xdg/autostart/pulseaudio.desktop)

Comment 7 paul59584 2015-04-03 19:05:16 UTC
running start-pulseaudio-x11 fails

$ start-pulseaudio-x11
Connection failure: Connection refused
pa_context_connect() failed: Connection refused

$ sudo start-pulseaudio-x11
Connection failure: Connection refused
pa_context_connect() failed: Connection refused

Comment 8 Rex Dieter 2015-04-04 18:30:20 UTC
Please attach/post the contents of 
/etc/pulse/daemon.conf
/etc/pulse/client.conf

Comment 9 paul59584 2015-04-04 21:17:47 UTC
Created attachment 1010937 [details]
contents of /etc/pulse/daemon.conf

Comment 10 paul59584 2015-04-04 21:18:25 UTC
Created attachment 1010938 [details]
contents of /etc/pulse/client.conf

Comment 11 Rex Dieter 2015-04-05 00:44:25 UTC
It's not clear to me why pulseaudio autospawn is failing for you, which those
/usr/bin/pactl load-module ...
calls are supposed to do.


Ah, I forgot one more possibility, check
~/.pulse/client.conf (in addition to /etc/pulse/client.conf)
and see if it contains
autospawn=no

If it does, remove that line, or change to autospawn=yes

Comment 12 paul59584 2015-04-05 00:52:17 UTC
changing
autospawn = no
to
autospawn = yes
in ~/.pulse/client.conf seems to fix it for me. Thank-you Rex.

Comment 13 Rex Dieter 2015-04-05 01:00:27 UTC
OK, I guess we can consider that a regression in autostart behavior, I'll re-add

/usr/bin/pulseaudio --start "$@"

to /usr/bin/start-pulseaudio-x11 script

Comment 14 Fedora Update System 2015-04-05 01:29:29 UTC
pulseaudio-6.0-2.fc21.1 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/pulseaudio-6.0-2.fc21.1

Comment 15 Fedora Update System 2015-04-05 14:33:13 UTC
Package pulseaudio-6.0-2.fc21.1:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pulseaudio-6.0-2.fc21.1'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5586/pulseaudio-6.0-2.fc21.1
then log in and leave karma (feedback).

Comment 16 paul59584 2015-04-06 00:48:32 UTC
I realised I had autospawn = no in ~/.pulse/client.conf for my jack setup, which I use only occasionally. It kills pulse on startup and starts it again with a custom config file. Before update (with autospawn = yes) this was broken. 
After update to pulseaudio-6.0-2.fc21.1 I changed back to autospawn = no and rebooted. All seems to be working as it should.

Comment 17 Fedora Update System 2015-04-08 06:56:53 UTC
pulseaudio-6.0-2.fc21.1 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Rex Dieter 2015-05-29 12:07:29 UTC
*** Bug 1209200 has been marked as a duplicate of this bug. ***

Comment 19 Sylvain Petreolle 2015-06-02 19:18:33 UTC
This happens with Fedora 22 again.
[syl@virt ~]$ rpm -qa pulseaudio pulseaudio-module-x11
pulseaudio-6.0-2.fc22.x86_64
pulseaudio-module-x11-6.0-2.fc22.x86_64

[syl@virt ~]$ LC_ALL=C bash -x start-pulseaudio-x11
...
+ /usr/bin/pactl load-module module-x11-publish display=:0
Connection failure: Connection refused
pa_context_connect() failed: Connection refused

Comment 20 Rex Dieter 2015-06-02 20:13:56 UTC
Re: comment #19

did you disable autospawn?

Comment 21 Sylvain Petreolle 2015-06-02 20:37:13 UTC
Yes, I disabled the autospawn into ~/.pulse/client.conf.

Comment 22 Rex Dieter 2015-06-02 21:15:40 UTC
Why?

Is it some usecase could not be handled by pasuspender ?

Comment 23 Sylvain Petreolle 2015-06-05 20:48:20 UTC
I didn't know about pasuspender.
it doesn't work with aliases, it only accepts programs.

Comment 24 Yves L'ECUYER 2015-06-17 12:11:35 UTC
As Sylvain Petreolle, i noticed that in root environment,( tested in MATE desktop environment ), that pulseaudio does not start at the beginning of the graphic session.
Once logged I also get like Sylvain:
# LC_ALL=C bash -x start-pulseaudio-x11
+ set -e
+ '[' x:0.0 '!=' x ']'
+ /usr/bin/pactl load-module module-x11-publish display=:0.0
Connection failure: Connection refused
pa_context_connect() failed: Connection refused
==
I get this result with autospan enble or not in :
   /etc/pulse/client.conf
(I have no ~/.pulse/client.conf in root home directory!
===
I tried this with last fedora 22 update, and even with the last fedora-updates-testing enabled to install: pulseaudio-6.0-4 (instead of 6.0-2)
# rpm -qa | grep pulseaudio | sort
alsa-plugins-pulseaudio-1.0.29-1.fc22.x86_64
pulseaudio-6.0-4.fc22.x86_64
pulseaudio-libs-6.0-4.fc22.i686
pulseaudio-libs-6.0-4.fc22.x86_64
pulseaudio-libs-glib2-6.0-4.fc22.x86_64
pulseaudio-module-bluetooth-6.0-4.fc22.x86_64
pulseaudio-module-gconf-6.0-4.fc22.x86_64
pulseaudio-module-x11-6.0-4.fc22.x86_64
pulseaudio-utils-6.0-4.fc22.x86_64
wine-pulseaudio-1.7.44-1.fc22.i686
wine-pulseaudio-1.7.44-1.fc22.x86_64
==== 
So currently the only bug turn around is the suggestion of Rex Dieter in comment 7 of the following bugzilla entry:
https://bugzilla.redhat.com/show_bug.cgi?id=1209200
==> 
insert
/usr/bin/pulseaudio --start
in the file:  /usr/bin/start-pulseaudio-x11

Comment 25 Israel 2015-06-22 12:30:28 UTC
I confirm that pulseaudio does NOT run under the root environment.
FC 22 pulseaudio 6.0-4.fc22


Note You need to log in before you can comment on or make changes to this bug.