Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1207577 - [ghostscript] crashes because of missing fonts
Summary: [ghostscript] crashes because of missing fonts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ghostscript
Version: 22
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Grulich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-31 08:54 UTC by Joachim Frieben
Modified: 2015-04-26 12:48 UTC (History)
1 user (show)

Fixed In Version: ghostscript-9.16-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-25 05:13:35 UTC
Type: Bug


Attachments (Terms of Use)
Sample PS file "Antisym.eps" (333.98 KB, image/x-eps)
2015-03-31 08:54 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2015-03-31 08:54:48 UTC
Created attachment 1008895 [details]
Sample PS file "Antisym.eps"

Description of problem:
Running ghostscript from the command line to display a sample PS file results in a crash with the following output to the shell:

$ ghostscript Antisym.eps
GPL Ghostscript 9.16 (2015-03-30)
Copyright (C) 2015 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Can't find (or can't open) font file /usr/share/ghostscript/9.16/Resource/Font/NimbusSan-Reg.
Can't find (or can't open) font file NimbusSan-Reg.
Can't find (or can't open) font file /usr/share/ghostscript/9.16/Resource/Font/NimbusSan-Reg.
Can't find (or can't open) font file NimbusSan-Reg.
Querying operating system for font files...
Can't find (or can't open) font file /usr/share/ghostscript/9.16/Resource/Font/NimbusSan-Reg.
Can't find (or can't open) font file NimbusSan-Reg.
Didn't find this font on the system!
Substituting font Courier for NimbusSan-Reg.
Can't find (or can't open) font file /usr/share/ghostscript/9.16/Resource/Font/NimbusMon-Reg.
Can't find (or can't open) font file NimbusMon-Reg.
Can't find (or can't open) font file /usr/share/ghostscript/9.16/Resource/Font/NimbusMon-Reg.
Can't find (or can't open) font file NimbusMon-Reg.
Didn't find this font on the system!
Unable to substitute for font.
Error: /invalidfont in /findfont
Operand stack:
   423.333   Helvetica
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1951   1   3   %oparray_pop   1950   1   3   %oparray_pop   --nostringval--   1934   1   3   %oparray_pop   1820   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   1903   2   4   %oparray_pop
Dictionary stack:
   --dict:1183/1684(ro)(G)--   --dict:0/20(G)--   --dict:83/200(L)--   --dict:23/40(L)--
Current allocation mode is local
Last OS error: No such file or directory
Current file position is 1877
GPL Ghostscript 9.16: Unrecoverable error, exit code 1

Version-Release number of selected component (if applicable):
ghostscript-9.16-1.fc22

How reproducible:
Always

Steps to Reproduce:
1. Run 'ghostscript Antisym.eps'

Actual results:
Ghostscript crashes.

Expected results:
Ghostscript displays the sample PS file.

Additional info:
Used to work with package ghostscript-9.15-6.fc22.

Comment 1 Tim Waugh 2015-03-31 10:01:26 UTC
This is caused by ghostscript using the new font names from urw-fonts, but we're still shipping the old names in that package. I've filed bug #1207607 to coordinate that better.

In the meantime I'll switch ghostscript back to using the old names.

Comment 2 Fedora Update System 2015-03-31 10:55:37 UTC
ghostscript-9.16-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/ghostscript-9.16-2.fc22

Comment 3 Fedora Update System 2015-04-02 01:41:40 UTC
Package ghostscript-9.16-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ghostscript-9.16-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5265/ghostscript-9.16-2.fc22
then log in and leave karma (feedback).

Comment 4 Fedora Admin XMLRPC Client 2015-04-22 11:00:46 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 5 Fedora Update System 2015-04-26 12:48:08 UTC
ghostscript-9.16-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.