Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1211746 - ValueError: new size is too large
Summary: ValueError: new size is too large
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker abrt_hash:3d276ad793c...
: 1040445 1214628 (view as bug list)
Depends On:
Blocks: 1040413 F22FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2015-04-14 19:19 UTC by David Shea
Modified: 2015-05-21 18:44 UTC (History)
12 users (show)

Fixed In Version: anaconda-22.20.13-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-21 18:44:01 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: anaconda-tb (413.39 KB, text/plain)
2015-04-14 19:19 UTC, David Shea
no flags Details
File: anaconda.log (21.38 KB, text/plain)
2015-04-14 19:19 UTC, David Shea
no flags Details
File: dnf.log (7.38 KB, text/plain)
2015-04-14 19:19 UTC, David Shea
no flags Details
File: environ (492 bytes, text/plain)
2015-04-14 19:19 UTC, David Shea
no flags Details
File: lsblk_output (2.43 KB, text/plain)
2015-04-14 19:19 UTC, David Shea
no flags Details
File: nmcli_dev_list (1.07 KB, text/plain)
2015-04-14 19:19 UTC, David Shea
no flags Details
File: os_info (443 bytes, text/plain)
2015-04-14 19:19 UTC, David Shea
no flags Details
File: storage.log (122.82 KB, text/plain)
2015-04-14 19:19 UTC, David Shea
no flags Details
File: syslog (68.33 KB, text/plain)
2015-04-14 19:19 UTC, David Shea
no flags Details
File: ifcfg.log (2.25 KB, text/plain)
2015-04-14 19:19 UTC, David Shea
no flags Details
File: packaging.log (855 bytes, text/plain)
2015-04-14 19:19 UTC, David Shea
no flags Details
File: program.log (33.27 KB, application/octet-stream)
2015-04-14 19:19 UTC, David Shea
no flags Details

Description David Shea 2015-04-14 19:19:25 UTC
Description of problem:
Attempting to resize existing lv

Version-Release number of selected component:
anaconda-22.20.9-1

The following was filed automatically by anaconda:
anaconda 22.20.9-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 433, in __init__
    raise ValueError("new size is too large")
  File "/usr/lib/python2.7/site-packages/blivet/blivet.py", line 1173, in resizeDevice
    self.devicetree.registerAction(action_class(device, new_size))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 778, in _handle_size_change
    self._storage_playground.resizeDevice(use_dev, use_size)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 128, in decorated
    return func(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1186, in _save_right_side
    self._handle_size_change(size, old_size, device)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2647, in on_update_settings_clicked
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/utils.py", line 242, in _run_once_one_arg
    self._func(*args, **kwargs)
ValueError: new size is too large

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-22_B-x86_64 quiet
dnf.rpm.log:    Apr 14 20:10:18 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.0.0-0.rc5.git4.1.fc22.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        22

Comment 1 David Shea 2015-04-14 19:19:31 UTC
Created attachment 1014440 [details]
File: anaconda-tb

Comment 2 David Shea 2015-04-14 19:19:33 UTC
Created attachment 1014441 [details]
File: anaconda.log

Comment 3 David Shea 2015-04-14 19:19:34 UTC
Created attachment 1014442 [details]
File: dnf.log

Comment 4 David Shea 2015-04-14 19:19:35 UTC
Created attachment 1014443 [details]
File: environ

Comment 5 David Shea 2015-04-14 19:19:36 UTC
Created attachment 1014444 [details]
File: lsblk_output

Comment 6 David Shea 2015-04-14 19:19:37 UTC
Created attachment 1014445 [details]
File: nmcli_dev_list

Comment 7 David Shea 2015-04-14 19:19:38 UTC
Created attachment 1014446 [details]
File: os_info

Comment 8 David Shea 2015-04-14 19:19:40 UTC
Created attachment 1014447 [details]
File: storage.log

Comment 9 David Shea 2015-04-14 19:19:41 UTC
Created attachment 1014448 [details]
File: syslog

Comment 10 David Shea 2015-04-14 19:19:42 UTC
Created attachment 1014449 [details]
File: ifcfg.log

Comment 11 David Shea 2015-04-14 19:19:44 UTC
Created attachment 1014450 [details]
File: packaging.log

Comment 12 David Shea 2015-04-14 19:19:45 UTC
Created attachment 1014451 [details]
File: program.log

Comment 13 David Shea 2015-04-14 19:20:37 UTC
*** Bug 1040445 has been marked as a duplicate of this bug. ***

Comment 14 Lukas Brabec 2015-04-23 08:11:03 UTC
Another user experienced a similar problem:

Just tried to reproduce bug 1040413

addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-22_B-x86_64 quiet
dnf.rpm.log:    Apr 23 08:09:06 INFO --- logging initialized ---
hashmarkername: anaconda
kernel:         4.0.0-0.rc5.git4.1.fc22.x86_64
package:        anaconda-22.20.9-1
product:        Fedora
reason:         ValueError: new size is too large
release:        Cannot get release name.
version:        22

Comment 15 Fedora Blocker Bugs Application 2015-04-23 08:40:50 UTC
Proposed as a Blocker for 22-final by Fedora user lbrabec using the blocker tracking app because:

 Violation of beta criterion:
Custom partitioning
When using the custom partitioning flow, the installer must be able to:
Reject or disallow invalid disk and volume configurations without crashing.

and violation of final criterion:
Storage volume resize
Any installer mechanism for resizing storage volumes must correctly attempt the requested operation.

Comment 16 mulhern 2015-04-23 12:28:26 UTC
*** Bug 1214628 has been marked as a duplicate of this bug. ***

Comment 17 Nick Coghlan 2015-04-24 21:02:28 UTC
After encountering this in bug 1214628 while using custom partitioning, I had another attempt using the guided partitioning workflow.

The "reclaim space" dialog in that workflow uses a bounded slider to handle the resizing request on partitions. Would it be possible to also use that slider in the custom partitioning dialogs?

Comment 18 David Gay 2015-04-28 20:53:48 UTC
Discussed at the 2015-04-28 blocker review meeting.[1] Voted as AcceptedBlocker.

Violates criterion "When using the custom partitioning flow, the installer must be able to: Reject or disallow invalid disk and volume configurations without crashing." [#15]

[1]: http://meetbot.fedoraproject.org/fedora-blocker-review/2015-04-28/

Comment 19 Adam Williamson 2015-05-12 00:39:53 UTC
anaconda team, ping - at first blush this looks like it should be fairly straightforward? it's an accepted blocker for F22 so needs fixing fairly soon, thanks!

Comment 20 David Lehman 2015-05-15 17:17:26 UTC
I have a patch. I'll send it for review on Monday at latest.

Comment 21 David Lehman 2015-05-18 15:01:32 UTC
Update image available for testing. Just add the following to your boot command line:

 inst.updates=https://dlehman.fedorapeople.org/updates/updates-1211746.0.img


Please share the results here. Thanks.

Comment 22 Kamil Páral 2015-05-19 10:08:10 UTC
When trying to reproduce this without the update image, I hit bug 1040413, not this one. David, how to reproduce this? Can you verify the updates img?

Comment 23 Kamil Páral 2015-05-19 10:48:07 UTC
(In reply to David Lehman from comment #21)
> Update image available for testing. Just add the following to your boot
> command line:
> 
>  inst.updates=https://dlehman.fedorapeople.org/updates/updates-1211746.0.img
> 

If I use this updates image, I don't hit the bug no matter what I do, and bug 1222811 seems to be fixed.

Comment 24 David Shea 2015-05-19 13:41:50 UTC
(In reply to David Lehman from comment #21)
> Update image available for testing. Just add the following to your boot
> command line:
> 
>  inst.updates=https://dlehman.fedorapeople.org/updates/updates-1211746.0.img
> 
> 
> Please share the results here. Thanks.

Yeah that works.


(In reply to Kamil Páral from comment #22)
> When trying to reproduce this without the update image, I hit bug 1040413,
> not this one. David, how to reproduce this? Can you verify the updates img?

Reproduced with the same steps in bug 1040445. Started with an autopart layout but with space free in the VG, attempted to add space to the root LV.

Comment 25 Stephen Gallagher 2015-05-19 13:45:49 UTC
I can reproduce the bug now with the following steps:

1) Boot Fedora 22 Server Final TC4 (I did this in a VM with an 8GB disk)
2) In storage setup, select manual creation
3) Click on the automatic setup link to generate the initial set of partitions
4) Select the / partition and reduce it's size (I used 1 GB)
5) Run the installation (I used the minimal package set for speed)
6) Reboot the VM and boot into the installer again.
7) Go to custom partitioning. Select each of the partitions and mark them to format (which will bring them up to the upper part of the left side)
8) Change the size of the / partition (I increased it by 1GB)

Anaconda will crash.

Side note: this happened with XFS partitions, which is irrelevant because of the reformatting anyway.

I'm going to test the updates.img now.

Comment 26 Stephen Gallagher 2015-05-19 13:48:17 UTC
I can also confirm that the provided updates.img fixes the bug.

Comment 27 Fedora Update System 2015-05-19 16:52:41 UTC
anaconda-22.20.13-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/anaconda-22.20.13-1.fc22

Comment 28 Fedora Update System 2015-05-20 02:52:57 UTC
Package anaconda-22.20.13-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-22.20.13-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8539/anaconda-22.20.13-1.fc22
then log in and leave karma (feedback).

Comment 29 Kamil Páral 2015-05-21 12:15:11 UTC
This particular problem seems to be fixed, but continuing with the installation, I encountered bug 1221247.

Comment 30 Fedora Update System 2015-05-21 18:44:01 UTC
anaconda-22.20.13-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.