Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1214241 - KeyError: 'fedora-pool'
Summary: KeyError: 'fedora-pool'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker abrt_hash:368be884f8d...
: 1204566 1214008 (view as bug list)
Depends On:
Blocks: F22FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2015-04-22 09:48 UTC by Vratislav Podzimek
Modified: 2015-05-13 01:17 UTC (History)
13 users (show)

Fixed In Version: python-blivet-1.0.9-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-13 01:17:16 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: anaconda-tb (359.09 KB, text/plain)
2015-04-22 09:49 UTC, Vratislav Podzimek
no flags Details
File: anaconda.log (15.78 KB, text/plain)
2015-04-22 09:49 UTC, Vratislav Podzimek
no flags Details
File: dnf.log (10.76 KB, text/plain)
2015-04-22 09:50 UTC, Vratislav Podzimek
no flags Details
File: dnf.rpm.log (147 bytes, text/plain)
2015-04-22 09:50 UTC, Vratislav Podzimek
no flags Details
File: environ (492 bytes, text/plain)
2015-04-22 09:50 UTC, Vratislav Podzimek
no flags Details
File: lsblk_output (5.17 KB, text/plain)
2015-04-22 09:50 UTC, Vratislav Podzimek
no flags Details
File: nmcli_dev_list (1.42 KB, text/plain)
2015-04-22 09:50 UTC, Vratislav Podzimek
no flags Details
File: os_info (443 bytes, text/plain)
2015-04-22 09:50 UTC, Vratislav Podzimek
no flags Details
File: program.log (33.87 KB, text/plain)
2015-04-22 09:50 UTC, Vratislav Podzimek
no flags Details
File: storage.log (105.84 KB, text/plain)
2015-04-22 09:50 UTC, Vratislav Podzimek
no flags Details
File: syslog (94.17 KB, text/plain)
2015-04-22 09:50 UTC, Vratislav Podzimek
no flags Details
File: ifcfg.log (2.44 KB, text/plain)
2015-04-22 09:50 UTC, Vratislav Podzimek
no flags Details
File: packaging.log (1.83 KB, text/plain)
2015-04-22 09:50 UTC, Vratislav Podzimek
no flags Details

Description Vratislav Podzimek 2015-04-22 09:48:51 UTC
Description of problem:
Unlocked LUKS with existing LVM Thin provisioning setup.

Version-Release number of selected component:
anaconda-22.20.9-1

The following was filed automatically by anaconda:
anaconda 22.20.9-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1397, in addRequiredLV
    addLV(lv_info[name])
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1476, in addLV
    addRequiredLV(pool_device_name, "failed to look up thin pool")
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1526, in handleVgLvs
    addLV(lv)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1590, in handleUdevLVMPVFormat
    self.handleVgLvs(vg_device)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1898, in handleUdevDeviceFormat
    self.handleUdevLVMPVFormat(info, device)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1262, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2194, in _populate
    self.addUdevDevice(dev)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2128, in populate
    self._populate()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2680, in on_unlock_clicked
    self._storage_playground.devicetree.populate()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/utils.py", line 242, in _run_once_one_arg
    self._func(*args, **kwargs)
KeyError: 'fedora-pool'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-22_B-x86_64 quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.0.0-0.rc5.git4.1.fc22.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        22

Comment 1 Vratislav Podzimek 2015-04-22 09:49:55 UTC
Created attachment 1017340 [details]
File: anaconda-tb

Comment 2 Vratislav Podzimek 2015-04-22 09:49:57 UTC
Created attachment 1017341 [details]
File: anaconda.log

Comment 3 Vratislav Podzimek 2015-04-22 09:50:01 UTC
Created attachment 1017342 [details]
File: dnf.log

Comment 4 Vratislav Podzimek 2015-04-22 09:50:07 UTC
Created attachment 1017343 [details]
File: dnf.rpm.log

Comment 5 Vratislav Podzimek 2015-04-22 09:50:08 UTC
Created attachment 1017344 [details]
File: environ

Comment 6 Vratislav Podzimek 2015-04-22 09:50:19 UTC
Created attachment 1017345 [details]
File: lsblk_output

Comment 7 Vratislav Podzimek 2015-04-22 09:50:32 UTC
Created attachment 1017346 [details]
File: nmcli_dev_list

Comment 8 Vratislav Podzimek 2015-04-22 09:50:34 UTC
Created attachment 1017347 [details]
File: os_info

Comment 9 Vratislav Podzimek 2015-04-22 09:50:35 UTC
Created attachment 1017348 [details]
File: program.log

Comment 10 Vratislav Podzimek 2015-04-22 09:50:37 UTC
Created attachment 1017349 [details]
File: storage.log

Comment 11 Vratislav Podzimek 2015-04-22 09:50:39 UTC
Created attachment 1017350 [details]
File: syslog

Comment 12 Vratislav Podzimek 2015-04-22 09:50:41 UTC
Created attachment 1017351 [details]
File: ifcfg.log

Comment 13 Vratislav Podzimek 2015-04-22 09:50:42 UTC
Created attachment 1017352 [details]
File: packaging.log

Comment 14 Vratislav Podzimek 2015-04-22 10:30:30 UTC
This is already fixed on master, just a port to f22-branch is needed.

Comment 15 Fedora Blocker Bugs Application 2015-04-22 11:23:04 UTC
Proposed as a Blocker for 22-final by Fedora user vpodzime using the blocker tracking app because:

 The installer must be able to create and install to any workable partition layout using any file system and/or container format combination offered in a default installer configuration.

Comment 16 Vratislav Podzimek 2015-04-22 11:24:37 UTC
This happens randomly (depending on how python sorts dict keys), but quite often when installing to an existing LVM ThinP setup.

Comment 17 David Lehman 2015-04-22 14:52:22 UTC
*** Bug 1214008 has been marked as a duplicate of this bug. ***

Comment 18 Vratislav Podzimek 2015-04-28 11:23:58 UTC
*** Bug 1204566 has been marked as a duplicate of this bug. ***

Comment 19 David Gay 2015-04-28 21:54:32 UTC
Discussed at the 2015-04-28 blocker review meeting.[1] Voted as AcceptedBlocker.

Violates "The installer must be able to create and install to any workable partition layout using any file system and/or container format combination offered in a default installer configuration."[2]

[1]: http://meetbot.fedoraproject.org/fedora-blocker-review/2015-04-28/
[2]: https://fedoraproject.org/wiki/Fedora_22_Final_Release_Criteria#Disk_layouts

Comment 20 Fedora Update System 2015-05-07 19:17:06 UTC
python-blivet-1.0.9-1.fc22, anaconda-22.20.12-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/python-blivet-1.0.9-1.fc22,anaconda-22.20.12-1.fc22

Comment 21 Fedora Update System 2015-05-11 00:01:18 UTC
Package python-blivet-1.0.9-1.fc22, anaconda-22.20.12-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-1.0.9-1.fc22 anaconda-22.20.12-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-7827/python-blivet-1.0.9-1.fc22,anaconda-22.20.12-1.fc22
then log in and leave karma (feedback).

Comment 22 Josef Skladanka 2015-05-12 10:28:35 UTC
Tried several times, without getting the error. Leaving ON_QA for now, because of the "randomness" in reproducer, but to me, everything seems to be OK.

Comment 23 Fedora Update System 2015-05-13 01:17:16 UTC
python-blivet-1.0.9-1.fc22, anaconda-22.20.12-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.