Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1215811 - sshmenu RPM does not work, needs ftools.rb
Summary: sshmenu RPM does not work, needs ftools.rb
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sshmenu
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-04-27 19:32 UTC by João Carlos Mendes Luís
Modified: 2015-05-14 11:14 UTC (History)
3 users (show)

Fixed In Version: ruby-gnome2-0.90.4-5.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 11:14:20 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description João Carlos Mendes Luís 2015-04-27 19:32:09 UTC
Description of problem:

Does not work


Version-Release number of selected component (if applicable):

sshmenu-3.18-14.fc21.noarch


How reproducible:

Every time


Steps to Reproduce:
1. yum install sshmenu
2. run


Actual results:

$ /usr/bin/sshmenu
/usr/share/ruby/vendor_ruby/sshmenu.rb:459: warning: assigned but unused variable - x
/usr/share/ruby/vendor_ruby/sshmenu.rb:459: warning: assigned but unused variable - y
/usr/share/ruby/vendor_ruby/sshmenu.rb:459: warning: assigned but unused variable - h
/usr/share/ruby/vendor_ruby/sshmenu.rb:978: warning: assigned but unused variable - w
/usr/share/ruby/vendor_ruby/sshmenu.rb:1022: warning: assigned but unused variable - keylist
/usr/share/ruby/vendor_ruby/sshmenu.rb:1706: warning: shadowing outer local variable - h
/usr/share/ruby/vendor_ruby/sshmenu.rb:2037: warning: shadowing outer local variable - renderer
/usr/share/ruby/vendor_ruby/sshmenu.rb:2295: warning: assigned but unused variable - result
/usr/share/ruby/vendor_ruby/sshmenu.rb:2314: warning: assigned but unused variable - result
/usr/share/ruby/vendor_ruby/sshmenu.rb:2355: warning: assigned but unused variable - item
/usr/share/ruby/vendor_ruby/sshmenu.rb:2981: warning: mismatched indentations at 'end' with 'def' at 2955
/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- ftools (LoadError)
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /usr/share/ruby/vendor_ruby/sshmenu.rb:3:in `<top (required)>'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /usr/bin/sshmenu:3:in `<main>'


Also:


/usr/bin/sshmenu-gnome 
/usr/share/ruby/vendor_ruby/sshmenu.rb:459: warning: assigned but unused variable - x
/usr/share/ruby/vendor_ruby/sshmenu.rb:459: warning: assigned but unused variable - y
/usr/share/ruby/vendor_ruby/sshmenu.rb:459: warning: assigned but unused variable - h
/usr/share/ruby/vendor_ruby/sshmenu.rb:978: warning: assigned but unused variable - w
/usr/share/ruby/vendor_ruby/sshmenu.rb:1022: warning: assigned but unused variable - keylist
/usr/share/ruby/vendor_ruby/sshmenu.rb:1706: warning: shadowing outer local variable - h
/usr/share/ruby/vendor_ruby/sshmenu.rb:2037: warning: shadowing outer local variable - renderer
/usr/share/ruby/vendor_ruby/sshmenu.rb:2295: warning: assigned but unused variable - result
/usr/share/ruby/vendor_ruby/sshmenu.rb:2314: warning: assigned but unused variable - result
/usr/share/ruby/vendor_ruby/sshmenu.rb:2355: warning: assigned but unused variable - item
/usr/share/ruby/vendor_ruby/sshmenu.rb:2981: warning: mismatched indentations at 'end' with 'def' at 2955
/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- ftools (LoadError)
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /usr/share/ruby/vendor_ruby/sshmenu.rb:3:in `<top (required)>'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /usr/share/ruby/vendor_ruby/gnome-sshmenu.rb:1:in `<top (required)>'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /usr/bin/sshmenu-gnome:3:in `<main>'



Expected results:

Open a clickable window with menu options.


Additional info:

We can make it to (partilally) work by manually adding adding ftools gem:

# gem install ftools
Fetching: ftools-0.0.0.gem (100%)
Successfully installed ftools-0.0.0
1 gem installed

Someone made an CentOS/EPEL package for that, this could help:

http://copr-be.cloud.fedoraproject.org/results/hguemar/staypuft-el7/epel-7-x86_64/rubygem-ftools-0.0.0-4.fc21/


I said partially, because only sshmenu works, while sshmenu-gnome gets into known bug 1181160

Comment 1 João Carlos Mendes Luís 2015-04-30 16:59:52 UTC
Also, see bug 1181160

Comment 2 Fedora Update System 2015-05-03 14:39:22 UTC
sshmenu-3.18-15.fc22,ruby-gnome2-0.90.4-5.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/sshmenu-3.18-15.fc22,ruby-gnome2-0.90.4-5.fc22

Comment 3 Fedora Update System 2015-05-03 14:40:56 UTC
sshmenu-3.18-15.fc21,ruby-gnome2-0.90.4-5.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/sshmenu-3.18-15.fc21,ruby-gnome2-0.90.4-5.fc21

Comment 4 Fedora Update System 2015-05-03 14:41:15 UTC
sshmenu-3.18-15.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sshmenu-3.18-15.fc20

Comment 5 Fedora Update System 2015-05-04 15:26:36 UTC
Package ruby-gnome2-0.90.4-5.fc21, sshmenu-3.18-15.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ruby-gnome2-0.90.4-5.fc21 sshmenu-3.18-15.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-7499/sshmenu-3.18-15.fc21,ruby-gnome2-0.90.4-5.fc21
then log in and leave karma (feedback).

Comment 6 João Carlos Mendes Luís 2015-05-04 20:37:10 UTC
I have tested this upgrade.

It appears that installing all patches solves my initial problem, but I had to install updated dependencies manually.

I suggest forcing dependency of sshmenu on ruby(gconf2) >= 0.90.4-5.fc21

Thanks for your attention!

Comment 7 Mamoru TASAKA 2015-05-06 16:04:08 UTC
As F-20 ruby-gconf need not fixing, ruby(gconf2) >= 0.90.4-5.foo is not appropriate.
By the way you can do "sudo yum upgrade" with testing repo enabled to install the above updates package without manually installing rpms.

Anyway thank you for testing.

Comment 8 João Carlos Mendes Luís 2015-05-07 22:18:51 UTC
I didn't do 'sudo yum update --enablerepo=updates-testing sshmenu' because no mirror had yet upgraded when I was testing.  Now it is ok, But I only wanted to upgrade sshmenu.  If ruby-gnome should need to be upgraded, IMHO, yum should solve this dependency.

I downgraded everything and did it again.

$ sudo yum update --enablerepo=updates-testing sshmenu

This only updates from sshmenu-3.18-14.fc21.noarch to sshmenu-3.18-15.fc21.noarch

And this is enough to run /usr/bin/sshmenu, but not to run /usr/bin/sshmenu-gnome

Then I did

$ sudo yum update --enablerepo=updates-testing ruby-gnome2-0.90.4-5.fc21

ruby-gnome2-0.90.4-5.fc21.x86_64
ruby-gnomecanvas2-0.90.4-5.fc21.x86_64
ruby-libart2-0.90.4-5.fc21.x86_64
ruby-gnome2-0.90.4-3.fc21.2.x86_64
ruby-gnomecanvas2-0.90.4-3.fc21.2.x86_64
ruby-libart2-0.90.4-3.fc21.2.x86_64


But this did NOT upgrade ruby-gconf2, and so, /usr/sbin/sshmenu-gnome kept crashing

Also, upgrading ONLY ruby-gconf2 did not require ruby-gnome2 et al to be upgraded.  But running sshmenu-gnome with the OLD version of ruby-gnome2 et al worked perfectly.

So, IMHO, sshmenu should require ruby(gconf2) >= 0.90.4-5.fc21 and maybe ruby-gconf2 should need ruby-gnome AKA ruby(gtk) == (same version).

Hope I had been clear now.  Just my two cents.

Comment 9 Fedora Update System 2015-05-10 23:41:27 UTC
sshmenu-3.18-15.fc22, ruby-gnome2-0.90.4-5.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-05-14 11:14:20 UTC
ruby-gnome2-0.90.4-5.fc21, sshmenu-3.18-15.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-05-14 11:14:48 UTC
sshmenu-3.18-15.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.