Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1217411 - F22 Desktop Final TC1 x86_64 German Version for installation no delete of previous SW possible
Summary: F22 Desktop Final TC1 x86_64 German Version for installation no delete of pre...
Keywords:
Status: CLOSED DUPLICATE of bug 1217504
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F22FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2015-04-30 10:20 UTC by joerg.lechner
Modified: 2015-05-06 14:20 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-06 14:20:55 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
anaconda.log for trial to install the German version of F22 Final TC1 (34.32 KB, text/plain)
2015-04-30 10:28 UTC, joerg.lechner
no flags Details
screenshot explaining the failing procedure (263.14 KB, image/jpeg)
2015-04-30 10:57 UTC, joerg.lechner
no flags Details
for comparison a screenshot of the English Version (305.19 KB, image/jpeg)
2015-04-30 10:58 UTC, joerg.lechner
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1169019 0 unspecified CLOSED UnicodeDecodeError: 'ascii' codec can't decode byte 0xe4 in position 11: ordinal not in range(128) 2022-05-16 11:32:56 UTC

Internal Links: 1169019

Description joerg.lechner 2015-04-30 10:20:49 UTC
Description of problem: When I try to install the GERMAN version of F22 Desktop Final TC1 x86_64, it is not possible to delete the partitions of an external disk previously successfully used for F22 Beta 3 x86_64. The US-English version seem to be possible to install, so far tested.


Version-Release number of selected component (if applicable):
anaconda 22.20.11-1

How reproducible:
for me always

Steps to Reproduce:
1. install F22 Desktop Final TC1 x86_64 to usb flash media with liveusb-creator
2. click install to harddrive
3. choose German version

Actual results:
Delete of "old" partitions on external harddrive not possible

Expected results:
successful installation

Additional info:

Comment 1 joerg.lechner 2015-04-30 10:28:32 UTC
Created attachment 1020527 [details]
anaconda.log for trial to install the German version of F22 Final TC1

Comment 2 joerg.lechner 2015-04-30 10:57:31 UTC
Created attachment 1020552 [details]
screenshot explaining the failing procedure

it is not possible to click successfully on "Speicherplatz zurueckgewinnen" (Reclaim Space) This button is not high lighted. If You click on "Alles Loeschen" (Delete All), the opposite happens -> "beihalten" (preserve partitions) occurs.

Comment 3 joerg.lechner 2015-04-30 10:58:39 UTC
Created attachment 1020553 [details]
for comparison a screenshot of the English Version

Comment 4 Adam Williamson 2015-05-01 01:06:20 UTC
It's possible the installer had actually crashed at this point. Could you interact with the screen in any other way? Does it work from a non-live installer image? Can you check if there's a /tmp/anaconda-tb-(something) file after reproducing the bug? Thanks!

Comment 5 Adam Williamson 2015-05-01 01:13:08 UTC
huh...no, it's not crashed, but I can definitely reproduce it. The significant thing I notice is that the 'Total selected space to reclaim' value does not change in German when you delete partitions. In English it starts out showing '0' and then when you select some partitions for deletion it jumps up - to '20 GiB' or whatever. In German it starts out showing '0 B' and continues to do so after you select partitions to delete.

This also affects Russian, but not French. I'm guessing it affects any language with translated size units that use non-ASCII characters (French size units are translated, but all ASCII characters) and is yet more unicode vs. ASCII fallout *somehow* or other.

Proposing as a Final blocker, makes space reclamation impossible in at least German and Russian, and probably many other languages. Beta criterion "When using the guided partitioning flow, the installer must be able to: ...  Remove existing storage volumes to free up space, at the user's direction", in the case of an affected language.

Comment 6 Dan Mossor [danofsatx] 2015-05-04 16:18:11 UTC
Discussed at the 2015-05-04 blocker review meeting.[0] Voted as AcceptedBlocker.

AcceptedBlocker - violates "When using the guided partitioning flow, the installer must be able to: ...Remove existing storage volumes to free up space, at the user's direction" in the case of an affected language.

[0] http://meetbot.fedoraproject.org/meetbot/fedora-blocker-review/2015-05-04/f22-blocker-review.2015-05-04-16.00.log.txt

Comment 7 David Shea 2015-05-06 14:20:55 UTC

*** This bug has been marked as a duplicate of bug 1217504 ***


Note You need to log in before you can comment on or make changes to this bug.