Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1218688 - flickering on login
Summary: flickering on login
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1200581 (view as bug list)
Depends On:
Blocks: F22FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2015-05-05 14:53 UTC by Johannes Raggam
Modified: 2015-05-28 20:42 UTC (History)
21 users (show)

Fixed In Version: kernel-4.0.4-201.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-22 19:53:33 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
patch that didn't work (deleted)
2015-05-18 16:58 UTC, Ray Strode [halfline]
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
FreeDesktop.org 90508 0 None None None Never

Description Johannes Raggam 2015-05-05 14:53:07 UTC
Description of problem:
Screen flickers at the login prompt. I've heard, you switched to Wayland? Maybe that's the reason. I'm using a Macbook Air 13'', late 2011.


Version-Release number of selected component (if applicable):
Fedorea 22 Beta

Comment 1 mchalupa 2015-05-11 15:46:23 UTC
I experience this bug too. When continuing to wayland session, it is still there (so not only when logging in). The flickering disappears when the cursor gets hidden or after VT switch, so probably drm related. The bug is present on all kernels in repositories, but with nightly-build 4.1.0 drm-intel kernel the flickering is gone.

Components:
F22
Lenovo T520
i915, Intel Corporation 2nd Generation Core Processor Integrated Graphics

Comment 2 Ray Strode [halfline] 2015-05-12 13:10:29 UTC
Marek, any chance you can bisect which commit fixes this and then maybe jwb could pull it in for release?

Comment 3 mchalupa 2015-05-14 14:46:34 UTC
(In reply to Ray Strode [halfline] from comment #2)
> Marek, any chance you can bisect which commit fixes this and then maybe jwb
> could pull it in for release?

So far I got to merge commit 14aa024, which is merge of this branch:
http://cgit.freedesktop.org/~airlied/linux/log/?h=drm-next-merged
Some commit(s) in this merge fix the issue.

Unfortunately, I won't have time to look into it at least till Monday, maybe Wednesday.

Comment 4 mchalupa 2015-05-14 14:49:33 UTC
Looks like this may be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1200581

Comment 5 Christian Fredrik Kalager Schaller 2015-05-14 14:53:17 UTC
I have a laptop which exhibits this behaviour, so as I just told Ray I can bring it to the Westford office if we have trouble identifying the fix and need a machine for testing.

Comment 6 Ray Strode [halfline] 2015-05-14 18:00:03 UTC
*** Bug 1200581 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Blocker Bugs Application 2015-05-14 18:56:57 UTC
Proposed as a Freeze Exception for 22-final by Fedora user rstrode using the blocker tracking app because:

 flickering for a large number of users will give a bad "out of the box" experience. it's clearly not a blocker, but we've narrowed where the problem is down a series of commits. if we can isolate it to a commit or two, jwb said he's willing to add the commits to the kernel for release.

Comment 8 Kamil Páral 2015-05-14 19:06:35 UTC
Discussed at the 2015-05-14 blocker review meeting.[1] Voted as AcceptedFreezeException - this is a bad bug on affected hardware and would affect first boot after install from live image, would be good to get a sufficiently targeted fix in the next few days

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-05-14

Comment 9 Christian Fredrik Kalager Schaller 2015-05-15 14:16:57 UTC
As a point of information, the system I have exhibiting this issue has Intel Ironlake Mobile GPU.

Comment 10 Christian Fredrik Kalager Schaller 2015-05-15 17:47:41 UTC
Put up a video of the flickering here, as it happens both under GDM and under Wayland. What I noticed is that it is related to the mouse pointer as the flickering only happens on the part of the screen that is below the mouse pointer at any given time:
https://plus.google.com/photos/109262178267841117787/albums/6149135938534130433/6149135938136021458

Comment 11 Christian Stadelmann 2015-05-15 22:04:21 UTC
You should also have a look at https://bugzilla.redhat.com/show_bug.cgi?id=1199890 which is a duplicate imho. You can find more info there.

Comment 12 Dave Airlie 2015-05-16 02:04:44 UTC
http://patchwork.freedesktop.org/patch/49314/

Comment 13 Yann Droneaud 2015-05-18 13:27:11 UTC
My Lenovo ThinkPad x220 is also affected by flickering on login screen
  DMI: LENOVO 4287CTO/4287CTO, BIOS 8DET58WW (1.28 ) 02/14/2012
  Intel(R) Core(TM) i7-2640M CPU @ 2.80GHz (fam: 06, model: 2a, stepping: 07)
  VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
  00:02.0 0300: 8086:0126 (rev 09)

Two other possible duplicates:

https://bugzilla.redhat.com/show_bug.cgi?id=1216970
https://bugzilla.redhat.com/show_bug.cgi?id=1214468

Comment 14 Ray Strode [halfline] 2015-05-18 16:58:19 UTC
Created attachment 1026784 [details]
patch that didn't work

So based on comment 12, i tried the above patch against 4.0.3-301

It didn't resolve the problem on sgallagh's laptop that i have here.
I'm not entirely certain sgallagh's laptop is showing the same issue Marek is seeing though, because for him the problem is resolved with airled's drm-next-merged branch, but on this laptop the problem needs some fix after that from the drm-intel-next branch.

will do more testing but have to go right now.

Comment 15 Ray Strode [halfline] 2015-05-18 18:31:50 UTC
(looking at the patch now it makes sense it wouldn't work, since it's not actually doing anything to prevent the cursor for being disabled, i guess fedora is shipping code from a before a different flickering bug was introduced that comment 12 addresses)

Comment 16 Vít Ondruch 2015-05-19 11:28:31 UTC
I used to see some flickering on my login screen in Rawhide, but after update at Saturday, it went away. Note that I did not updated kernel, I am still using 4.0.0-1.fc23.

Comment 17 Ray Strode [halfline] 2015-05-20 17:32:14 UTC
issue seems fixed by a patch on the upstream bug ( https://bugs.freedesktop.org/show_bug.cgi?id=90508 )

Comment 18 M. Edward (Ed) Borasky 2015-05-21 01:11:46 UTC
(In reply to Ray Strode [halfline] from comment #17)
> issue seems fixed by a patch on the upstream bug (
> https://bugs.freedesktop.org/show_bug.cgi?id=90508 )

When is this expected in the repos? I just updated my Asus U64E BAL5 to the latest software and I'm still seeing a flicker in GDM and in GNOME on Wayland. It's not as bad as it was - GDM is usable now - but it's still there. Current packages are

xorg-x11-drv-intel.x86_64            2.99.917-6.20150211.fc22            @System
gnome-session-wayland-session.x86_64 3.16.0-1.fc22                       @System
xorg-x11-server-Xwayland.x86_64      1.17.1-12.fc22                      @System
kernel-modules.x86_64                4.0.4-300.fc22                      @System

Comment 19 Josh Boyer 2015-05-21 12:28:44 UTC
I've added the patch Anders sent upstream that Ray tested to the F22 and F21 kernels.  It will be in the next build.

Comment 20 Fedora Update System 2015-05-21 17:38:52 UTC
kernel-4.0.4-301.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/kernel-4.0.4-301.fc22

Comment 21 Fedora Update System 2015-05-21 19:58:51 UTC
kernel-4.0.4-201.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kernel-4.0.4-201.fc21

Comment 22 Fedora Update System 2015-05-22 02:31:35 UTC
Package kernel-4.0.4-301.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-4.0.4-301.fc22'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8690/kernel-4.0.4-301.fc22
then log in and leave karma (feedback).

Comment 23 Fedora Update System 2015-05-22 19:53:33 UTC
kernel-4.0.4-301.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Johannes Raggam 2015-05-25 06:48:58 UTC
No probs, no flickering on login!

Comment 25 M. Edward (Ed) Borasky 2015-05-25 06:59:00 UTC
Works now on my Asus U64E BAL5 - in fact, I'm now running GNOME Shell on Wayland.

Comment 26 Ozkan Sezer 2015-05-26 08:41:56 UTC
The patch seems to be missing in f20 version of 4.0.4 kernel?

Comment 27 Josh Boyer 2015-05-26 12:25:27 UTC
(In reply to Ozkan Sezer from comment #26)
> The patch seems to be missing in f20 version of 4.0.4 kernel?

Added now.  Thanks for pointing this out.

Comment 28 Fedora Update System 2015-05-27 16:05:23 UTC
kernel-4.0.4-201.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 29 Fedora Update System 2015-05-28 20:42:05 UTC
kernel-4.0.4-101.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-4.0.4-101.fc20


Note You need to log in before you can comment on or make changes to this bug.