Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1235173 - rsyslog logfiles not rotated properly
Summary: rsyslog logfiles not rotated properly
Keywords:
Status: CLOSED DUPLICATE of bug 1224972
Alias: None
Product: Fedora
Classification: Fedora
Component: rsyslog
Version: 22
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Tomas Heinrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-24 07:56 UTC by Jan ONDREJ
Modified: 2016-09-20 04:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-28 06:55:47 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Jan ONDREJ 2015-06-24 07:56:32 UTC
Description of problem:
Logrotate can't rotate syslog files properly. They are renamed, bug rsyslog is not restarted. Looks like problem is in /etc/logrotate.d/syslog file, which is trying to HUP kill /var/run/syslogd.pid instead of  /var/run/rsyslogd.pid.

Version-Release number of selected component (if applicable):
rsyslog-8.8.0-2.fc22.x86_64

How reproducible:
weekly (always on rotation)

Additional info:
Consider changing /etc/logrotate/syslog to /etc/logrotate/rsyslog too, but may be only in Fedora 23. For Fedora 22 this could cause problems if somebody modified this file.

Comment 1 Stefan Becker 2015-06-28 06:55:47 UTC

*** This bug has been marked as a duplicate of bug 1224972 ***


Note You need to log in before you can comment on or make changes to this bug.