Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1237298 - Log rotation fails to HUP
Summary: Log rotation fails to HUP
Keywords:
Status: CLOSED DUPLICATE of bug 1224972
Alias: None
Product: Fedora
Classification: Fedora
Component: rsyslog
Version: 22
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Tomas Heinrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-06-30 18:15 UTC by Pete Zaitcev
Modified: 2016-09-20 04:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-30 18:19:59 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Pete Zaitcev 2015-06-30 18:15:19 UTC
Description of problem:

The /var/log/messages is empty. Messages continue to be written into
/var/log/messages-20150629 because the SIGHUP does not reach rsyslogd.
This is because the file name of the PID file in /etc/logrotate.d/syslog
is incorrect. That file belongs to rsyslog RPM, not logrotate RPM.

[root@takane zaitcev]# ls -lt /var/log/messages*
-rw-r--r-- 1 root root 1625066 Jun 30 11:52 /var/log/messages-20150629
-rw-r--r-- 1 root root       0 Jun 29 03:23 /var/log/messages
-rw-r--r-- 1 root root  551610 Jun 21 03:46 /var/log/messages-20150621
-rw-r--r-- 1 root root  363929 Jun 14 03:36 /var/log/messages-20150614
-rw-r--r-- 1 root root  471553 Jun  7 03:29 /var/log/messages-20150607
[root@takane zaitcev]# grep HUP /etc/logrotate.d/syslog
        /bin/kill -HUP `cat /var/run/syslogd.pid 2> /dev/null` 2> /dev/null || true
[root@takane zaitcev]# ls -ld /var/run/*log*
drwxr-xr-x 2 root root 40 Jun 23 13:00 /var/run/log
-rw-r--r-- 1 root root  3 Jun 23 13:00 /var/run/rsyslogd.pid
[root@takane zaitcev]# rpm -qf /etc/logrotate.d/syslog
rsyslog-8.8.0-2.fc22.x86_64
[root@takane zaitcev]# 

Version-Release number of selected component (if applicable):

rsyslog-8.8.0-2.fc22.x86_64

How reproducible:

100%, but wait for rotation

Steps to Reproduce:
1. Make sure logrotate is installed, cronie is installed.
1. Wait a week.
2. Verify that /var/log/messages is empty.

Actual results:

The /var/log/messages is empty.

Expected results:

The /var/log/messages stores messages as in Fedora 21.

Additional info:

Regression from Fedora 21.

Comment 1 Pete Zaitcev 2015-06-30 18:19:59 UTC
oops, it's a dup of bug 1224972

*** This bug has been marked as a duplicate of bug 1224972 ***


Note You need to log in before you can comment on or make changes to this bug.