Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1255284 - Unable to use phone over bluetooth for internet connection
Summary: Unable to use phone over bluetooth for internet connection
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1230461 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-20 08:21 UTC by Lukas Brabec
Modified: 2016-01-21 04:49 UTC (History)
8 users (show)

Fixed In Version: NetworkManager-1.0.10-2.fc23 NetworkManager-1.0.10-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-08 20:54:51 UTC
Type: Bug


Attachments (Terms of Use)
snippet from journalctl (6.86 KB, text/plain)
2015-08-21 06:48 UTC, Lukas Brabec
no flags Details

Description Lukas Brabec 2015-08-20 08:21:36 UTC
Description of problem:
I successfully paired phone (tested moto g and iphone 5s) over blootooth with my laptop. However, clicking on 'Use as internet connection' fails. Phone itself 'sees' that the computer tries to use it.


output from journalctl (from clicking on 'use as internet connection'):

srp 20 10:16:12 dhcp-2-104.brq.redhat.com NetworkManager[1115]: <info>  (AC:FD:EC:5F:88:80): Activation: starting connection 'Lukáš's iPhone Network' (f3281626-6f18-4835-97b3-6c4bd3d5b6bf)
srp 20 10:16:12 dhcp-2-104.brq.redhat.com NetworkManager[1115]: <info>  (AC:FD:EC:5F:88:80): device state change: disconnected -> prepare (reason 'none') [30 40 0]
srp 20 10:16:12 dhcp-2-104.brq.redhat.com NetworkManager[1115]: <info>  (AC:FD:EC:5F:88:80): device state change: prepare -> config (reason 'none') [40 50 0]
srp 20 10:16:13 dhcp-2-104.brq.redhat.com bluetoothd[974]:  connected
srp 20 10:16:13 dhcp-2-104.brq.redhat.com systemd-udevd[14045]: Error changing net interface name 'bnep0' to 'enp0s20u7': Device or resource busy
srp 20 10:16:13 dhcp-2-104.brq.redhat.com systemd-udevd[14045]: could not rename interface '90' from 'bnep0' to 'enp0s20u7': Device or resource busy
srp 20 10:16:14 dhcp-2-104.brq.redhat.com avahi-daemon[946]: Registering new address record for fe80::5ee0:c5ff:fe80:684d on bnep0.*.
srp 20 10:16:42 dhcp-2-104.brq.redhat.com NetworkManager[1115]: <info>  (AC:FD:EC:5F:88:80): device state change: config -> failed (reason 'bluetooth-failed') [50 120 44]
srp 20 10:16:42 dhcp-2-104.brq.redhat.com NetworkManager[1115]: <warn>  (AC:FD:EC:5F:88:80): Activation: failed for connection 'Lukáš's iPhone Network'
srp 20 10:16:42 dhcp-2-104.brq.redhat.com NetworkManager[1115]: <info>  (AC:FD:EC:5F:88:80): device state change: failed -> disconnected (reason 'none') [120 30 0]
srp 20 10:16:42 dhcp-2-104.brq.redhat.com avahi-daemon[946]: Withdrawing address record for fe80::5ee0:c5ff:fe80:684d on bnep0.
srp 20 10:16:42 dhcp-2-104.brq.redhat.com /firewalld[11653]: 2015-08-20 10:16:42 ERROR: UNKNOWN_INTERFACE: 'bnep0' is not in any zone



Version-Release number of selected component (if applicable):
NetworkManager-1.0.6-0.2.20150813git7e2caa2.fc23.x86_64

Comment 1 Jan Sedlák 2015-08-20 08:26:13 UTC
This is happening to me also. I have Fedora 22 with NetworkManager-1.0.2-1.fc22.x86_64.

Comment 2 Dan Williams 2015-08-20 14:57:01 UTC
Analysis: the failure is coming from bt_connect_timeout().  This only runs when one or both of (a) bluez fails to return from the Connect() call, and (b) bluez signals the 'Connected' property for the device.  So one of these two things is not happening within the 30 second timeout.  Lets figure out which one that is:

http://koji.fedoraproject.org/koji/taskinfo?taskID=10765770

If those of you hitting this issue could install this package (it should also work on F22, let us know if it doesn't) and then grab the journalctl output like you already have, there's some additional logging that will narrow down what's going on.

Comment 3 Lukas Brabec 2015-08-21 06:48:44 UTC
Created attachment 1065447 [details]
snippet from journalctl

Comment 4 Dimitris 2015-10-23 16:22:04 UTC
Just a quick note that I'm seeing this under F22 with NM 1.0.6-7.fc22.

I have not disabled interface renaming (see bug 1267659)

Comment 5 Dimitris 2015-10-23 16:42:25 UTC
This and bug 1267659 seem related to/regressions of bug 1047427 (note last comment there); I knew I had seen this before...

Comment 6 Dan Williams 2015-10-23 16:53:30 UTC
I believe I've isolated the issue and I've posted a patch upstream for it:

https://mail.gnome.org/archives/networkmanager-list/2015-October/msg00053.html

Comment 8 Dan Williams 2015-11-13 17:20:43 UTC
*** Bug 1230461 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2015-11-24 11:19:37 UTC
NetworkManager-vpnc-1.0.8-1.fc23 NetworkManager-openconnect-1.0.8-1.fc23 NetworkManager-openvpn-1.0.8-1.fc23 NetworkManager-openswan-1.0.8-1.fc23 NetworkManager-fortisslvpn-1.0.8-1.fc23 NetworkManager-1.0.8-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-2ae867c402

Comment 10 Fedora Update System 2015-11-24 11:22:50 UTC
NetworkManager-vpnc-1.0.8-1.fc22 NetworkManager-openconnect-1.0.8-1.fc22 NetworkManager-openvpn-1.0.8-1.fc22 NetworkManager-openswan-1.0.8-1.fc22 NetworkManager-fortisslvpn-1.0.8-1.fc22 NetworkManager-1.0.8-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-efc06edc85

Comment 11 Lukas Brabec 2015-11-24 11:39:34 UTC
Bug fixed in 1.0.8-1

Comment 12 Fedora Update System 2015-11-25 02:54:05 UTC
NetworkManager-1.0.8-1.fc23, NetworkManager-fortisslvpn-1.0.8-1.fc23, NetworkManager-openconnect-1.0.8-1.fc23, NetworkManager-openswan-1.0.8-1.fc23, NetworkManager-openvpn-1.0.8-1.fc23, NetworkManager-vpnc-1.0.8-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update NetworkManager NetworkManager-fortisslvpn NetworkManager-openswan NetworkManager-openvpn NetworkManager-openconnect NetworkManager-vpnc'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-2ae867c402

Comment 13 Fedora Update System 2015-11-26 02:26:30 UTC
NetworkManager-1.0.8-1.fc22, NetworkManager-fortisslvpn-1.0.8-1.fc22, NetworkManager-openconnect-1.0.8-1.fc22, NetworkManager-openswan-1.0.8-1.fc22, NetworkManager-openvpn-1.0.8-1.fc22, NetworkManager-vpnc-1.0.8-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update NetworkManager NetworkManager-fortisslvpn NetworkManager-openswan NetworkManager-openvpn NetworkManager-openconnect NetworkManager-vpnc'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-efc06edc85

Comment 14 Fedora Update System 2015-12-23 15:10:05 UTC
NetworkManager-fortisslvpn-1.0.8-1.fc22 NetworkManager-openconnect-1.0.8-1.fc22 NetworkManager-openswan-1.0.8-1.fc22 NetworkManager-openvpn-1.0.8-1.fc22 NetworkManager-vpnc-1.0.8-1.fc22 network-manager-applet-1.0.10-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-efc06edc85

Comment 15 Fedora Update System 2015-12-23 15:10:19 UTC
NetworkManager-1.0.10-1.fc23 NetworkManager-fortisslvpn-1.0.8-1.fc23 NetworkManager-openconnect-1.0.8-1.fc23 NetworkManager-openswan-1.0.8-1.fc23 NetworkManager-openvpn-1.0.8-1.fc23 NetworkManager-vpnc-1.0.8-1.fc23 network-manager-applet-1.0.10-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-2ae867c402

Comment 16 Fedora Update System 2015-12-25 01:59:09 UTC
NetworkManager-1.0.10-1.fc23, NetworkManager-fortisslvpn-1.0.8-1.fc23, NetworkManager-openconnect-1.0.8-1.fc23, NetworkManager-openswan-1.0.8-1.fc23, NetworkManager-openvpn-1.0.8-1.fc23, NetworkManager-vpnc-1.0.8-1.fc23, network-manager-applet-1.0.10-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-2ae867c402

Comment 17 Fedora Update System 2015-12-30 20:57:59 UTC
NetworkManager-1.0.10-1.fc22, NetworkManager-fortisslvpn-1.0.8-1.fc22, NetworkManager-openconnect-1.0.8-1.fc22, NetworkManager-openswan-1.0.8-1.fc22, NetworkManager-openvpn-1.0.8-1.fc22, NetworkManager-vpnc-1.0.8-1.fc22, network-manager-applet-1.0.10-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-efc06edc85

Comment 18 Fedora Update System 2016-01-05 14:06:55 UTC
NetworkManager-1.0.10-2.fc23 NetworkManager-fortisslvpn-1.0.8-1.fc23 NetworkManager-openconnect-1.0.8-1.fc23 NetworkManager-openswan-1.0.8-1.fc23 NetworkManager-openvpn-1.0.8-1.fc23 NetworkManager-vpnc-1.0.8-1.fc23 network-manager-applet-1.0.10-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-2ae867c402

Comment 19 Fedora Update System 2016-01-05 14:16:16 UTC
NetworkManager-1.0.10-2.fc22 NetworkManager-fortisslvpn-1.0.8-1.fc22 NetworkManager-openconnect-1.0.8-1.fc22 NetworkManager-openswan-1.0.8-1.fc22 NetworkManager-openvpn-1.0.8-1.fc22 NetworkManager-vpnc-1.0.8-1.fc22 network-manager-applet-1.0.10-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-efc06edc85

Comment 20 Fedora Update System 2016-01-06 00:25:28 UTC
NetworkManager-1.0.10-2.fc22, NetworkManager-fortisslvpn-1.0.8-1.fc22, NetworkManager-openconnect-1.0.8-1.fc22, NetworkManager-openswan-1.0.8-1.fc22, NetworkManager-openvpn-1.0.8-1.fc22, NetworkManager-vpnc-1.0.8-1.fc22, network-manager-applet-1.0.10-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-efc06edc85

Comment 21 Fedora Update System 2016-01-06 00:30:43 UTC
NetworkManager-1.0.10-2.fc23, NetworkManager-fortisslvpn-1.0.8-1.fc23, NetworkManager-openconnect-1.0.8-1.fc23, NetworkManager-openswan-1.0.8-1.fc23, NetworkManager-openvpn-1.0.8-1.fc23, NetworkManager-vpnc-1.0.8-1.fc23, network-manager-applet-1.0.10-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-2ae867c402

Comment 22 Fedora Update System 2016-01-08 20:54:17 UTC
NetworkManager-1.0.10-2.fc23, NetworkManager-fortisslvpn-1.0.8-1.fc23, NetworkManager-openconnect-1.0.8-1.fc23, NetworkManager-openswan-1.0.8-1.fc23, NetworkManager-openvpn-1.0.8-1.fc23, NetworkManager-vpnc-1.0.8-1.fc23, network-manager-applet-1.0.10-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2016-01-21 04:49:16 UTC
NetworkManager-1.0.10-2.fc22, NetworkManager-fortisslvpn-1.0.8-1.fc22, NetworkManager-openconnect-1.0.8-1.fc22, NetworkManager-openswan-1.0.8-1.fc22, NetworkManager-openvpn-1.0.8-1.fc22, NetworkManager-vpnc-1.0.8-1.fc22, network-manager-applet-1.0.10-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.