Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1258095 - [abrt] viking: __memcpy_sse2_unaligned(): viking killed by SIGSEGV
Summary: [abrt] viking: __memcpy_sse2_unaligned(): viking killed by SIGSEGV
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: viking
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:cfac4fa2972b2618f25566447a1...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-29 01:33 UTC by Marcus
Modified: 2015-12-18 09:59 UTC (History)
1 user (show)

Fixed In Version: viking-1.6.1-1.fc23 viking-1.6.1-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-18 07:54:38 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (deleted)
2015-08-29 01:33 UTC, Marcus
no flags Details
File: cgroup (deleted)
2015-08-29 01:33 UTC, Marcus
no flags Details
File: core_backtrace (deleted)
2015-08-29 01:33 UTC, Marcus
no flags Details
File: dso_list (deleted)
2015-08-29 01:33 UTC, Marcus
no flags Details
File: environ (deleted)
2015-08-29 01:33 UTC, Marcus
no flags Details
File: limits (deleted)
2015-08-29 01:33 UTC, Marcus
no flags Details
File: maps (deleted)
2015-08-29 01:33 UTC, Marcus
no flags Details
File: mountinfo (deleted)
2015-08-29 01:33 UTC, Marcus
no flags Details
File: namespaces (deleted)
2015-08-29 01:33 UTC, Marcus
no flags Details
File: open_fds (deleted)
2015-08-29 01:33 UTC, Marcus
no flags Details
File: proc_pid_status (deleted)
2015-08-29 01:33 UTC, Marcus
no flags Details
File: var_log_messages (deleted)
2015-08-29 01:33 UTC, Marcus
no flags Details

Description Marcus 2015-08-29 01:33:01 UTC
Description of problem:
 I had two map layers, one Bing on the bottom, One StreetCyclemap on top with alpha set at around 50%.
Just panning left/right make the sigsegv happen.
Can be reproduced intermittently.

Version-Release number of selected component:
viking-1.6-1.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        viking
crash_function: __memcpy_sse2_unaligned
executable:     /usr/bin/viking
global_pid:     8202
kernel:         4.1.6-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 __memcpy_sse2_unaligned at ../sysdeps/x86_64/multiarch/memcpy-sse2-unaligned.S:33
 #1 memcpy at /usr/include/bits/string3.h:53
 #2 _gdk_x11_convert_to_format at gdkdrawable-x11.c:1147
 #3 draw_with_images at gdkdrawable-x11.c:1321
 #4 gdk_x11_draw_pixbuf at gdkdrawable-x11.c:1520
 #5 vik_viewport_draw_pixbuf at vikviewport.c:1373
 #6 maps_layer_draw_section at vikmapslayer.c:1384
 #7 maps_layer_draw at vikmapslayer.c:1468
 #8 vik_aggregate_layer_draw at vikaggregatelayer.c:351
 #9 vik_layers_panel_draw_all at viklayerspanel.c:570

Comment 1 Marcus 2015-08-29 01:33:04 UTC
Created attachment 1068180 [details]
File: backtrace

Comment 2 Marcus 2015-08-29 01:33:05 UTC
Created attachment 1068181 [details]
File: cgroup

Comment 3 Marcus 2015-08-29 01:33:07 UTC
Created attachment 1068182 [details]
File: core_backtrace

Comment 4 Marcus 2015-08-29 01:33:08 UTC
Created attachment 1068183 [details]
File: dso_list

Comment 5 Marcus 2015-08-29 01:33:09 UTC
Created attachment 1068184 [details]
File: environ

Comment 6 Marcus 2015-08-29 01:33:11 UTC
Created attachment 1068185 [details]
File: limits

Comment 7 Marcus 2015-08-29 01:33:13 UTC
Created attachment 1068186 [details]
File: maps

Comment 8 Marcus 2015-08-29 01:33:14 UTC
Created attachment 1068187 [details]
File: mountinfo

Comment 9 Marcus 2015-08-29 01:33:15 UTC
Created attachment 1068188 [details]
File: namespaces

Comment 10 Marcus 2015-08-29 01:33:16 UTC
Created attachment 1068189 [details]
File: open_fds

Comment 11 Marcus 2015-08-29 01:33:18 UTC
Created attachment 1068190 [details]
File: proc_pid_status

Comment 12 Marcus 2015-08-29 01:33:19 UTC
Created attachment 1068191 [details]
File: var_log_messages

Comment 13 Fedora Update System 2015-11-25 09:39:19 UTC
viking-1.6.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-4f81292f22

Comment 14 Fedora Update System 2015-11-25 10:08:01 UTC
viking-1.6.1-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-d775e43058

Comment 15 Fedora Update System 2015-11-25 11:38:27 UTC
viking-1.6.1-1.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-264e3aa9ac

Comment 16 Fedora Update System 2015-11-26 01:21:43 UTC
viking-1.6.1-1.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update viking'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-264e3aa9ac

Comment 17 Fedora Update System 2015-11-26 02:25:11 UTC
viking-1.6.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update viking'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-d775e43058

Comment 18 Fedora Update System 2015-11-26 02:54:04 UTC
viking-1.6.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update viking'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-4f81292f22

Comment 19 Marcus 2015-12-13 23:01:02 UTC
I have tested on F23 and all seems to be ok.
Thank you for fixing this.
Great product.

Comment 20 Fedora Update System 2015-12-18 07:54:26 UTC
viking-1.6.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2015-12-18 09:59:52 UTC
viking-1.6.1-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.