Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1258640 - Cannot magnify my large pdf beyond 125% in evince, atril
Summary: Cannot magnify my large pdf beyond 125% in evince, atril
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: atril
Version: 23
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Wolfgang Ulbrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-31 21:18 UTC by Steven Usdansky
Modified: 2016-07-10 02:21 UTC (History)
5 users (show)

Fixed In Version: atril-1.14.1-2.fc24 atril-1.14.1-2.fc23 atril-1.14.1-2.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-26 20:55:57 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Steven Usdansky 2015-08-31 21:18:04 UTC
Description of problem:
Large pdf (19.09 x 46.98 inch) will not magnify above 125% in either atril or evince. 

Version-Release number of selected component (if applicable):
poppler-0.34.0-1.fc23.x86_64
poppler-data-0.4.7-4.fc23.noarch
poppler-glib-0.34.0-1.fc23.x86_64
poppler-utils-0.34.0-1.fc23.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Open pdf in evince or atril
2. Click on magnification list(?) box
3. Try to set magnification above 125%

Actual results:
1. Largest magnification shown is 150%
2. Cannot even select 150%; 125% is largest selectable magnification


Expected results:
1. Largest magnification shown will be 400%, as it is with smaller (in dimension) documents 
2. What I perceive to be a list box should actually be a combo box that allows me to specify any magnification

Additional info:
Xpdf, which requires poppler-utils which requires poppler but not poppler-glib, works as expected - it displays magnifications up to 400% in the combo box, and allows me to select even larger magnifications (I tried 600%)

Comment 1 Steven Usdansky 2015-09-01 21:06:55 UTC
Bug should probably be filed against evince and atril. Manually editing my test pdf to reduce the reported page size by 50% then loading the pdf into both evince and atril caused magifications up to 300% to appear in the zoom combobox of both apps. Atril allowd me to select 300%; evince maxed out at 259.51%.

Comment 2 Marek Kašík 2015-09-03 14:26:56 UTC
This can be configured at org.gnome.Evince gsettings' key "page-cache-size". Try to set something larger then 50MB for a page and it will allow you to magnify more.
I'm reassigning this to Atril since I don't see the key there.

Comment 3 Wolfgang Ulbrich 2015-09-03 16:48:17 UTC
Here is a test build with the missing gsettings key (gtk3)
https://dl.dropboxusercontent.com/u/49862637/Mate-desktop/SOURCE/atril.tar.xz
Can you confirm if that fixes the issue?

Comment 4 Wolfgang Ulbrich 2015-09-03 17:13:49 UTC
Ok, forget that build, this will break pdf viewing

Comment 5 Steven Usdansky 2015-11-18 00:41:19 UTC
Will await a fix. I've lived with it this long, I can live with it a while longer

Comment 6 Wolfgang Ulbrich 2015-11-18 00:50:24 UTC
ask upstream, i can't fix it.

Comment 7 Nemoinis 2016-05-04 19:35:45 UTC
The maximum document zoom in Evince is related to the page-cache-size, which is 50 (MB) by default, and that's not enough to be useful in many documents. You can change it like this:

gsettings set org.gnome.Evince page-cache-size 200

It does not look like this parameter is available in Atril (1.14), only Evince.

Comment 8 Wolfgang Ulbrich 2016-05-11 15:43:07 UTC
Can you please try this scratch build where i have include the page-cache-size gsettings key.
Please test.
http://koji.fedoraproject.org/koji/taskinfo?taskID=14010918

Comment 9 Steven Usdansky 2016-06-17 22:58:02 UTC
Scratch build works. Closing the bug (better late than never)

Comment 10 Fedora Update System 2016-06-20 15:22:45 UTC
atril-1.14.1-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cce31d5dd3

Comment 11 Fedora Update System 2016-06-20 15:22:52 UTC
atril-1.14.1-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-00ec9f6274

Comment 12 Fedora Update System 2016-06-20 15:22:57 UTC
atril-1.14.1-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-d31247315c

Comment 13 Fedora Update System 2016-06-20 15:25:58 UTC
atril-1.14.1-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-d31247315c

Comment 14 Fedora Update System 2016-06-22 02:19:18 UTC
atril-1.14.1-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-d31247315c

Comment 15 Fedora Update System 2016-06-22 02:27:44 UTC
atril-1.14.1-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cce31d5dd3

Comment 16 Fedora Update System 2016-06-22 02:55:28 UTC
atril-1.14.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-00ec9f6274

Comment 17 Fedora Update System 2016-06-26 20:55:55 UTC
atril-1.14.1-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2016-06-29 17:22:44 UTC
atril-1.14.1-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2016-07-10 02:21:36 UTC
atril-1.14.1-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.