Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1275824 - [abrt] gnome-abrt: remove_quotes(): python3.4 killed by SIGSEGV
Summary: [abrt] gnome-abrt: remove_quotes(): python3.4 killed by SIGSEGV
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreport
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Filak
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:ff5c2e9977da9eef7248f0c559a...
: 1275774 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-27 20:39 UTC by info@kobaltwit.be
Modified: 2016-12-01 00:50 UTC (History)
7 users (show)

Fixed In Version: libreport-2.6.4-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-05 00:21:18 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (deleted)
2015-10-27 20:39 UTC, info@kobaltwit.be
no flags Details
File: cgroup (deleted)
2015-10-27 20:39 UTC, info@kobaltwit.be
no flags Details
File: core_backtrace (deleted)
2015-10-27 20:39 UTC, info@kobaltwit.be
no flags Details
File: dso_list (deleted)
2015-10-27 20:39 UTC, info@kobaltwit.be
no flags Details
File: environ (deleted)
2015-10-27 20:39 UTC, info@kobaltwit.be
no flags Details
File: limits (deleted)
2015-10-27 20:39 UTC, info@kobaltwit.be
no flags Details
File: maps (deleted)
2015-10-27 20:39 UTC, info@kobaltwit.be
no flags Details
File: mountinfo (deleted)
2015-10-27 20:39 UTC, info@kobaltwit.be
no flags Details
File: namespaces (deleted)
2015-10-27 20:39 UTC, info@kobaltwit.be
no flags Details
File: open_fds (deleted)
2015-10-27 20:39 UTC, info@kobaltwit.be
no flags Details
File: proc_pid_status (deleted)
2015-10-27 20:39 UTC, info@kobaltwit.be
no flags Details
File: var_log_messages (deleted)
2015-10-27 20:39 UTC, info@kobaltwit.be
no flags Details

Description info@kobaltwit.be 2015-10-27 20:39:30 UTC
Description of problem:
I'm trying to run gnome-abrt on my system (Fedora 22, Plasma desktop).
It crashes with the info found in this report.

I also tried running it in a gnome environment. Same crash.

It may be relevant that I'm running sddm instead of gdm, in case this sets up
a different environment ?

Note I also tried this on a Fedora 23 machine - same crash.

Version-Release number of selected component:
gnome-abrt-1.2.0-3.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/bin/python3 /bin/gnome-abrt
crash_function: remove_quotes
executable:     /usr/bin/python3.4
global_pid:     11269
kernel:         4.1.6-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 remove_quotes at desktop-utils.c:42
 #1 problem_create_app_from_cmdline at desktop-utils.c:220
 #2 p_get_app_for_cmdline at problem_app.c:30
 #3 call_function at /usr/src/debug/Python-3.4.2/Python/ceval.c:4263
 #4 PyEval_EvalFrameEx at /usr/src/debug/Python-3.4.2/Python/ceval.c:2860
 #5 fast_function at /usr/src/debug/Python-3.4.2/Python/ceval.c:4360
 #6 call_function at /usr/src/debug/Python-3.4.2/Python/ceval.c:4288
 #7 PyEval_EvalFrameEx at /usr/src/debug/Python-3.4.2/Python/ceval.c:2860
 #8 fast_function at /usr/src/debug/Python-3.4.2/Python/ceval.c:4360
 #9 call_function at /usr/src/debug/Python-3.4.2/Python/ceval.c:4288

Comment 1 info@kobaltwit.be 2015-10-27 20:39:35 UTC
Created attachment 1087043 [details]
File: backtrace

Comment 2 info@kobaltwit.be 2015-10-27 20:39:36 UTC
Created attachment 1087044 [details]
File: cgroup

Comment 3 info@kobaltwit.be 2015-10-27 20:39:38 UTC
Created attachment 1087045 [details]
File: core_backtrace

Comment 4 info@kobaltwit.be 2015-10-27 20:39:40 UTC
Created attachment 1087046 [details]
File: dso_list

Comment 5 info@kobaltwit.be 2015-10-27 20:39:41 UTC
Created attachment 1087047 [details]
File: environ

Comment 6 info@kobaltwit.be 2015-10-27 20:39:43 UTC
Created attachment 1087048 [details]
File: limits

Comment 7 info@kobaltwit.be 2015-10-27 20:39:45 UTC
Created attachment 1087049 [details]
File: maps

Comment 8 info@kobaltwit.be 2015-10-27 20:39:46 UTC
Created attachment 1087050 [details]
File: mountinfo

Comment 9 info@kobaltwit.be 2015-10-27 20:39:48 UTC
Created attachment 1087051 [details]
File: namespaces

Comment 10 info@kobaltwit.be 2015-10-27 20:39:49 UTC
Created attachment 1087052 [details]
File: open_fds

Comment 11 info@kobaltwit.be 2015-10-27 20:39:50 UTC
Created attachment 1087053 [details]
File: proc_pid_status

Comment 12 info@kobaltwit.be 2015-10-27 20:39:52 UTC
Created attachment 1087054 [details]
File: var_log_messages

Comment 13 info@kobaltwit.be 2015-10-27 20:41:47 UTC
*** Bug 1275774 has been marked as a duplicate of this bug. ***

Comment 14 Jakub Filak 2015-10-27 21:44:26 UTC
Sorry for the inconvenience, this is a bug in libreport. The problem is that you have installed a desktop file for which g_app_info_get_commandline() returns a value that cannot be divided into string tokens delimited by " " by g_strsplit().

https://github.com/abrt/libreport/blob/master/src/gtk-helpers/desktop-utils.c#L219

Comment 15 Jakub Filak 2015-10-28 00:47:25 UTC
Upstream commit https://github.com/abrt/libreport/commit/01204ee26dfd48b734efdf0dd01dd8e87f6a9543 fixes the bug.

Comment 16 info@kobaltwit.be 2015-11-01 17:49:08 UTC
That fixes it indeed on my systems, thanks !

Will this be backported or should I wait for the next release of libreport to get this fix via official channels ?

Comment 17 Matej Habrnal 2016-02-02 10:04:41 UTC
It will be backported to Fedora 22 and released via official channels.

Comment 18 Fedora Update System 2016-02-02 16:13:22 UTC
libreport-2.6.4-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-de4d7b3b1f

Comment 19 Fedora Update System 2016-02-03 23:26:13 UTC
abrt-2.6.1-8.fc22, libreport-2.6.4-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-de4d7b3b1f

Comment 20 Fedora Update System 2016-02-05 00:21:07 UTC
abrt-2.6.1-8.fc22, libreport-2.6.4-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.