Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1296539 (CVE-2016-1570, xsa167) - CVE-2016-1570 xen: PV superpage functionality missing sanity checks
Summary: CVE-2016-1570 xen: PV superpage functionality missing sanity checks
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2016-1570, xsa167
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1300345
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-07 13:24 UTC by Adam Mariš
Modified: 2021-06-02 06:22 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-26 11:52:02 UTC
Embargoed:


Attachments (Terms of Use)
Patch for xen-unstable, Xen 4.6.x, Xen 4.5.x (deleted)
2016-01-07 13:27 UTC, Adam Mariš
no flags Details | Diff
Patch for Xen 4.3.x, 4.4.x (deleted)
2016-01-07 13:28 UTC, Adam Mariš
no flags Details | Diff
Xen 4.6.x (deleted)
2016-01-07 13:28 UTC, Adam Mariš
no flags Details | Diff

Description Adam Mariš 2016-01-07 13:24:46 UTC
It was found that PV superpage functionality lacks certain validity checks on data being passed to the hypervisor by guests. This is the case for the page identifier (MFN) passed to MMUEXT_MARK_SUPER and MMUEXT_UNMARK_SUPER sub-ops of the HYPERVISOR_mmuext_op hypercall as well as for various forms of page table updates.

Use of the feature, which is disabled by default, may have unknown effects, ranging from information leaks through Denial of Service to privilege escalation.

Only systems which enable the PV superpage feature are affected. That is, only systems with an `allowsuperpage' setting on the hypervisor command line. Note that in Xen 4.0.x and 3.4.x the option is named `allowhugepage'. Xen versions 3.4.0, 3.4.1, and from 4.1 onwards are affected. Only x86 systems are affected. Only PV guests can exploit the vulnerability.

Running only HVM guests will avoid this issue. Not enabling PV superpage support (by omitting the `allowsuperpage' or `allowhugepage' hypervisor command line options) will avoid exposing the issue.

Comment 1 Adam Mariš 2016-01-07 13:27:23 UTC
Created attachment 1112460 [details]
Patch for xen-unstable, Xen 4.6.x, Xen 4.5.x

Comment 2 Adam Mariš 2016-01-07 13:28:06 UTC
Created attachment 1112462 [details]
Patch for Xen 4.3.x, 4.4.x

Comment 3 Adam Mariš 2016-01-07 13:28:54 UTC
Created attachment 1112463 [details]
Xen 4.6.x

Comment 5 Andrej Nemec 2016-01-20 14:15:38 UTC
Created xen tracking bugs for this issue:

Affects: fedora-all [bug 1300345]

Comment 6 Andrej Nemec 2016-01-20 14:16:28 UTC
Public via:

http://seclists.org/oss-sec/2016/q1/155

Comment 7 Fedora Update System 2016-01-28 18:24:36 UTC
xen-4.5.2-7.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2016-02-01 06:29:40 UTC
xen-4.5.2-7.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.