Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1299502 - swig breaks ruby tests when building subversion
Summary: swig breaks ruby tests when building subversion
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: swig
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jitka Plesnikova
QA Contact: Fedora Extras Quality Assurance
URL: http://koji.fedoraproject.org/koji/ta...
Whiteboard:
: 1308159 (view as bug list)
Depends On:
Blocks: F24FTBFS
TreeView+ depends on / blocked
 
Reported: 2016-01-18 14:20 UTC by Petr Pisar
Modified: 2016-05-30 21:21 UTC (History)
7 users (show)

Fixed In Version: swig-3.0.8-8.fc25 subversion-1.9.4-3.fc25 swig-3.0.8-7.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-28 02:23:06 UTC
Type: Bug


Attachments (Terms of Use)

Description Petr Pisar 2016-01-18 14:20:17 UTC
subversion-1.9.3-1.fc24 fails to build in F24 because tests fail:

if [ "LD_LIBRARY_PATH" = "DYLD_LIBRARY_PATH" ]; then for d in /builddir/build/BUILD/subversion-1.9.3/subversion/bindings/swig/ruby/libsvn_swig_ruby /builddir/build/BUILD/subversion-1.9.3/subversion/bindings/swig/ruby/../../../libsvn_*; do if [ -n "$DYLD_LIBRARY_PATH" ]; then LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$d/.libs"; else LD_LIBRARY_PATH="$d/.libs"; fi; done; export LD_LIBRARY_PATH; fi; \
cd /builddir/build/BUILD/subversion-1.9.3/subversion/bindings/swig/ruby; \
          if [ "2" -eq 1 -a "2" -lt 9 ] ; then \
            /usr/bin/ruby -I /builddir/build/BUILD/subversion-1.9.3/subversion/bindings/swig/ruby \
              /builddir/build/BUILD/subversion-1.9.3/subversion/bindings/swig/ruby/test/run-test.rb \
      --verbose=verbose; \
          else \
    /usr/bin/ruby -I /builddir/build/BUILD/subversion-1.9.3/subversion/bindings/swig/ruby \
      /builddir/build/BUILD/subversion-1.9.3/subversion/bindings/swig/ruby/test/run-test.rb; \
          fi
Loaded suite test
Started
...............................................................................
...............................................F
===============================================================================
Failure: test_create(SvnFsTest)
/builddir/build/BUILD/subversion-1.9.3/subversion/bindings/swig/ruby/test/test_fs.rb:65:in `assert_create'
/builddir/build/BUILD/subversion-1.9.3/subversion/bindings/swig/ruby/test/test_fs.rb:74:in `test_create'
     71:   end
     72: 
     73:   def test_create
  => 74:     assert_create do |method, args, callback|
     75:       Svn::Fs.__send__(method, *args, &callback)
     76:     end
     77:   end
<Svn::Error::FsAlreadyClose> expected but was
<ObjectPreviouslyDeleted(<Expected argument 0 of type svn_fs_t *, but got SWIG::TYPE_p_svn_fs_t #<SWIG::TYPE_p_svn_fs_t:0x5725...
	in SWIG method 'svn_fs_path'>)>
diff:
+ ObjectPreviouslyDeleted(<Expected argument 0 of type svn_fs_t *, but got SWIG::TYPE_p_svn_fs_t #<SWIG::TYPE_p_svn_fs_t:0x5725...
?     S             vn::Error::FsAlreadyClose
? 	in  WIG method 's  _f         _p   th'>)  
===============================================================================
F
===============================================================================
Failure: test_create_for_backward_compatibility(SvnFsTest)
/builddir/build/BUILD/subversion-1.9.3/subversion/bindings/swig/ruby/test/test_fs.rb:65:in `assert_create'
/builddir/build/BUILD/subversion-1.9.3/subversion/bindings/swig/ruby/test/test_fs.rb:80:in `test_create_for_backward_compatibility'
     77:   end
     78: 
     79:   def test_create_for_backward_compatibility
  => 80:     assert_create do |method, args, callback|
     81:       Svn::Fs::FileSystem.__send__(method, *args, &callback)
     82:     end
     83:   end
<Svn::Error::FsAlreadyClose> expected but was
<ObjectPreviouslyDeleted(<Expected argument 0 of type svn_fs_t *, but got SWIG::TYPE_p_svn_fs_t #<SWIG::TYPE_p_svn_fs_t:0x56a8...
	in SWIG method 'svn_fs_path'>)>
diff:
+ ObjectPreviouslyDeleted(<Expected argument 0 of type svn_fs_t *, but got SWIG::TYPE_p_svn_fs_t #<SWIG::TYPE_p_svn_fs_t:0x56a8...
?     S             vn::Error::FsAlreadyClose
? 	in  WIG method 's  _f         _p   th'>)  
===============================================================================
...................................F
===============================================================================
Failure: test_create(SvnReposTest)
/builddir/build/BUILD/subversion-1.9.3/subversion/bindings/swig/ruby/test/test_repos.rb:110:in `test_create'
     107:     end
     108: 
     109:     assert(repos.closed?)
  => 110:     assert_raises(Svn::Error::ReposAlreadyClose) do
     111:       repos.fs
     112:     end
     113: 
<Svn::Error::ReposAlreadyClose> expected but was
<ObjectPreviouslyDeleted(<Expected argument 0 of type svn_repos_t *, but got SWIG::TYPE_p_svn_repos_t #<SWIG::TYPE_p_svn_repos_t:0x5...
	in SWIG method 'svn_repos_fs_wrapper'>)>
diff:
+ ObjectPreviouslyDeleted(<Expected argument 0 of type svn_repos_t *, but got SWIG::TYPE_p_svn_repos_t #<SWIG::TYPE_p_svn_repos_t:0x5...
?     S             vn::Error::ReposAl   r   eadyClose
? 	in  WIG method 's  _             _fs_w app r'>)    
===============================================================================
..........................................................
Finished in 188.655340304 seconds.
------
222 tests, 5546 assertions, 3 failures, 0 errors, 0 pendings, 0 omissions, 0 notifications
98.6486% passed
------
1.18 tests/s, 29.40 assertions/s
Makefile:923: recipe for target 'check-swig-rb' failed
make: *** [check-swig-rb] Error 1

Difference between working and failing build root is:

        swig 	3.0.7-10.fc24 	> 	3.0.8-1.fc24
	libgcc 	5.3.1-2.fc24 	> 	5.3.1-3.fc24
	gcc 	5.3.1-2.fc24 	> 	5.3.1-3.fc24
	libstdc++ 	5.3.1-2.fc24 	> 	5.3.1-3.fc24
	libgomp 	5.3.1-2.fc24 	> 	5.3.1-3.fc24
	kde-l10n 	15.08.3-1.fc24 	> 	15.08.3-2.fc24
	cpp 	5.3.1-2.fc24 	> 	5.3.1-3.fc24
	kernel-headers 	4.4.0-0.rc8.git0.1.... 	> 	4.4.0-0.rc8.git1.1....
	libstdc++-devel 	5.3.1-2.fc24 	> 	5.3.1-3.fc24
	gcc-gdb-plugin 	5.3.1-2.fc24 	> 	5.3.1-3.fc24
	gcc-c++ 	5.3.1-2.fc24 	> 	5.3.1-3.fc24

Comment 1 Petr Pisar 2016-02-17 12:13:11 UTC
*** Bug 1308159 has been marked as a duplicate of this bug. ***

Comment 2 Yaakov Selkowitz 2016-02-19 02:39:41 UTC
Culprit appears to be swig: https://github.com/swig/swig/issues/602

Comment 3 Jan Kurik 2016-02-24 14:18:12 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Comment 4 Fedora Update System 2016-05-25 20:36:56 UTC
swig-3.0.8-7.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b8a9bd0fae

Comment 5 Fedora Update System 2016-05-26 05:00:57 UTC
swig-3.0.8-7.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b8a9bd0fae

Comment 6 Jitka Plesnikova 2016-05-26 07:19:24 UTC
I backported the patch for the swig issue mention in comment#2. The
reported subversion's errors were solved with this fix.

However, another error appears in subversion. I fixed it by reverting one
of Ruby 2.2 fixes which were removed in release subversion-1.9.4-1.fc25.
I will submit fix for it asap.

  test_load:						F
===============================================================================
Failure: test_load(SvnReposTest)
/builddir/build/BUILD/subversion-1.9.4/subversion/bindings/swig/ruby/test/test_repos.rb:681:in `block (2 levels) in test_load'
     678: 
     679:       dest_path = File.join(@tmp_path, "dest")
     680:       Svn::Repos.create(dest_path) do |repos|
  => 681:         assert_raises(NoMethodError) do
     682:           repos.load_fs(nil)
     683:         end
     684:       end
/builddir/build/BUILD/subversion-1.9.4/subversion/bindings/swig/ruby/svn/util.rb:99:in `svn_repos_create'
/builddir/build/BUILD/subversion-1.9.4/subversion/bindings/swig/ruby/svn/util.rb:99:in `create'
/builddir/build/BUILD/subversion-1.9.4/subversion/bindings/swig/ruby/svn/repos.rb:47:in `create'
/builddir/build/BUILD/subversion-1.9.4/subversion/bindings/swig/ruby/test/test_repos.rb:680:in `block in test_load'
/builddir/build/BUILD/subversion-1.9.4/subversion/bindings/swig/ruby/test/util.rb:242:in `make_context'
/builddir/build/BUILD/subversion-1.9.4/subversion/bindings/swig/ruby/test/test_repos.rb:667:in `test_load'
/builddir/build/BUILD/subversion-1.9.4/subversion/bindings/swig/ruby/test/test-unit-ext/priority.rb:115:in `run'
<NoMethodError> expected but was
<RuntimeError(<can't modify frozen NilClass>)>

Comment 7 Fedora Update System 2016-05-26 11:12:15 UTC
subversion-1.9.4-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fcbb7c0289

Comment 8 Fedora Update System 2016-05-26 16:23:59 UTC
subversion-1.9.4-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d0b6920b34

Comment 9 Fedora Update System 2016-05-26 23:23:31 UTC
subversion-1.9.4-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d0b6920b34

Comment 10 Fedora Update System 2016-05-26 23:28:24 UTC
subversion-1.9.4-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fcbb7c0289

Comment 11 Fedora Update System 2016-05-28 02:23:02 UTC
subversion-1.9.4-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-05-30 21:21:26 UTC
subversion-1.9.4-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2016-05-30 21:21:47 UTC
swig-3.0.8-7.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.