Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1301063 - Review Request: python-congressclient - OpenStack Congress client
Summary: Review Request: python-congressclient - OpenStack Congress client
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Haïkel Guémar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: RDO-MITAKA, RDO-MITAKA-REVIEWS
TreeView+ depends on / blocked
 
Reported: 2016-01-22 13:31 UTC by Marcos
Modified: 2023-09-14 03:16 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-19 20:30:15 UTC
Type: ---
Embargoed:
karlthered: fedora-review+


Attachments (Terms of Use)

Description Marcos 2016-01-22 13:31:19 UTC
Spec URL: http://mferminl.web.cern.ch/mferminl/fedorapkg/python-congressclient/1.2.2/python-congressclient.spec
SRPM URL: http://mferminl.web.cern.ch/mferminl/fedorapkg/python-congressclient/1.2.2/python-congressclient-1.2.2-1.fc23.src.rpm
Description: This is the official client for OpenStack Congress, the open policy project.
Fedora Account System Username: mflobo

I have disabled with_python3 for fedora builds. Please let me know if it is good to enabled again now.

This RPM is for version 1.2.2, which means MITAKA. So, should we build this RPM for FC24 or FC23?

Successful scratch http://koji.fedoraproject.org/koji/taskinfo?taskID=12647817

Comment 1 Upstream Release Monitoring 2016-01-22 14:08:16 UTC
mflobo's scratch build of python-congressclient-1.2.2-1.fc23.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=12648245

Comment 2 Haïkel Guémar 2016-02-03 00:22:20 UTC
Ok, requires updating oslo.log

Comment 3 Haïkel Guémar 2016-02-17 14:13:37 UTC
Upgrading oslo libs has proven to be tricky, I suggest that we package congressclient 1.2.1 which has less requirements.
When F24 will be branched, we'll be able to go back to 1.2.2

Comment 4 Upstream Release Monitoring 2016-03-04 09:29:09 UTC
mflobo's scratch build of python-congressclient-1.2.1-1.fc23.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=13225042

Comment 5 Chandan Kumar 2016-03-04 09:31:40 UTC
Hello mflobo,

Please include the tests subpackage in the spec file.

Thanks,

Chandan Kumar

Comment 6 Upstream Release Monitoring 2016-03-04 10:24:36 UTC
mflobo's scratch build of python-congressclient-1.2.1-1.fc23.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=13225207

Comment 8 Chandan Kumar 2016-03-09 13:19:14 UTC
Hello Marcos,

Thanks for updating the spec.
Below is my comments:
[1.] rename python-%{pypi_name}-tests to python2-%{pypi_name}-tests
[2.] under %package -n python-%{pypi_name}-tests
add Requires:   python2-%{pypi_name} = %{version}-%{release}

[3.] under %package -n python3-%{pypi_name}-tests
add Requires:   python3-%{pypi_name} = %{version}-%{release}

[4.] Please include %check section to invoke tests
like this:

%check
%if 0%{?with_python3}
%{__python3} setup.py test
rm -rf .testrepository
%endif
%{__python2} setup.py test

[5.] under %files -n python-%{pypi_name}
add this line %exclude %{python2_sitelib}/%{pypi_name}/tests

and do same for python3 subpackage.

Rest looks ok to me.

Please update the spec.

Thanks,

Chandan Kumar

Comment 10 Haïkel Guémar 2016-03-09 15:46:39 UTC
All requires in -tests subpackages are broken, you need to put spaces around operators in spec files (known issue in RPM spec file parser). They do not install.
Please, put min versions for pbr in Requires and BuildRequires.

Comment 12 Haïkel Guémar 2016-04-14 21:53:06 UTC
Ok, I had to fix few things
* python-discover is not required anymore (and doesn't exist as a package)
* RPM parser requires that comparison operators are surrounded by spaces which
prevented to install the -tests packages.


I hereby approve the fixed package, here are the fixed spec + src.rpm
Please do the import in Fedora.

SPEC URL: https://hguemar.fedorapeople.org/reviews/python-congressclient.spec
SRPM URL: https://hguemar.fedorapeople.org/reviews/python-congressclient-1.2.1-1.fc25.src.rpm


Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "Apache (v2.0)", "Unknown or generated", "*No copyright* Apache
     (v2.0)". 8 files have unknown license. Detailed output of licensecheck
     in /home/haikel/python-congressclient/review-python-
     congressclient/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 10240 bytes in 1 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

Python:
[x]: Python eggs must not download any dependencies during the build
     process.
[x]: A package which is used by another package via an egg interface should
     provide egg info.
[ ]: Package meets the Packaging Guidelines::Python
[x]: Package contains BR: python2-devel or python3-devel
[x]: Binary eggs must be removed in %prep

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[-]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in
     python2-congressclient , python-congressclient-doc , python2
     -congressclient-tests
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: python2-congressclient-1.2.1-1.fc25.noarch.rpm
          python-congressclient-doc-1.2.1-1.fc25.noarch.rpm
          python2-congressclient-tests-1.2.1-1.fc25.noarch.rpm
          python-congressclient-1.2.1-1.fc25.src.rpm
python2-congressclient.noarch: W: no-manual-page-for-binary congressclient-2
python2-congressclient.noarch: W: no-manual-page-for-binary congressclient-2.7
python2-congressclient.noarch: W: no-manual-page-for-binary congressclient
python2-congressclient-tests.noarch: W: spelling-error Summary(en_US) subpackage -> sub package, sub-package, package's
python2-congressclient-tests.noarch: W: summary-not-capitalized C congressclient test subpackage
python2-congressclient-tests.noarch: W: no-documentation
4 packages and 0 specfiles checked; 0 errors, 6 warnings.




Rpmlint (installed packages)
----------------------------
python2-congressclient.noarch: W: no-manual-page-for-binary congressclient-2
python2-congressclient.noarch: W: no-manual-page-for-binary congressclient-2.7
python2-congressclient.noarch: W: no-manual-page-for-binary congressclient
python2-congressclient-tests.noarch: W: spelling-error Summary(en_US) subpackage -> sub package, sub-package, package's
python2-congressclient-tests.noarch: W: summary-not-capitalized C congressclient test subpackage
python2-congressclient-tests.noarch: W: no-documentation
3 packages and 0 specfiles checked; 0 errors, 6 warnings.



Requires
--------
python2-congressclient (rpmlib, GLIBC filtered):
    python(abi)
    python-babel
    python-cliff
    python-keystoneclient
    python-oslo-i18n
    python-pbr
    python-requests
    python-six

python2-congressclient-tests (rpmlib, GLIBC filtered):
    python(abi)
    python-coverage
    python-fixtures
    python-mock
    python-oslo-sphinx
    python-sphinx
    python-subunit
    python-testrepository
    python-testscenarios
    python-testtools
    python-webob
    python2-congressclient

python-congressclient-doc (rpmlib, GLIBC filtered):



Provides
--------
python2-congressclient:
    python-congressclient
    python2-congressclient

python2-congressclient-tests:
    python2-congressclient-tests

python-congressclient-doc:
    python-congressclient-doc



Source checksums
----------------
http://pypi.python.org/packages/source/p/python-congressclient/python-congressclient-1.2.1.tar.gz :
  CHECKSUM(SHA256) this package     : 372c8e3e2f476324afc9006bdc2e6e162066fd23c3cac7e7ec774cf2d96c4a34
  CHECKSUM(SHA256) upstream package : 372c8e3e2f476324afc9006bdc2e6e162066fd23c3cac7e7ec774cf2d96c4a34


Generated by fedora-review 0.6.0 (3c5c9d7) last change: 2015-05-20
Command line :/usr/bin/fedora-review -n /home/haikel/python-congressclient/ -m fedora-rawhide-x86_64
Buildroot used: fedora-rawhide-x86_64
Active plugins: Python, Generic, Shell-api
Disabled plugins: Java, C/C++, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP, Ruby
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6

Comment 13 Marcos 2016-04-15 13:52:57 UTC
Hi,

python-congressclient was successfully pushed to master, f24 and epel7 http://pkgs.fedoraproject.org/cgit/rpms/python-congressclient.git/

Koji builds for rawhide (master) and f24 worked fine. For epel7 it failed due to:

"Error: No Package found for python-oslo-sphinx >= 2.3.0"

More info here http://koji.fedoraproject.org/koji/taskinfo?taskID=13670964

Comment 14 Fedora Update System 2016-04-15 15:25:49 UTC
python-congressclient-1.2.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d6abd5312a

Comment 15 Fedora Update System 2016-04-15 23:21:24 UTC
python-congressclient-1.2.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d6abd5312a

Comment 16 Fedora Update System 2016-04-19 20:30:12 UTC
python-congressclient-1.2.1-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Red Hat Bugzilla 2023-09-14 03:16:36 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 1000 days


Note You need to log in before you can comment on or make changes to this bug.