Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1307437 - eclipse-jbosstools: FTBFS in rawhide
Summary: eclipse-jbosstools: FTBFS in rawhide
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-jbosstools
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1206515 (view as bug list)
Depends On:
Blocks: F24FTBFS F23FTBFS
TreeView+ depends on / blocked
 
Reported: 2016-02-13 21:14 UTC by Fedora Release Engineering
Modified: 2016-05-30 18:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-30 18:11:38 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2016-02-13 21:14 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2016-02-13 21:14 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2016-02-13 21:14 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2016-02-13 21:14:42 UTC
Your package eclipse-jbosstools failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12813332

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild

Comment 1 Fedora Release Engineering 2016-02-13 21:14:49 UTC
Created attachment 1124381 [details]
build.log

Comment 2 Fedora Release Engineering 2016-02-13 21:14:53 UTC
Created attachment 1124382 [details]
root.log

Comment 3 Fedora Release Engineering 2016-02-13 21:14:55 UTC
Created attachment 1124383 [details]
state.log

Comment 4 Gerard Ryan 2016-02-14 19:55:31 UTC
I orphaned this a while back, since I don't have time to get it working. FAS user marcusk took it over.

Marcus, I don't see any activity from you to address any of the issues (ftbfs, out-of-date from upstream). Do you intend to fix it?

Comment 5 Gerard Ryan 2016-02-14 19:58:31 UTC
Related: open bug for failure in F23: https://bugzilla.redhat.com/show_bug.cgi?id=1206515

Comment 6 mk 2016-02-14 20:09:12 UTC
It has taken a bit longer than expected but this is something that I am still working on. Some dependencies have changed in the new upstream release so I am currently working on getting openshift-restclient-java packaged (https://bugzilla.redhat.com/show_bug.cgi?id=1302144).

Comment 7 Gerard Ryan 2016-02-14 20:18:53 UTC
Great, thanks for replying! :) I just wanted to make sure that there was something being done, since I also get the daily automated 'broken' mail.

Comment 8 Jan Kurik 2016-02-24 14:38:56 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Comment 9 mk 2016-05-23 23:38:41 UTC
For the past couple of months I've been working on updating the eclipse-jbosstools package to upstream release 4.3. Unfortunately this has not gone as smooth as I initially hoped. While I have been able to get most of the package updated and building the work is not complete. I am still missing a dependency on Eclipse Sapphire which I have so far not been able to successfully package.

One week from today the eclipse-jbosstools package will be automatically retired as part of the final freeze for Fedora 24. I do not expect to complete the update before then and has thus decided to let the package retire. I have published the work so far in a Git repository [1], it might be useful as a starting point if someone is interested in continuing with it at some point. Even if I was able to get the package up to date before the freeze the amount of patching required makes me doubt that I alone will be able to keep it updated and properly maintained going forward.

I recognize that there are a lot of things that I could have done better. To some extent I saw this as a learning exercise in taking over a larger and already established package, but it turned out that maybe I jumped too quickly into the deep end of the pool.

[1] https://fedorapeople.org/cgit/marcusk/public_git/eclipse-jbosstools.git

Comment 10 Fedora Admin XMLRPC Client 2016-05-30 16:19:41 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 11 mk 2016-05-30 18:08:08 UTC
*** Bug 1206515 has been marked as a duplicate of this bug. ***

Comment 12 mk 2016-05-30 18:11:38 UTC
Closing since the package has been retired. Sorry everyone.


Note You need to log in before you can comment on or make changes to this bug.