Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1307765 - maven-license-plugin: FTBFS in rawhide
Summary: maven-license-plugin: FTBFS in rawhide
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: maven-license-plugin
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mikolaj Izdebski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1239668 (view as bug list)
Depends On:
Blocks: F24FTBFS F23FTBFS
TreeView+ depends on / blocked
 
Reported: 2016-02-13 21:51 UTC by Fedora Release Engineering
Modified: 2016-10-03 13:11 UTC (History)
4 users (show)

Fixed In Version: 1.8.0-20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-03 13:11:18 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2016-02-13 21:51 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2016-02-13 21:51 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2016-02-13 21:51 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2016-02-13 21:51:11 UTC
Your package maven-license-plugin failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12834736

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild

Comment 1 Fedora Release Engineering 2016-02-13 21:51:14 UTC
Created attachment 1125356 [details]
build.log

Comment 2 Fedora Release Engineering 2016-02-13 21:51:15 UTC
Created attachment 1125357 [details]
root.log

Comment 3 Fedora Release Engineering 2016-02-13 21:51:16 UTC
Created attachment 1125358 [details]
state.log

Comment 4 Jan Kurik 2016-02-24 14:54:12 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Comment 5 Yaakov Selkowitz 2016-02-25 19:33:57 UTC
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.5:compile (default-compile) on project maven-license-plugin: Compilation failure
[ERROR] /builddir/build/BUILD/maven-license-plugin/src/main/java/com/google/code/mojo/license/util/FileUtils.java:[56,121] incompatible types: java.util.Map<java.lang.Object,java.lang.Object> cannot be converted to java.util.Map<java.lang.String,java.lang.Object>

This code is not compatible with JDK 8.  Any reason not to rebase to the latest upstream 2.x on github?

Comment 6 Raphael Groner 2016-10-03 11:34:36 UTC
*** Bug 1239668 has been marked as a duplicate of this bug. ***

Comment 7 Raphael Groner 2016-10-03 11:38:21 UTC
What's the state here? I can not build jwebunit (see package review ¹) with enabled license check ².

¹ bug 1380942
² https://github.com/JWebUnit/jwebunit/issues/3

Comment 8 Mikolaj Izdebski 2016-10-03 13:03:33 UTC
Fixed in maven-license-plugin-1.8.0-20

Comment 9 Mikolaj Izdebski 2016-10-03 13:04:55 UTC
(In reply to Yaakov Selkowitz from comment #5)
> This code is not compatible with JDK 8.  Any reason not to rebase to the
> latest upstream 2.x on github?

This was incompatibility with our plexus-utils, not Java 8.

Comment 10 Mikolaj Izdebski 2016-10-03 13:11:18 UTC
I believe that this bug is fixed in maven-license-plugin-1.8.0-20,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=806459

This bug was fixed in the next release of Fedora, and it is currently
not planned to be fixed in the release it was filed against.
You can update to the newer release of Fedora to get the fix.


Note You need to log in before you can comment on or make changes to this bug.