Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1307871 - postbooks: FTBFS in rawhide
Summary: postbooks: FTBFS in rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: postbooks
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Pocock
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F24FTBFS
TreeView+ depends on / blocked
 
Reported: 2016-02-13 22:02 UTC by Fedora Release Engineering
Modified: 2016-05-25 00:53 UTC (History)
3 users (show)

Fixed In Version: postbooks-4.9.5-9.fc24 postbooks-4.9.5-9.fc23 postbooks-4.9.5-9.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-25 00:53:41 UTC
Type: ---


Attachments (Terms of Use)
build.log (1.83 MB, text/plain)
2016-02-13 22:02 UTC, Fedora Release Engineering
no flags Details
root.log (101.84 KB, text/plain)
2016-02-13 22:02 UTC, Fedora Release Engineering
no flags Details
state.log (629 bytes, text/plain)
2016-02-13 22:02 UTC, Fedora Release Engineering
no flags Details
Patch to fix the FTBFS (2.11 KB, patch)
2016-03-09 17:33 UTC, Ralf Corsepius
no flags Details | Diff

Description Fedora Release Engineering 2016-02-13 22:02:37 UTC
Your package postbooks failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12857307

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild

Comment 1 Fedora Release Engineering 2016-02-13 22:02:40 UTC
Created attachment 1125674 [details]
build.log

Comment 2 Fedora Release Engineering 2016-02-13 22:02:41 UTC
Created attachment 1125675 [details]
root.log

Comment 3 Fedora Release Engineering 2016-02-13 22:02:42 UTC
Created attachment 1125676 [details]
state.log

Comment 4 Jan Kurik 2016-02-24 14:59:50 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Comment 5 Ralf Corsepius 2016-03-09 17:33:01 UTC
Created attachment 1134591 [details]
Patch to fix the FTBFS

This FTBFS is caused by a seemingly obvious bug in the source code, gcc-6 now treats as an error (cf. attachment).

Unless somebody objects, I will apply this patch in the attachment (against Fedora git master) and build the package in near future.

Comment 6 Daniel Pocock 2016-03-09 17:44:33 UTC
Upstream has fixed this in Github and it will be in the next release.

If this is the only change required and if it matches what upstream has in Github then you are more than welcome to update the package with this patch.

Comment 7 Ralf Corsepius 2016-03-09 18:00:33 UTC
(In reply to Daniel Pocock from comment #6)
> Upstream has fixed this in Github and it will be in the next release.

I can't spot any fix to this bug upstream's git.

Also, 4.9.3 is still failing with same FTBFS:
...
displays/dspBookings.cpp: In member function 'virtual void dspBookings::sViewOrder()':
displays/dspBookings.cpp:163:52: error: no matching function for call to 'salesOrder::viewSalesOrder(int, bool)'
   salesOrder::viewSalesOrder(list()->altId(), false);
...

Comment 8 Daniel Pocock 2016-03-09 18:12:09 UTC
This is the message I received from upstream:

"I have seen this before. It's a bad method call that passes a boolean where a pointer is expected. It's been fixed in 4_10_x by simply removing the 2nd arg to salesOrder::viewSalesOrder() at https://github.com/xtuple/qt-client/blob/v4.9.2/guiclient/displays/dspBookings.cpp#L163"

Maybe it is in the commit from 20 May 2015:

https://github.com/xtuple/qt-client/commits/4_10_x/guiclient/displays/dspBookings.cpp

Comment 9 Gil Moskowitz 2016-03-10 20:01:33 UTC
Upstream sources have been tagged v4.9.4 to address this problem: https://github.com/xtuple/qt-client/releases/tag/v4.9.4
Unlike most xTuple releases, the 4.9.4 client expects to talk to a 4.9.3 database.

Comment 10 Daniel Pocock 2016-03-10 20:41:24 UTC
Gil, thanks for addressing this issue

Ralf, would you possibly have time to fetch 4.9.4 from the tag in Github and see if it builds OK?  I have more travel over the next two weeks for FOSSASIA so I didn't want to upload something today if I won't be able to respond to any other issues that arise.

Comment 11 Upstream Release Monitoring 2016-05-05 11:31:34 UTC
pocock's postbooks-4.9.5-9.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=760247

Comment 12 Fedora Update System 2016-05-06 14:44:29 UTC
postbooks-4.9.5-9.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3f3a320414

Comment 13 Fedora Update System 2016-05-06 14:44:37 UTC
postbooks-4.9.5-9.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fa5678069b

Comment 14 Fedora Update System 2016-05-07 16:55:49 UTC
postbooks-4.9.5-9.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3f3a320414

Comment 15 Fedora Update System 2016-05-07 17:26:59 UTC
postbooks-4.9.5-9.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fa5678069b

Comment 16 Juan Jimenez 2016-05-10 15:37:47 UTC
I can confirm that the package is installed correctly on Fedora 23 using Fedora testing repository. However, program is still unusable due to GUI glitches which hide menus and options (as per reported in bug https://www.xtuple.org/xtincident/view/bugs/27099)

Comment 17 Daniel Pocock 2016-05-11 19:41:13 UTC
Juan, thanks for the feedback.  I haven't ever seen the GUI glitches on Debian, I've asked xTuple if they can comment on why it happens on Fedora.  Is there any chance you could test the F24 update and give feedback in the xTuple bug tracker if you see the same problem?  Did you ever use the packages on F22 or other versions as well?  Please comment further in the xTuple bug tracker as this bug is only for the FTBFS issue.

Comment 18 Fedora Update System 2016-05-16 08:27:22 UTC
postbooks-4.9.5-9.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0c3e0809cd

Comment 19 Fedora Update System 2016-05-16 16:28:57 UTC
postbooks-4.9.5-9.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2016-05-16 22:27:09 UTC
postbooks-4.9.5-9.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2016-05-17 03:53:34 UTC
postbooks-4.9.5-9.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0c3e0809cd

Comment 22 Fedora Update System 2016-05-25 00:53:38 UTC
postbooks-4.9.5-9.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.