Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1311161 - pygit2 fails to import - missing dependency?
Summary: pygit2 fails to import - missing dependency?
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pygit2
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pete Walter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1318263 1339790 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-23 14:25 UTC by Barry Scott
Modified: 2016-07-07 09:49 UTC (History)
10 users (show)

Fixed In Version: python-pygit2-0.24.0-1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-07 09:49:10 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Barry Scott 2016-02-23 14:25:06 UTC
Description of problem:

As non-root python3 import pygit2 fails with:

PermissionError: [Errno 13] Permission denied: '/usr/lib64/python3.4/site-packages/pygit2/__pycache__/pygit2_cffi_6bc76ceexe8494016.c

As root fails with:

>>> import pygit2
/usr/lib64/python3.4/site-packages/pygit2/__pycache__/pygit2_cffi_6bc76ceexe8494016.c:208:18: fatal error: git2.h: No such file or directory
compilation terminated.
Traceback (most recent call last):
  File "/usr/lib64/python3.4/distutils/unixccompiler.py", line 126, in _compile
    extra_postargs)
  File "/usr/lib64/python3.4/distutils/ccompiler.py", line 909, in spawn
    spawn(cmd, dry_run=self.dry_run)
  File "/usr/lib64/python3.4/distutils/spawn.py", line 36, in spawn
    _spawn_posix(cmd, search_path, dry_run=dry_run)
  File "/usr/lib64/python3.4/distutils/spawn.py", line 162, in _spawn_posix
    % (cmd, exit_status))
distutils.errors.DistutilsExecError: command 'gcc' failed with exit status 1


Version-Release number of selected component (if applicable):

python3-pygit2-0.23.0-0.1.fc23.x86_64
libgit2-0.23.4-1.fc23.x86_64

How reproducible:

Make sure that libgit2-devel is not installed before installing python3-pygit2.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

I appears that there is a missing dependency on libgit2-devel that is not automatically installed when pygit2 is installed.

Comment 1 Barry Scott 2016-02-23 14:26:16 UTC
The component is wrong. I could not find python3-pygit2 as a choice.

Comment 2 Petr Viktorin (pviktori) 2016-02-23 14:50:15 UTC
python3-pygit2 is part of the python-pygit2 source package.

Let me know if you need any help related to Python3.

Comment 3 Fedora Admin XMLRPC Client 2016-02-26 17:38:03 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Fedora Admin XMLRPC Client 2016-02-26 18:05:30 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 5 Igor Gnatenko 2016-03-20 14:24:51 UTC
*** Bug 1318263 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2016-03-29 23:04:32 UTC
rubygem-rugged-0.24.0-1.fc24 julia-0.4.5-2.fc24 gnome-builder-3.20.0-1.fc24 gitg-3.20.0-1.fc24 subsurface-4.4.2-5.fc24 python-pygit2-0.24.0-1.fc24 libgit2-glib-0.24.0-2.fc24 libgit2-0.24.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fadc1e6504

Comment 7 Fedora Update System 2016-03-30 22:26:27 UTC
gitg-3.20.0-1.fc24, gnome-builder-3.20.0-1.fc24, julia-0.4.5-2.fc24, kate-15.12.3-2.fc24, kf5-ktexteditor-5.20.0-3.fc24, libgit2-0.24.0-1.fc24, libgit2-glib-0.24.0-2.fc24, python-pygit2-0.24.0-1.fc24, rubygem-rugged-0.24.0-1.fc24, subsurface-4.4.2-5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fadc1e6504

Comment 8 Miro Hrončok 2016-03-30 22:59:14 UTC
F23 please.

Comment 9 Fedora Update System 2016-03-31 20:29:30 UTC
gitg-3.20.0-1.fc24, gnome-builder-3.20.0-1.fc24, julia-0.4.5-2.fc24, kate-15.12.3-2.fc24, kf5-ktexteditor-5.20.0-3.fc24, libgit2-0.24.0-1.fc24, libgit2-glib-0.24.0-2.fc24, python-pygit2-0.24.0-1.fc24, rubygem-rugged-0.24.0-1.fc24, subsurface-4.4.2-5.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Miro Hrončok 2016-04-01 11:30:06 UTC
This was reported as a bug on F23 and closed with build on F24. Reopening.

Comment 11 Fedora Admin XMLRPC Client 2016-04-04 20:31:51 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 12 Fedora Admin XMLRPC Client 2016-04-04 20:42:46 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 13 Igor Gnatenko 2016-05-27 09:06:04 UTC
*** Bug 1339790 has been marked as a duplicate of this bug. ***

Comment 14 Igor Gnatenko 2016-07-07 09:49:10 UTC
Sorry, I can't do anything here. It requires updating to 0.24.x, but it will require rebuild/patch/update of other components.


Note You need to log in before you can comment on or make changes to this bug.