Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1314964 - [gnome-session] user-defined X resources not used in GNOME on Wayland session
Summary: [gnome-session] user-defined X resources not used in GNOME on Wayland session
Keywords:
Status: CLOSED DUPLICATE of bug 1149905
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-session
Version: 25
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-05 08:00 UTC by Joachim Frieben
Modified: 2017-01-18 19:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-18 19:04:37 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Joachim Frieben 2016-03-05 08:00:50 UTC
Description of problem:
X environment variables like XENVIRONMENT and XUSERFILESEARCHPATH defined in $HOME/.login are ignored in a GNOME on Wayland session. Accordingly, any user-defined X resources are ignored when X applications are launched from the application grid.

Version-Release number of selected component (if applicable):
gdm-3.19.90-1.fc24

How reproducible:
Always.

Steps to Reproduce:
1. Start GNOME on Wayland session.
2. Launch X application from the application grid.

Actual results:
X application ignores user-specific X resources.

Expected results:
X application applies user-specific X resources.

Additional info:
- X environment variables are set correctly in a GNOME on Xorg session.
- This issue also applies to current Fedora 23.

Comment 1 Joachim Frieben 2016-03-07 08:54:39 UTC
As a matter of fact, using the C shell, all environment variables set in $HOME/.login or $HOME/.cshrc are being ignored, not only the X related ones.

Comment 2 Joachim Frieben 2017-01-18 19:04:37 UTC

*** This bug has been marked as a duplicate of bug 1149905 ***


Note You need to log in before you can comment on or make changes to this bug.