Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1321200 - docker-compose-1.7.0 is available
Summary: docker-compose-1.7.0 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: docker-compose
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Hampton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1333212 (view as bug list)
Depends On: 1331898
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-25 00:12 UTC by Upstream Release Monitoring
Modified: 2016-05-07 12:09 UTC (History)
4 users (show)

Fixed In Version: docker-compose-1.7.0-1.fc24
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-07 12:09:58 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (20.33 KB, patch)
2016-04-14 00:13 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2016-03-25 00:12:59 UTC
Latest upstream release: 1.7.0-rc1
Current version/release in rawhide: 1.6.2-1.fc25
URL: https://github.com/docker/compose

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/6185/

Comment 1 Upstream Release Monitoring 2016-03-25 00:13:04 UTC
Rebase helper failed.
See logs and attachments in this bugzilla 

  RAN: '/usr/bin/git clone http://pkgs.fedoraproject.org/cgit/docker-compose.git /var/tmp/thn-rhq1QPBR'

  STDOUT:
Cloning into '/var/tmp/thn-rhq1QPBR'...


  STDERR:
fatal: repository 'http://pkgs.fedoraproject.org/cgit/docker-compose.git/' not found

Comment 2 Upstream Release Monitoring 2016-04-14 00:13:09 UTC
Latest upstream release: 1.7.0
Current version/release in rawhide: 1.6.2-1.fc25
URL: https://github.com/docker/compose

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/6185/

Comment 3 Upstream Release Monitoring 2016-04-14 00:13:22 UTC
Patching or scratch build for docker-compose-1.6.2 failed.

Comment 4 Upstream Release Monitoring 2016-04-14 00:13:24 UTC
Created attachment 1146999 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.

Comment 5 Upstream Release Monitoring 2016-04-14 00:13:25 UTC
Following patches has been deleted:
['remove-requires-upper-bound.patch']

Comment 6 Upstream Release Monitoring 2016-04-14 00:13:27 UTC
Following patches has been unapplied:
['remove-requires-upper-bound.patch']

Comment 7 Upstream Release Monitoring 2016-04-14 01:30:17 UTC
error's docker-compose-1.7.0-1.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=754181

Comment 8 Fedora Update System 2016-04-14 01:52:03 UTC
docker-compose-1.7.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8b7bbf12ab

Comment 9 Fedora Update System 2016-04-14 02:29:54 UTC
docker-compose-1.7.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4ea3b9fb42

Comment 10 Fedora Update System 2016-04-15 08:37:50 UTC
docker-compose-1.7.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8b7bbf12ab

Comment 11 Fedora Update System 2016-04-16 19:26:45 UTC
docker-compose-1.7.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4ea3b9fb42

Comment 12 Jan Pazdziora 2016-04-19 11:35:13 UTC
There seems to be https://github.com/docker/compose/issues/3342 present in docker-compose-1.7.0-1.fc23:

Traceback (most recent call last):
  File "/usr/bin/docker-compose", line 9, in <module>
    load_entry_point('docker-compose==1.7.0', 'console_scripts', 'docker-compose')()
  File "/usr/lib/python2.7/site-packages/compose/cli/main.py", line 57, in main
    command()
  File "/usr/lib/python2.7/site-packages/compose/cli/main.py", line 105, in perform_command
    project = project_from_options('.', options)
  File "/usr/lib/python2.7/site-packages/compose/cli/command.py", line 31, in project_from_options
    environment=environment
  File "/usr/lib/python2.7/site-packages/compose/cli/command.py", line 76, in get_project
    host=host, environment=environment
  File "/usr/lib/python2.7/site-packages/compose/cli/command.py", line 49, in get_client
    environment=environment
  File "/usr/lib/python2.7/site-packages/compose/cli/docker_client.py", line 52, in docker_client
    kwargs = kwargs_from_env(environment=environment)
TypeError: kwargs_from_env() got an unexpected keyword argument 'environment'

Comment 13 Jan Pazdziora 2016-04-19 12:21:37 UTC
We seem to need python-docker-py 1.8 built for Fedora 23.

Comment 14 Michael Hampton 2016-05-05 04:46:26 UTC
*** Bug 1333212 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2016-05-07 12:09:55 UTC
docker-compose-1.7.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.