Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1323540 - [abrt] clementine: logging::MessageHandler(): clementine killed by SIGABRT
Summary: [abrt] clementine: logging::MessageHandler(): clementine killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: clementine
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Grulich
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:0987a8c4df42ab2809c169f28a2...
: 1341279 1344370 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-04 01:24 UTC by jacob
Modified: 2016-09-15 07:29 UTC (History)
14 users (show)

Fixed In Version: clementine-1.3.1-2.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-28 10:23:39 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (deleted)
2016-04-04 01:25 UTC, jacob
no flags Details
Migrate from FTS3 to FTS4 (deleted)
2016-05-26 23:44 UTC, Real Name
no flags Details | Diff
Just change the tokenizer from unicode to unicode61 (deleted)
2016-05-27 23:40 UTC, Real Name
no flags Details | Diff
Enable the FTS3 custom tokenizer at runtime (deleted)
2016-05-30 09:18 UTC, Real Name
no flags Details | Diff

Description jacob 2016-04-04 01:24:44 UTC
Description of problem:
The program crash when i try to start it

Version-Release number of selected component:
clementine-1.3.0-0.4.rc1.fc24

Additional info:
reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        clementine /home/yeicob/Downloads/alice/aliceinwonderlandinwordsofonesyllable_01_gorham_64kb.mp3
crash_function: logging::MessageHandler
executable:     /usr/bin/clementine
global_pid:     2897
kernel:         4.5.0-302.fc24.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 logging::MessageHandler at /usr/src/debug/clementine-1.3.0rc1/ext/libclementine-common/core/logging.cpp:96
 #3 qt_message_output at global/qglobal.cpp:2369
 #4 qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) at global/qglobal.cpp:2469
 #5 qFatal at global/qglobal.cpp:2652
 #6 Database::ExecSongTablesCommands at /usr/src/debug/clementine-1.3.0rc1/src/core/database.cpp:533
 #7 Database::ExecSchemaCommands at /usr/src/debug/clementine-1.3.0rc1/src/core/database.cpp:501
 #8 Database::ExecSchemaCommandsFromFile at /usr/src/debug/clementine-1.3.0rc1/src/core/database.cpp:483
 #9 Database::UpdateDatabaseSchema at /usr/src/debug/clementine-1.3.0rc1/src/core/database.cpp:446
 #10 Database::UpdateMainSchema at /usr/src/debug/clementine-1.3.0rc1/src/core/database.cpp:346
 #11 Database::Connect at /usr/src/debug/clementine-1.3.0rc1/src/core/database.cpp:303

Potential duplicate: bug 862092

Comment 1 jacob 2016-04-04 01:25:42 UTC
Created attachment 1143146 [details]
File: backtrace

Comment 2 Rex Dieter 2016-04-23 22:04:37 UTC
Similar problem has been detected:

Pretty simple, install clementine, try to start it the first time.  Crashes.  :(

reporter:       libreport-2.7.0
backtrace_rating: 4
cmdline:        clementine
crash_function: logging::MessageHandler
executable:     /usr/bin/clementine
global_pid:     5187
kernel:         4.5.1-300.fc24.x86_64
package:        clementine-1.3.1-1.fc24
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reason:         clementine killed by SIGABRT
reproducible:   Not sure how to reproduce the problem
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 3 Rex Dieter 2016-04-23 22:05:36 UTC
I reproduced with clementine-1.3.1-1.fc24 from
https://bodhi.fedoraproject.org/updates/FEDORA-2016-396e222c76

Comment 4 Iaroslav Prokopenko 2016-05-01 08:20:54 UTC
Similar problem has been detected:

Clementine crashes just after startup.
--verbose command line option adds no additional information

$ clementine --verbose
11:16:57.180 ERROR unknown                          Unable to update music library database

reporter:       libreport-2.7.0
backtrace_rating: 4
cmdline:        clementine
crash_function: logging::MessageHandler
executable:     /usr/bin/clementine
global_pid:     12794
kernel:         4.5.2-302.fc24.x86_64
package:        clementine-1.3.1-1.fc24
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reason:         clementine killed by SIGABRT
reproducible:   The problem occurs regularly
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 5 Filipe Rosset 2016-05-10 04:15:26 UTC
Similar problem has been detected:

run clementine w/ strace from command line

open("/home/filiperosset/.config/Clementine/clementine.db-journal", O_RDWR|O_CREAT|O_CLOEXEC, 0644) = 15
fstat(15, {st_mode=S_IFREG|0644, st_size=4640, ...}) = 0
geteuid()                               = 1000
fstat(15, {st_mode=S_IFREG|0644, st_size=4640, ...}) = 0
open("/dev/urandom", O_RDONLY|O_CLOEXEC) = 19
read(19, "\335\236\372S\240\320\2148\3\10\245ry\262\245<H\264D\250\324\274\373\7z\371\226\201\257\317`\247"..., 256) = 256
close(19)                               = 0
lseek(15, 0, SEEK_SET)                  = 0
write(15, "\0\0\0\0\0\0\0\0\0\0\0\0K\301N:\0\0\0\r\0\0\2\0\0\0\4\0\0\0\0\0"..., 512) = 512
lseek(15, 512, SEEK_SET)                = 512
write(15, "\0\0\0\f", 4)                = 4
lseek(15, 516, SEEK_SET)                = 516
write(15, "\r\0\0\0\2\0<\0\0\315\0<\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 1024) = 1024
lseek(15, 1540, SEEK_SET)               = 1540
write(15, "K\301Ol", 4)                 = 4
lseek(15, 1544, SEEK_SET)               = 1544
write(15, "\0\0\0\1", 4)                = 4
lseek(15, 1548, SEEK_SET)               = 1548
write(15, "SQLite format 3\0\4\0\1\1\0@  \0\0\0\r\0\0\0\r"..., 1024) = 1024
lseek(15, 2572, SEEK_SET)               = 2572
write(15, "K\301N:", 4)                 = 4
lseek(15, 2576, SEEK_SET)               = 2576
write(15, "\0\0\0\5", 4)                = 4
lseek(15, 2580, SEEK_SET)               = 2580
write(15, "\r\0\0\0\2\0H\0\3\216\0H\3)\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 1024) = 1024
lseek(15, 3604, SEEK_SET)               = 3604
write(15, "K\301O\306", 4)              = 4
lseek(15, 3608, SEEK_SET)               = 3608
write(15, "\0\0\0\6", 4)                = 4
lseek(15, 3612, SEEK_SET)               = 3612
write(15, "\r\2L\0\5\0=\0\3\233\0033\2\233\0=\0\334\0\324\0\0\0\0\0\0\0\0\0\0\0\0"..., 1024) = 1024
lseek(15, 4636, SEEK_SET)               = 4636
write(15, "K\301N\210", 4)              = 4
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2015, ...}) = 0
write(2, "01:03:44.525 ERROR unknown      "..., 9301:03:44.525 ERROR unknown                          Unable to update music library database 
) = 93
rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
tgkill(7902, 7902, SIGABRT)             = 0
--- SIGABRT {si_signo=SIGABRT, si_code=SI_TKILL, si_pid=7902, si_uid=1000} ---
+++ killed by SIGABRT (core dumped) +++

reporter:       libreport-2.7.0
backtrace_rating: 4
cmdline:        clementine
crash_function: logging::MessageHandler
executable:     /usr/bin/clementine
global_pid:     7841
kernel:         4.5.3-300.fc24.x86_64
package:        clementine-1.3.1-1.fc24
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reason:         clementine killed by SIGABRT
reproducible:   Not sure how to reproduce the problem
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 6 Filipe Rosset 2016-05-17 23:59:02 UTC
steps to reproduce (rawhide)

rm -rf .config/Clementine
rm -rf .cache/Clementine

run clementine from command line

source file: src/core/database.cpp



20:43:20.669 ERROR unknown                          Unable to update music library database 
==30007== 
==30007== Process terminating with default action of signal 6 (SIGABRT): dumping core
==30007==    at 0xC63A635: raise (in /usr/lib64/libc-2.23.90.so)
==30007==    by 0xC63C239: abort (in /usr/lib64/libc-2.23.90.so)
==30007==    by 0xADF252: logging::MessageHandler(QtMsgType, char const*) (in /home/filiperosset/rpmbuild/extras/clementine/a/clementine-1.3.1/bla/clementine)
==30007==    by 0x7532855: qt_message_output(QtMsgType, char const*) (in /usr/lib64/libQtCore.so.4.8.7)
==30007==    by 0x7532A40: ??? (in /usr/lib64/libQtCore.so.4.8.7)
==30007==    by 0x7533360: qFatal(char const*, ...) (in /usr/lib64/libQtCore.so.4.8.7)
==30007==    by 0x5EC5C5: Database::ExecSongTablesCommands(QSqlDatabase&, QStringList const&, QStringList const&) (in /home/filiperosset/rpmbuild/extras/clementine/a/clementine-1.3.1/bla/clementine)
==30007==    by 0x5EDB4B: Database::ExecSchemaCommands(QSqlDatabase&, QString const&, int, bool) (in /home/filiperosset/rpmbuild/extras/clementine/a/clementine-1.3.1/bla/clementine)
==30007==    by 0x5EEBC3: Database::ExecSchemaCommandsFromFile(QSqlDatabase&, QString const&, int, bool) (in /home/filiperosset/rpmbuild/extras/clementine/a/clementine-1.3.1/bla/clementine)
==30007==    by 0x5EED13: Database::UpdateDatabaseSchema(int, QSqlDatabase&) (in /home/filiperosset/rpmbuild/extras/clementine/a/clementine-1.3.1/bla/clementine)
==30007==    by 0x5EF257: Database::UpdateMainSchema(QSqlDatabase*) (in /home/filiperosset/rpmbuild/extras/clementine/a/clementine-1.3.1/bla/clementine)
==30007==    by 0x5F055F: Database::Connect() (in /home/filiperosset/rpmbuild/extras/clementine/a/clementine-1.3.1/bla/clementine)
==30007== 
==30007== HEAP SUMMARY:
==30007==     in use at exit: 5,255,851 bytes in 64,174 blocks
==30007==   total heap usage: 214,478 allocs, 150,304 frees, 15,507,484 bytes allocated
==30007== 
==30007== LEAK SUMMARY:
==30007==    definitely lost: 2,560 bytes in 4 blocks
==30007==    indirectly lost: 14,714 bytes in 609 blocks
==30007==      possibly lost: 30,037 bytes in 251 blocks
==30007==    still reachable: 5,001,372 bytes in 62,113 blocks
==30007==                       of which reachable via heuristic:
==30007==                         length64           : 1,424,160 bytes in 370 blocks
==30007==                         newarray           : 6,168 bytes in 40 blocks
==30007==                         multipleinheritance: 304 bytes in 1 blocks
==30007==         suppressed: 0 bytes in 0 blocks
==30007== Rerun with --leak-check=full to see details of leaked memory
==30007== 
==30007== For counts of detected and suppressed errors, rerun with: -v
==30007== ERROR SUMMARY: 0 errors from 0 contexts (suppressed: 0 from 0)
Killed

Comment 7 Egor Zakharov 2016-05-21 19:15:55 UTC
Similar problem has been detected:

Just installed it using GNOME Software and started it up.

And:
$ clementine
22:00:55.531 ERROR unknown                          Unable to update music library database 
Aborted (core dumped)

reporter:       libreport-2.7.0
backtrace_rating: 4
cmdline:        clementine
crash_function: logging::MessageHandler
executable:     /usr/bin/clementine
global_pid:     4046
kernel:         4.5.4-300.fc24.x86_64
package:        clementine-1.3.1-1.fc24
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reason:         clementine killed by SIGABRT
reproducible:   Not sure how to reproduce the problem
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 8 Real Name 2016-05-26 23:43:23 UTC
Clementine uses FTS3, and SQLite 3.11, the version shipped with F24, has it disabled due to security concerns, so Clementine cannot create a new database nor can it modify an existing one (it will still start if you have an existing database, but it won't be able to add new songs to the library).

I wrote a (somewhat unrefined) patch that makes it work again by using FTS4 instead of FTS3, since Fedora's SQLite also has FTS5 disabled. (It's disabled by default in upstream as well.) So far, so good.

The other option would be to rebuild sqlite3 with -DSQLITE_ENABLE_FTS3_TOKENIZER, but I don't know if this would be accepted. Maybe I should try asking.

Comment 9 Real Name 2016-05-26 23:44:36 UTC
Created attachment 1162306 [details]
Migrate from FTS3 to FTS4

Comment 10 Real Name 2016-05-27 23:40:01 UTC
Created attachment 1162564 [details]
Just change the tokenizer from unicode to unicode61

Oh, well. I should have tested the SQL statements in the shell before jumping to conclusions. For the record, SQLite is disabling by default just the custom tokenizer, not FTS3 itself, but Clementine doesn't seem to need it anyway.

Comment 11 Real Name 2016-05-28 15:08:06 UTC
After the last sqlite update, and with the latest patch I attached, Clementine may seem to be broken again, but this time it's just a matter of deleting jamendo.db in your ~/.config/Clementine directory (it spits out an error about a duplicate column and bail out). You need a debug build to see that, though.

Comment 12 Jan Grulich 2016-05-30 06:40:07 UTC
I asked SQLite packagers to include newer version of SQLite into Fedora 24, which means that we can use SQLITE_DBCONFIG_ENABLE_FTS3_TOKENIZER option to sqlite3_db_config() to enable FTS3 custom tokenizer at runtime. What do you think? I would prefer trying to find a way arround this without a need to delete jamendo.db in users home directory.

Comment 13 Real Name 2016-05-30 09:16:55 UTC
(In reply to Jan Grulich from comment #12)
> I asked SQLite packagers to include newer version of SQLite into Fedora 24,
> which means that we can use SQLITE_DBCONFIG_ENABLE_FTS3_TOKENIZER option to
> sqlite3_db_config() to enable FTS3 custom tokenizer at runtime. What do you
> think? I would prefer trying to find a way arround this without a need to
> delete jamendo.db in users home directory.

Assuming I didn't mess anything up while testing, I don't think they'll have a choice.

Comment 14 Real Name 2016-05-30 09:18:59 UTC
Created attachment 1162739 [details]
Enable the FTS3 custom tokenizer at runtime

This patch was taken from here: https://github.com/clementine-player/Clementine/issues/5297#issuecomment-196211148 I didn't try it, though.

Comment 15 Real Name 2016-05-30 21:07:55 UTC
I've just rebuilt Clementine with the patch on #14 and it worked. Reinstating the statu quo might be better for users than my approach of potentially breaking databases apart.

Comment 16 Fedora Update System 2016-05-31 10:00:44 UTC
clementine-1.3.1-2.fc24 sqlite-3.12.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3d4c0d27b6

Comment 17 Fedora Update System 2016-05-31 10:00:54 UTC
clementine-1.3.1-2.fc24 sqlite-3.12.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3d4c0d27b6

Comment 18 Jan Grulich 2016-06-01 07:33:02 UTC
*** Bug 1341279 has been marked as a duplicate of this bug. ***

Comment 19 Fedora Update System 2016-06-01 08:29:34 UTC
clementine-1.3.1-2.fc24, sqlite-3.12.2-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3d4c0d27b6

Comment 20 Jan Grulich 2016-06-09 15:00:21 UTC
*** Bug 1344370 has been marked as a duplicate of this bug. ***

Comment 21 Peter Janes 2016-06-25 20:20:05 UTC
The testing repo version of Clementine doesn't depend on the testing repo version of sqlite, i.e. it still crashes if sqlite isn't updated.  However, if both are installed it does work.

Comment 22 Fedora Update System 2016-06-28 10:23:34 UTC
clementine-1.3.1-2.fc24, sqlite-3.12.2-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Kevin Benko 2016-09-10 15:36:24 UTC
Similar problem has been detected:

I tried to start the application, via a left-click and the dang thing crashed.

reporter:       libreport-2.7.1
backtrace_rating: 4
cmdline:        clementine
crash_function: __signbit
executable:     /usr/bin/clementine
global_pid:     2956
kernel:         4.5.5-300.fc24.x86_64
package:        clementine-1.3.1-1.fc24
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reason:         clementine killed by SIGABRT
reproducible:   Not sure how to reproduce the problem
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 24 Real Name 2016-09-10 16:40:45 UTC
(In reply to Kevin Benko from comment #23)
> Similar problem has been detected:
> 
> I tried to start the application, via a left-click and the dang thing
> crashed.
> 
> reporter:       libreport-2.7.1
> backtrace_rating: 4
> cmdline:        clementine
> crash_function: __signbit
> executable:     /usr/bin/clementine
> global_pid:     2956
> kernel:         4.5.5-300.fc24.x86_64
> package:        clementine-1.3.1-1.fc24
> pkg_fingerprint: 73BD E983 81B4 6521
> pkg_vendor:     Fedora Project
> reason:         clementine killed by SIGABRT
> reproducible:   Not sure how to reproduce the problem
> runlevel:       N 5
> type:           CCpp
> uid:            1000

Update your packages. The bug has been fixed in clementine-1.3.1-2.


Note You need to log in before you can comment on or make changes to this bug.