Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1333391 - python3-breathe sphinx extension doesn't work
Summary: python3-breathe sphinx extension doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-breathe
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dave Johansen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1333385 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-05 12:13 UTC by Jan Včelák
Modified: 2017-02-14 15:48 UTC (History)
2 users (show)

Fixed In Version: python-breathe-4.2.0-3.fc23 python-breathe-4.2.0-3.el7 python-breathe-4.2.0-3.fc24 python-breathe-4.2.0-3.fc22 python-breathe-4.4.0-2.fc25
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-13 22:21:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Jan Včelák 2016-05-05 12:13:29 UTC
Description of problem:

When using 

The Breathe extension for Sphinx has some incompatibilities with Python 3.

Version-Release number of selected component (if applicable):
python3-breathe-4.2.0-2.fc24.noarch

How reproducible:
always

Steps to Reproduce:
1. use breathe as a sphinx extension
2.
3.

Actual results:

Exception occurred:
  File "/usr/lib/python3.5/site-packages/breathe/renderer/target.py", line 36, in create_target_handler
    if options.has_key("no-link"):
AttributeError: 'dict' object has no attribute 'has_key'

another one

Exception occurred:
  File "/usr/lib/python3.5/site-packages/breathe/renderer/base.py", line 92, in get_domain
    if type(node) == unicode or node.node_type == "enumvalue":
NameError: name 'unicode' is not defined

...

Expected results:
The build passes.

Additional info:

The problems are hopefully fixed upstream. I've noticed the following commit. I'm not sure if it applies cleanly on Fedora package.

https://github.com/michaeljones/breathe/commit/a0587f035202e4f6b4eb02ad5a2f33ce93bd0f25

Comment 1 Jan Včelák 2016-05-05 12:15:35 UTC
*** Bug 1333385 has been marked as a duplicate of this bug. ***

Comment 2 Dave Johansen 2016-05-14 05:01:09 UTC
I applied the linked to patch.

Comment 3 Fedora Update System 2016-05-14 16:06:41 UTC
python-breathe-4.2.0-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-5a909b7d5a

Comment 4 Fedora Update System 2016-05-14 16:06:44 UTC
python-breathe-4.2.0-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c887e40f9a

Comment 5 Fedora Update System 2016-05-14 16:06:48 UTC
python-breathe-4.2.0-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-bc9a1af498

Comment 6 Fedora Update System 2016-05-14 16:06:53 UTC
python-breathe-4.2.0-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-22eb4981dd

Comment 7 Fedora Update System 2016-05-16 23:57:10 UTC
python-breathe-4.2.0-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c887e40f9a

Comment 8 Fedora Update System 2016-05-17 03:24:42 UTC
python-breathe-4.2.0-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-5a909b7d5a

Comment 9 Fedora Update System 2016-05-17 03:53:58 UTC
python-breathe-4.2.0-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-22eb4981dd

Comment 10 Fedora Update System 2016-05-17 04:25:00 UTC
python-breathe-4.2.0-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-bc9a1af498

Comment 11 Jan Včelák 2016-05-19 12:21:15 UTC
Applying just the one patch doesn't work. The package is still incompatible with Python 3.

I'm encountering this problem when building Knot Resolver documentation:

$ git clone https://gitlab.labs.nic.cz/knot/resolver.git
$ cd resolver
$ make doc sphinx-build_BIN=/usr/bin/sphinx-build-3
...
Running Sphinx v1.3.1
loading pickled environment... not yet created
building [mo]: targets for 0 po files that are out of date
building [html]: targets for 6 source files that are out of date
updating environment: 6 added, 0 changed, 0 removed
reading sources... [ 66%] lib                                                                                          
Exception occurred:
  File "/usr/lib/python3.5/site-packages/breathe/renderer/base.py", line 92, in get_domain
    if type(node) == unicode or node.node_type == "enumvalue":
NameError: name 'unicode' is not defined
The full traceback has been saved in /tmp/fcelda/sphinx-err-6x_k5uf4.log, if you want to report the issue to the developers.
Please also report this if it was a user error, so that a better error message can be provided next time.
A bug report can be filed in the tracker at <https://github.com/sphinx-doc/sphinx/issues>. Thanks!
doc/doc.mk:5: recipe for target 'doc-html' failed
make: *** [doc-html] Error 1

Comment 12 Dave Johansen 2016-05-19 16:36:21 UTC
I don't have the time/interest to get this working, so if you point me to a patch that fixes it, then I'd be glad to apply it to the current version. Otherwise, it will just have to wait until upstream releases a version that is fully compatible with Python 3.

Comment 13 Fedora Update System 2016-07-09 23:54:42 UTC
python-breathe-4.2.0-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2016-07-10 02:22:33 UTC
python-breathe-4.2.0-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2016-07-10 06:01:03 UTC
python-breathe-4.2.0-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Dave Johansen 2016-07-10 15:45:36 UTC
Reopening the bug because the issue is not fully resolved.

Comment 17 Fedora Update System 2016-07-12 02:23:50 UTC
python-breathe-4.2.0-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Dave Johansen 2016-07-12 15:27:47 UTC
Sorry, I thought all of the updates had been pushed. Re-opening again.

Comment 19 Dave Johansen 2016-12-20 05:37:42 UTC
Rawhide (F26) was updated to 4.4.0 ( https://koji.fedoraproject.org/koji/taskinfo?taskID=16987057 ).

Comment 20 Petr Špaček 2017-01-23 19:29:58 UTC
Unfortunatelly python3-breathe-4.2.0-3.fc25.noarch still does not work for me on Fedora 25.

I've verified that upstream version 4.4.0 installed from pip works fine. Could you please provide 4.4.0 package for Fedora 25?

Thank you!

Comment 21 Fedora Update System 2017-01-24 03:35:41 UTC
python-breathe-4.4.0-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-3dd793333f

Comment 22 Fedora Update System 2017-01-28 19:19:23 UTC
python-breathe-4.4.0-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3dd793333f

Comment 23 Fedora Update System 2017-02-13 22:21:53 UTC
python-breathe-4.4.0-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2017-02-14 15:48:35 UTC
python-breathe-4.4.0-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.