Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1333905 - Please package version 5.6.10 of aqbanking to solve Comdirect issue
Summary: Please package version 5.6.10 of aqbanking to solve Comdirect issue
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: aqbanking
Version: 25
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-06 15:41 UTC by Eric Lavarde
Modified: 2016-11-07 23:27 UTC (History)
3 users (show)

Fixed In Version: aqbanking-5.6.12-1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 23:27:35 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Eric Lavarde 2016-05-06 15:41:41 UTC
Description of problem:
In a nutshell, certain Comdirect accounts can't be retrieved anymore, whereas they could in the past.
See https://devel.aqbanking.de/trac/aqbanking/ticket/237 and https://devel.aqbanking.de/trac/aqbanking/ticket/249 for more details (https://devel.aqbanking.de/trac/aqbanking/ticket/237#comment:6 is from me and in English)

Version-Release number of selected component (if applicable):
5.5.1

How reproducible:
Always

Steps to Reproduce:
1. try to retrieve transactions from certain Comdirect accounts

Actual results:
Aqbanking complains that the account doesn't support certain transactions (I don't go into the details because the solution is obvious, upgrade to the next version :-P).

Expected results:
Account transactions can be downloaded.

Additional info:

According to https://devel.aqbanking.de/trac/aqbanking/ticket/237#comment:10 the issue is solved in version 5.6.5beta respectively 5.6.10.0 (see http://www2.aquamaniac.de/sites/download/packages.php?showall=1#03)

The bug is urgent because I can't download my transactions and they disappear after 90 days.

Comment 1 Bill Nottingham 2016-05-06 18:12:31 UTC
There is a report on gnucash-user of 5.6.10 breaking online banking in GnuCash entirely. Will require some investigation.

Comment 2 Eric Lavarde 2016-05-09 09:36:45 UTC
A limited backport of the one fix impacting me would be gratefully taken, but, yeah, better test thoroughly before releasing a broken package.
(for the records, I'm using KMyMoney, let me know if you need some end-user testing for any "beta" package)

Comment 3 Bill Nottingham 2016-07-08 02:21:24 UTC
Sorry about the awful delay.

Coming to rawhide tomorrow-ish.

Comment 4 Bill Nottingham 2016-07-08 03:55:32 UTC
aqbanking-5.6.10-1.fc25
kmymoney-4.7.2-5.fc25

I tested it briefly in GnuCash with an online account and it was OK.

Comment 5 Eric Lavarde 2016-07-09 08:10:14 UTC
I've installed those packages on top of my fc24:

# dnf install fedora-repos-rawhide
# dnf install kmymoney aqbanking --enablerepo rawhide
[...]
Upgraded:
  aqbanking.x86_64 5.6.10-1.fc25         kmymoney.x86_64 4.7.2-5.fc25           
  kmymoney-doc.noarch 4.7.2-5.fc25       kmymoney-libs.x86_64 4.7.2-5.fc25      

and it looks OK so far: the first account sync went wrong like before, but the 2nd one seems to have worked (there was a remark somewhere that account capabilities are updated _after_ a sync).

Only _seems_ because I've got some strange duplicates of entries and accounts, but I think that's not related (got those before, even if they look really tough this time).

Need to go, but I keep you posted once I've progressed on my tests.

Comment 6 Jan Kurik 2016-07-26 04:50:46 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 7 Yaakov Selkowitz 2016-08-29 21:17:17 UTC
aqbanking-5.6.12 is available now.

Comment 8 Fedora Update System 2016-11-05 04:23:47 UTC
gnucash-2.6.14-1.fc24 kmymoney-4.7.2-5.fc24 aqbanking-5.6.12-1.fc24 gwenhywfar-4.15.3-2.fc24 gnucash-docs-2.6.14-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-29e231710b

Comment 9 Fedora Update System 2016-11-06 01:53:17 UTC
aqbanking-5.6.12-1.fc24, gnucash-2.6.14-1.fc24, gnucash-docs-2.6.14-1.fc24, gwenhywfar-4.15.3-2.fc24, kmymoney-4.7.2-5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-29e231710b

Comment 10 Fedora Update System 2016-11-07 23:27:35 UTC
aqbanking-5.6.12-1.fc24, gnucash-2.6.14-1.fc24, gnucash-docs-2.6.14-1.fc24, gwenhywfar-4.15.3-2.fc24, kmymoney-4.7.2-5.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.