Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1334407 - Conflict with python-SocksiPy
Summary: Conflict with python-SocksiPy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pysocks
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ralph Bean
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-09 14:26 UTC by Gwyn Ciesla
Modified: 2016-07-27 20:53 UTC (History)
3 users (show)

Fixed In Version: python-pysocks-1.5.6-4.fc24 python-pysocks-1.5.6-4.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-20 00:19:49 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Gwyn Ciesla 2016-05-09 14:26:59 UTC
python2-pysocks conflicts with python-SocksiPy:

Error: Transaction check error:
  file /usr/lib/python2.7/site-packages/socks.py from install of python2-pysocks-1.5.6-2.fc23.noarch conflicts with file from package python-SocksiPy-1.00-11.fc23.noarch
  file /usr/lib/python2.7/site-packages/socks.pyc from install of python2-pysocks-1.5.6-2.fc23.noarch conflicts with file from package python-SocksiPy-1.00-11.fc23.noarch
  file /usr/lib/python2.7/site-packages/socks.pyo from install of python2-pysocks-1.5.6-2.fc23.noarch conflicts with file from package python-SocksiPy-1.00-11.fc23.noarch


Is this fork intended to be a replacement?

https://fedoraproject.org/wiki/Packaging:Guidelines#Renaming.2FReplacing_Existing_Packages

Comment 1 Ralph Bean 2016-05-09 15:32:39 UTC
Oh, I see.. there's a typo in the python-pysocks specfile.

It specifies a conflict with python3-SocksiPy, mistakenly:  http://pkgs.fedoraproject.org/cgit/rpms/python-pysocks.git/commit/?id=733ebbd83270de7fc8bed19bf4191ffb34e7d769

Therefore, the conflict is implicit (when it was meant to be explicit).  There is in fact a conflict.

Do you think the conflict (if I change it to be explicit) is warranted by https://fedoraproject.org/wiki/Packaging:Conflicts ?  If not, should we file for an exception?

Comment 2 Gwyn Ciesla 2016-05-09 15:42:06 UTC
I would either Conflicts: explicitly, or Obsoletes/Provides if it's intended to be a drop-in replacement and you've worked that out with the python-SocksiPy maintainer.

Disclaimer, I know nothing of either codebase, including reasons for the fork or why a project would choose one or the other.

Comment 3 James Boyle 2016-05-11 16:13:17 UTC
I'm also experiencing this error:

# dnf clean packages ; dnf clean all ; dnf -y upgrade

Delta RPMs reduced 423.4 MB of updates to 150.3 MB (64.1% saved)
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/lib/python2.7/site-packages/socks.py from install of python2-pysocks-1.5.6-2.fc23.noarch conflicts with file from package python-SocksiPy-1.00-11.fc23.noarch
  file /usr/lib/python2.7/site-packages/socks.pyc from install of python2-pysocks-1.5.6-2.fc23.noarch conflicts with file from package python-SocksiPy-1.00-11.fc23.noarch
  file /usr/lib/python2.7/site-packages/socks.pyo from install of python2-pysocks-1.5.6-2.fc23.noarch conflicts with file from package python-SocksiPy-1.00-11.fc23.noarch

Comment 4 Gwyn Ciesla 2016-07-15 17:29:22 UTC
Seeing this now as well, same root cause:

package python2-requests-2.10.0-2.fc24.noarch requires python-urllib3 = 1.15.1, but none of the providers can be installed

Comment 5 Fedora Update System 2016-07-15 17:47:50 UTC
python-pysocks-1.5.6-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d7ed60de99

Comment 6 Fedora Update System 2016-07-15 17:47:56 UTC
python-pysocks-1.5.6-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-341729fc3c

Comment 7 Fedora Update System 2016-07-15 17:48:01 UTC
python-pysocks-1.5.6-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ada5ffd6b3

Comment 8 Gwyn Ciesla 2016-07-15 17:54:21 UTC
Works, thank you!

Comment 9 Ralph Bean 2016-07-15 18:03:22 UTC
\รณ/

Comment 10 Fedora Update System 2016-07-16 22:57:26 UTC
python-pysocks-1.5.6-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d7ed60de99

Comment 11 Fedora Update System 2016-07-17 02:22:37 UTC
python-pysocks-1.5.6-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ada5ffd6b3

Comment 12 Fedora Update System 2016-07-17 16:23:25 UTC
python-pysocks-1.5.6-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-341729fc3c

Comment 13 Fedora Update System 2016-07-20 00:19:47 UTC
python-pysocks-1.5.6-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2016-07-27 20:53:39 UTC
python-pysocks-1.5.6-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.