Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1374028 - [mutter] causes failure of Wayland in virtual guest session
Summary: [mutter] causes failure of Wayland in virtual guest session
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 25
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-07 17:55 UTC by Joachim Frieben
Modified: 2016-09-26 14:27 UTC (History)
8 users (show)

Fixed In Version: mutter-3.21.92-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-24 13:55:10 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
System journal file (deleted)
2016-09-07 18:03 UTC, Joachim Frieben
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1266484 0 unspecified CLOSED spice + fedora wayland VM + spice-vdagent + resize-guest == flickering display 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1375504 0 unspecified CLOSED VM screen is often black after boot in gnome-boxes 2021-02-22 00:41:40 UTC

Internal Links: 1266484 1375504

Description Joachim Frieben 2016-09-07 17:55:52 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Joachim Frieben 2016-09-07 18:03:51 UTC
Created attachment 1198792 [details]
System journal file

Comment 2 Joachim Frieben 2016-09-07 18:10:47 UTC
Description of problem:
When running current Fedora 25 in a virtual box by means of GNOME Boxes, Xorg is used by the graphical login manager GDM and also after a GNOME on Wayland session has been initiated.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xwayland-1.18.4-5.fc25

How reproducible:
Always

Steps to Reproduce:
1. Launch a Fedora 25 guest session in GNOME Boxes.

Actual results:
Xorg is used by the graphical login manager GDM and also by a GNOME on Wayland session.

Expected results:
Xwayland is used instead of Xorg.


Additional info:
Things used to work as expected until recently.

Comment 3 Joachim Frieben 2016-09-07 18:42:33 UTC
Live image Fedora-Workstation-Live-x86_64-25-20160904.n.0 was not affected by this issue yet.

Comment 4 Olivier Fourdan 2016-09-09 14:57:48 UTC
gdm decides/choose which session (x11/Wayland) to run, not the X server.

=> Moving to gdm

Comment 5 Ray Strode [halfline] 2016-09-09 15:17:57 UTC
we don't offer a GNOME on Wayland session in Fedora 25. Are you sure you see it?  In F25, the two options are "GNOME" and "GNOME on Xorg".  The former is either wayland or xorg depending on if WaylandEnable=true or WaylandEnable=false in /etc/gdm/custom.config.  There is also some fail safe logic to make that option pick Xorg if wayland doesn't seem to work for the login screen.

Comment 6 Joachim Frieben 2016-09-09 21:06:33 UTC
(In reply to Ray Strode [halfline] from comment #5)
I had written "GNOME on Wayland" session without explicitly referring to the session denomination used by GDM. The corresponding session type in Fedora 25 is "GNOME".
As mentioned above, the issue becomes apparent already when GDM appears on the screen: because of bug 1266484, GDM used to show heavy flicker when running in a virtual machine, e.g. try booting from live image Fedora-Workstation-Live-x86_64-25-20160904.n.0. Switching to a virtual console and checking the relevant processes for later live images confirmed that a process Xorg was running instead of the expected process Xwayland.
Finally, I had provided attachment 1198792 [details] for a reason, namely, it exhibits a number of error messages, e.g.:

"(EE) failed to dispatch Wayland events: Connection reset by peer".

Comment 7 Joachim Frieben 2016-09-09 21:38:04 UTC
Too bad I upgraded my host system from Fedora 24 to Fedora 25 yesterday; right now, both of Fedora-Workstation-Live-x86_64-25-20160904.n.0 and Fedora-Workstation-Live-x86_64-25-20160907.n.0 do boot into the default "GNOME" session running Xwayland (the comment about GDM referred to fresh system installed using the corresponding live media). Nevertheless, I will leave this bug report open until I have the opportunity to recheck against a Fedora 24 host system.

Comment 8 Joachim Frieben 2016-09-10 20:53:37 UTC
This regression has been introduced by upgrading mutter-3.21.90-3.fc25 to mutter-3.21.91-1.fc25. This can be verified by updating mutter after booting from a recent live image.
Downgrading mutter restores correct behaviour; on a fully updated Fedora 25 system this requires to also downgrade gnome-shell plus extensions.

Comment 9 Joachim Frieben 2016-09-11 09:08:02 UTC
There a now two live images available which include different versions of package mutter and exhibit the issue without any further action by merely booting from the latter in gnome-boxes:
1. Fedora-Workstation-Live-x86_64-25-20160907.n.0 (mutter-3.21.90-3.fc25): Xwayland session.
2. Fedora-Workstation-Live-x86_64-25-20160910.n.0 (mutter-3.21.91-1.fc25): Xorg session.

Comment 10 Kamil Páral 2016-09-19 13:28:25 UTC
mutter-3.21.92-1.fc25 is not pushed yet:
https://bodhi.fedoraproject.org/updates/FEDORA-2016-78efe5595f

Comment 11 Joachim Frieben 2016-09-21 12:00:02 UTC
(In reply to Kamil Páral from comment #10)
This bug is not subject to https://bodhi.fedoraproject.org/updates/FEDORA-2016-78efe5595f which does not even mention bug 1374028. As a consequence, no bodhi notification was added to this bug report.

Comment 12 Kamil Páral 2016-09-26 14:27:00 UTC
This seems to be resolved with Fedora-Workstation-Live-x86_64-25-20160925.n.0.iso. Boots into Wayland in Boxes and virt-manager.


Note You need to log in before you can comment on or make changes to this bug.