Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1376181 - quanta+ is not starting anymore under Fedora 24
Summary: quanta+ is not starting anymore under Fedora 24
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs3
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-14 19:21 UTC by Martin
Modified: 2016-10-09 09:22 UTC (History)
6 users (show)

Fixed In Version: kdelibs3-3.5.10-76.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-09 06:21:11 UTC
Type: Bug


Attachments (Terms of Use)

Description Martin 2016-09-14 19:21:41 UTC
Description of problem: quanta+ hangs at the splash-screen with 100% (25% with my i5-2500) CPU-Usage


Version-Release number of selected component (if applicable):
kdewebdev.x86_64 6:3.5.10-27.fc24 

How reproducible:
Every time

Steps to Reproduce:
1.Start quanta+
2.
3.

Actual results:
Freeze at splash-screen

Expected results:
It should start ;-)

Additional info:
With F21, it was ok. Then later with update to F24, it freezes.
I also installed a new F24 on a fresh harddisk, same there.

Comment 1 Amaro R. Silva 2016-09-16 01:18:39 UTC
I get the same behavior. From a shell

>quanta
kbuildsycoca running...
Invalid entry (empty key) at /usr/share/apps/quanta/doc/php.docrc:186
Invalid entry (empty key) at /usr/share/apps/quanta/doc/php.docrc:187
Invalid entry (empty key) at /usr/share/apps/quanta/doc/php.docrc:188
Invalid entry (empty key) at /usr/share/apps/quanta/doc/php.docrc:189
Invalid entry (empty key) at /usr/share/apps/quanta/doc/php.docrc:190
Invalid entry (empty key) at /usr/share/apps/quanta/doc/php.docrc:191
Invalid entry (empty key) at /usr/share/apps/quanta/doc/php.docrc:192
Invalid entry (empty key) at /usr/share/apps/quanta/doc/php.docrc:193
Invalid entry (empty key) at /usr/share/apps/quanta/doc/php.docrc:194
Invalid entry (empty key) at /usr/share/apps/quanta/doc/php.docrc:224
^C

then a banner for Quanta+ displays and nothing happens, htop shows one CPU at 100% load until quanta is killed.

Comment 2 Denys Vlasenko 2016-09-18 23:00:49 UTC
I see the same on Rawhide. Freshly installed quanta, on xfce4 desktop, on start shows the same messages as in prev comment, then it sits spinning on one CPU. strace -p PID shows nothing (must be spinning in userspace). Attached with gdb and backtrace shows this:

(gdb) bt
#0  0x00007fb1dc630110 in KSVGIconPainter::drawPath(QString const&, bool) () from /usr/lib64/libkdecore.so.4
#1  0x00007fb1dc628301 in KSVGIconEngineHelper::handleTags(QDomElement, bool) () from /usr/lib64/libkdecore.so.4
#2  0x00007fb1dc6284f4 in KSVGIconEngineHelper::handleTags(QDomElement, bool) () from /usr/lib64/libkdecore.so.4
#3  0x00007fb1dc624ea8 in KSVGIconEngine::load(int, int, QString const&) () from /usr/lib64/libkdecore.so.4
#4  0x00007fb1dc575acd in KIconLoader::loadIcon(QString const&, KIcon::Group, int, int, QString*, bool) const () from /usr/lib64/libkdecore.so.4
#5  0x00007fb1dc5766fb in SmallIcon(QString const&, int, int, KInstance*) () from /usr/lib64/libkdecore.so.4
#6  0x00005651d3bda8b1 in QuantaInit::initActions() ()
#7  0x00005651d3bf9b21 in QuantaInit::initQuanta() ()
#8  0x00005651d3bfd491 in KQApplicationPrivate::init() ()
#9  0x00005651d3bfd9c0 in KQApplication::KQApplication() ()
#10 0x00005651d3ba7939 in main ()

Comment 3 Than Ngo 2016-09-28 09:36:17 UTC
it looks like a bug in kdelibs3, reassign to kdelibs3. still investigating...

Comment 4 Kevin Kofler 2016-09-28 11:32:00 UTC
Looks like this the old KDE 3 KSVG choking on some new icon. What icon theme are you using? Breeze?

Comment 5 Than Ngo 2016-09-28 14:42:13 UTC
indeed it happens with the breeze icontheme, but works fine with oxygen icontheme.
Kevin, Maybe we should make kdelibs3 only using default.kde* instead.

Comment 6 Than Ngo 2016-09-28 15:19:00 UTC
it's fixed in kdelibs3-3.5.10-76.fc26. I will do update for f24.
http://koji.fedoraproject.org/koji/taskinfo?taskID=15846763

Comment 7 Kevin Kofler 2016-09-28 16:17:08 UTC
Your build failed. I fixed it and also did some trivial specfile cleanups.

Comment 8 Martin 2016-09-28 16:37:01 UTC
Hi people,

many thanks for your work!

Best regards
Martin

Comment 9 Kevin Kofler 2016-09-28 17:17:47 UTC
Now it's building for F24, but the build still fails for F25/Rawhide due to a CUPS incompatibility (error: 'cupsGetPPD' was not declared in this scope), I'm looking into it. (I think there is some #define you have to set to enable that deprecated API now, I've seen it in some code.)

Comment 10 Kevin Kofler 2016-09-28 17:20:55 UTC
It's actually just a header to add:
http://mirror.git.trinitydesktop.org/cgit/tdelibs/commit/?id=52a1b55368ec53b14347996851aca7eb29374397

Comment 11 Rex Dieter 2016-09-28 17:25:54 UTC
beat me to it, I had to fix kde-print-manager recently the same way

Comment 12 Kevin Kofler 2016-09-28 17:32:20 UTC
kdelibs3-3.5.10-76.fc23 and kdelibs3-3.5.10-76.fc24 built successfully. The FTBFS on F25/Rawhide (CUPS 2.2) should be fixed in kdelibs3-3.5.10-77.fc25 and kdelibs3-3.5.10-77.fc26, now building.

Comment 14 Fedora Update System 2016-09-29 01:52:09 UTC
kdelibs3-3.5.10-76.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9b73db090b

Comment 15 Fedora Update System 2016-09-29 02:49:14 UTC
kdelibs3-3.5.10-76.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4fbd73a4d8

Comment 16 Fedora Update System 2016-09-29 15:22:10 UTC
kdelibs3-3.5.10-77.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-afda6b5846

Comment 17 Fedora Update System 2016-10-09 02:47:46 UTC
kdelibs3-3.5.10-77.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2016-10-09 06:21:11 UTC
kdelibs3-3.5.10-76.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2016-10-09 09:22:32 UTC
kdelibs3-3.5.10-76.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.